LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-10-2018, 02:50 AM   #1
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Rep: Reputation: 0
cmst broke my internet connection


Today, out of sheer curiosity, I installed cmst application. It turned out to be a huge mistake.
Because it was not useful to me, I removed cmst immediately after installing it. I could not have imagined that this small experiment will cause me so much headache.

Now I have no internet access anymore. My PC does connect to the router, I can access my NAS directories and files, but nothing form the WWW gets through. There is a question mark in the notification area, where WiFi icon is supposed to be.

I managed to find this command line workaround, that enables the WWW access:
Code:
[root@E7440-DELL home]# ping -c 2 www.google.com
ping: www.google.com: Name or service not known
[root@E7440-DELL home]# ifconfig -a
eno1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 34:e6:d7:16:c1:2e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf7e00000-f7e20000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 772  bytes 60832 (59.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 772  bytes 60832 (59.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.221  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::3f5:5f8e:81ff:da74  prefixlen 64  scopeid 0x20<link>
        ether 80:19:34:71:8e:e6  txqueuelen 1000  (Ethernet)
        RX packets 139  bytes 20774 (20.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 122  bytes 15067 (14.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[root@E7440-DELL home]# dhclient wlp2s0
[root@E7440-DELL home]# ping -c 2 www.google.com
PING www.google.com (216.58.212.132) 56(84) bytes of data.
64 bytes from ams15s21-in-f4.1e100.net (216.58.212.132): icmp_seq=1 ttl=57 time=27.4 ms
64 bytes from ams15s21-in-f4.1e100.net (216.58.212.132): icmp_seq=2 ttl=57 time=27.3 ms

--- www.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 27.389/27.399/27.410/0.165 ms
[root@E7440-DELL home]#
Still, every time I boot my PC, no internet...
Each time I must use `dhclient wlp2s0` in order to get the internet access.

Does anyone know what got broken, and how to fix it?

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
I just discovered that google search on cmst gives a lot of options, such as:
  • Centre for MicroSystems Technology
  • Certified Manager of Software Testing
  • Certified Master Safe Technician
  • Cornwall Music Service Trust
  • Computational Methods in Science and Technology
  • and many others...

So, in case you don't know which cmst is to blame. It is none of the above, but this one:
Code:
[root@E7440-DELL home]# dnf info cmst
Last metadata expiration check: 9:31:49 ago on Wed 10 Oct 2018 12:17:55 AM CEST.
Available Packages
Name         : cmst
Version      : 2018.01.06
Release      : 1.gitd6ee8f8.fc27
Arch         : x86_64
Size         : 2.2 M
Source       : cmst-2018.01.06-1.gitd6ee8f8.fc27.src.rpm
Repo         : updates
Summary      : A Qt based GUI front end for the connman connection manager with systemtray icon
URL          : https://github.com/andrew-bibb/cmst
License      : MIT
Description  : Qt GUI for Connman with system tray icon. The program provides graphical user
             : interface to control the connman daemon. The connman daemon must be started as
             : you normally would, this program just interfaces with that daemon.
             : You can see what technologies and services connman has found, and for wifi
             : services an agent is registered to assist in obtaining the information from
             : you necessary to logon the wifi service.

[root@E7440-DELL home]#

Last edited by blnl; 10-10-2018 at 03:07 AM.
 
Old 10-10-2018, 02:40 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,620

Rep: Reputation: 140Reputation: 140
You check which script start WiFi DHCP client. It look like that DHCP client is started too early.
 
Old 10-10-2018, 02:55 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,479

Rep: Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994
Try:
Code:
# systemctl enable connman && systemctl start connman
Should work then.
 
Old 10-11-2018, 10:24 AM   #4
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by AwesomeMachine View Post
Try:
Code:
# systemctl enable connman && systemctl start connman
Should work then.
I have done the following:
Code:
[root@E7440-DELL home]# systemctl status connman
\u25cf connman.service - Connection service
   Loaded: loaded (/usr/lib/systemd/system/connman.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
[root@E7440-DELL home]# systemctl enable connman && systemctl start connman
Created symlink /etc/systemd/system/multi-user.target.wants/connman.service \u2192 /usr/lib/systemd/system/connman.service.
[root@E7440-DELL home]# systemctl status connman
\u25cf connman.service - Connection service
   Loaded: loaded (/usr/lib/systemd/system/connman.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-10-11 16:57:58 CEST; 4s ago
 Main PID: 3081 (connmand)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/connman.service
           \u2514\u25003081 /usr/sbin/connmand -n

Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {update} flags 36866 <DOWN>
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {newlink} index 3 address CE:A8:DB:A8:9B:00 mtu 1500
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {newlink} index 3 operstate 2 <DOWN>
Oct 11 16:57:59 E7440-DELL connmand[3081]: get_nfs_server_ip: Cannot split pnp at file "/proc/net/pnp"
Oct 11 16:57:59 E7440-DELL connmand[3081]: get_nfs_server_ip: Cannot split pnp at file "/proc/net/pnp"
Oct 11 16:57:59 E7440-DELL connmand[3081]: Adding interface wlp2s0 [ wifi ]
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {RX} 2034 packets 1480079 bytes
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {TX} 1928 packets 345688 bytes
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {newlink} index 3 address CE:A8:DB:A8:9B:00 mtu 1500
Oct 11 16:57:59 E7440-DELL connmand[3081]: wlp2s0 {newlink} index 3 operstate 2 <DOWN>
Unfortunately, it did not help. Now my system starts with WiFi turned off.
Code:
[root@E7440-DELL home]# iwconfig wlp2s0
wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
After turning on WiFi, still must use `dhclient wlp2s0` to get access to the internet. I'm disabling the connman service.
 
Old 10-11-2018, 11:00 AM   #5
blnl
Member
 
Registered: Nov 2009
Location: The Netherlands
Distribution: Fedora
Posts: 89

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nini09 View Post
You check which script start WiFi DHCP client. It look like that DHCP client is started too early.
I don't know if this is the right way to fix it, but after adding `dhclient wlp2s` in /etc/sysconfig/network everything works fine.
Code:
[root@E7440-DELL home]# cat /etc/sysconfig/network
# Created by anaconda
NETWORKING=yes

dhclient wlp2s0
 
Old 10-11-2018, 02:53 PM   #6
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,620

Rep: Reputation: 140Reputation: 140
It is hardly to say whether is right way. The cmst package damage WiFi module. We don't know what's original but we can use this way to fix the issue at least.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Who Broke the Internet? LXer Syndicated Linux News 1 11-09-2011 02:43 AM
[SOLVED] I broke my wireless connection... Unable to get IP address Robert.Thompson Slackware 4 02-15-2011 03:32 PM
Initng broke internet SnowSurfAir Linux - Software 1 03-18-2006 09:54 PM
internet broke Craigwd Debian 9 09-02-2004 01:39 PM
Trying to compile 2.6 broke net connection Tyir Slackware 3 01-15-2004 02:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration