LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-12-2018, 05:14 AM   #1
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 116

Rep: Reputation: 43
Brightness function keys not working on Slackware64 & Slackware64 current


I have a problem with brightness function keys on my Lenovo laptop. They are not working with Slackware64 14.2 or Slackware64 current.

I've tried some possible solutions suggested online (such as appending different settings to lilo.conf), but to no avail. However, when I tried Alien Bob's Slackware64 live plasma5 current, I've found that everything is working out of the box.

Would anybody have an idea what could be the exact cause of this difference, so I could configure my Slackware64 current installation the same way?
 
Old 01-12-2018, 06:45 PM   #2
SqdnGuns
Senior Member
 
Registered: Aug 2005
Distribution: Slackware64 Current w/Alien's Plasma
Posts: 1,003

Rep: Reputation: 99
What model do you have??

Works perfectly fine on my T450s and T550 with -Current and Xfce / Mate, also loaded up Plasma5 and zero issues.

Last edited by SqdnGuns; 01-12-2018 at 06:46 PM.
 
1 members found this post helpful.
Old 01-12-2018, 07:39 PM   #3
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: 43
It's Ideapad 520s. I gave a chance to Xfce too, it didn't help. Which kernel do you use? I tried Slackware64 14.2 and Slackware64 current, using default (huge) kernel with both.

I'm using Alien's Slackware live at the moment. It's Plasma 5 version, but it's the same with the other live versions, they too do OK with brightness Fn keys. I installed it to HDD and everything works well, but I'm afraid I can't use slackpkg to upgrade all packages without breaking something (or everything).
 
Old 01-13-2018, 02:15 AM   #4
cgorac
Member
 
Registered: Oct 2009
Posts: 115

Rep: Reputation: 54
Usually I get problems of this type resolved by following advice from corresponding ThinkWiki page.
 
1 members found this post helpful.
Old 01-13-2018, 03:02 AM   #5
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 2,519

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Code:
sbin/lspci -nnkk | grep -iA2 VGA
Any difference with loaded acpi modules between the Slackware versions?
Code:
lsmod|grep acpi
Boot parameter comparison between working and non-working versions?
Code:
cat /proc/cmdline
 
1 members found this post helpful.
Old 01-13-2018, 10:27 AM   #6
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: 43
Meanwhile I installed the latest Slackware64 current. The idea was to check for parameters ferrari suggested earlier and to compare with those found in Slackware live. However, after installing this version, Fn keys worked as they should be. So, the problem disappeared somewhere between the October version of Slackware64 current (it's what I had before I installed Slackware live) and the latest Slackware64 current update. Thank you all for your suggestions!
 
Old 01-14-2018, 12:30 AM   #7
Fat_Elvis
Member
 
Registered: Oct 2016
Distribution: FreeDOS 1.2
Posts: 206

Rep: Reputation: 54
For future reference, the little program xev(1) is very handy for detecting things like dead keys and buttons. It basically prints all input events received by X. Helpfun for finding out the correct strings for X configuration files as well.
 
1 members found this post helpful.
Old 01-15-2018, 05:27 AM   #8
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 116

Original Poster
Rep: Reputation: 43
Quote:
Originally Posted by Fat_Elvis View Post
For future reference, the little program xev(1) is very handy for detecting things like dead keys and buttons. It basically prints all input events received by X. Helpfun for finding out the correct strings for X configuration files as well.
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware64-current, xorg-1.14, kernel 3.10.11, bumblebee not working Clementine Jam Slackware 6 09-13-2013 11:14 AM
[SOLVED] slackpkg upgrade-all is not working in slackware64-current foobarz Slackware 1 08-13-2012 02:55 PM
Nvidia driver not working on my Slackware64 current bdahz Slackware 11 05-09-2011 04:37 AM
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 07:50 PM
Screen brightness control function keys not working. Gargle Slackware 5 07-22-2007 06:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration