LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Closed Thread
  Search this Thread
Old 08-12-2018, 10:13 AM   #1
panpo
LQ Newbie
 
Registered: Aug 2018
Distribution: Slackware
Posts: 3

Rep: Reputation: Disabled
Problems with UTF-8 characters after installing the multilib in 14.2


Hi,

I am experiencing some problems when I type UTF-8 characters. I have an issue with nvi, vim and less.

With nvi, if I type a non-ascii character, the program exited with the message: "Aborted (core dumped)".

With vim, non-ascii characters are not properly rendered. For example, the "é" character is inserted as "é ", "€" as "�~B�", etc. I have the same problem with elvis.

With less, some UTF-8 are print in hex value, for exemple, "é" is printed as "<C3><A9>".

Other informations :

- I am running Slackware 14.2,
- I have commented the "export LANG=en_US" line in /etc/profile.d/lang.sh file and uncommented the "export LANG=en_US.UTF-8" line,
- when I have installed the multilib, I did it with slackpkg+ but I seleccted the wrong slackware version. I
installed the multilib for -current. So I tried to remove it install the 14.2 one instead,
- I have a quick fix for those problems:

Code:
# slackpkg upgrade-all
# slackpkg upgrade multilib
# slackpkg install multilib
But I did not find when and why the problem appears again. Is there a way to fix it?

Thanks !
 
Old 08-13-2018, 09:39 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,477

Rep: Reputation: 990Reputation: 990Reputation: 990Reputation: 990Reputation: 990Reputation: 990Reputation: 990Reputation: 990
It generally annoys people when you duplicate question posts.

Are you opening those in xterms, or runlevel 3 before you start X?
I would try a different codepage, perhaps 850 instead of 437 and look at the bash profile settings. You seem to be fond of Vi clones, though not vim. For xterms, there's also ~/.bashrc.
For those matters the general line of attack is 'keep messing about with adjustments until you're satifsfied, then stop.' I would also go through the individual program's config.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with UTF-8 characters after installing the multilib on 14.2 panpo Slackware 2 08-13-2018 03:16 PM
gimp text and utf characters dokkalf Slackware 2 09-14-2014 11:18 PM
[SOLVED] How do I write special characters in UTF-8? Advice Pro Linux - Newbie 2 09-08-2011 03:42 AM
[SOLVED] MySQL, UTF-8 and accented characters Tinkster Linux - Software 15 02-03-2010 11:45 AM
How to input non-utf characters from utf-8 linux enviroment? jadas Linux - General 6 02-07-2009 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration