LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 01-08-2018, 04:29 PM   #1
maelcum
LQ Newbie
 
Registered: Jan 2018
Distribution: slackware
Posts: 4

Rep: Reputation: 0
Post slack14.2 - getting tagfiles to work...


Hello, my name is Wolf from Germany and I am a newbie... <:*|

I'm currently making my first steps with slackware. slackwarearm-14.2 that would be, on different Raspberry Pi versions (1 and 3) as well as slackware64-14.2 in VMs on macOS and Windows.

My goal is to replace raspbian/debian on the RPis with a minimal installation. A GUI is not necessary, so usually only the A, AP, D, L and N packages are installed. That works nicely and without a hitch, but could be slimmed down by leaving out things.

This customization of the installation could be done with tagfiles, I've learned. There are the two options in the SELECT PROMPTING MODE of setup: "custom" ad "tagpath".
I cannot, for the life of me, get this to work. Here I would be very grateful for a hint of what to look for, an URL to some in-depth instructions (or even a newbie guided tutorial)...



What have I tried?

To verify that tagfiles _are_ the way to go, I've set up a mirror of a ftp server and edited the ".../?/tagfile".
This works. \o/

I've copied and edited the ".../?/tagfile" to ".../?/tagfile.srv" and tried the "custom" prompting mode, entering ".srv" (without quotes) in the dialog.
This did not work.

I've copied all tagfiles in their respective directory unter ex: "slackware64-14.2/tagfiles/a/tagfile" and tried the "tagpath" prompting mode, entering "slackware64-14.2" as path (and all other ways I could think of that would make sense).
This did not work.

I've copied the "tagfiles"-directory to "slackware64-14.2/slackware64/" and tried the "tagpath" prompting mode again, again with all possible ways of "spelling".
This did not work.

The "tagfiles"-directory was copied to an NFS share. Then a VM was booted from the installation ISO. Instead of doing "setup", "pxesetup" was used, and the network started (DHCP). pxesetup was exited and after verification that the network was working, a /mnt/nfs-directory was created and the NFS share was mounted. It was verified that the NFS-mount was working and that it was possible to 'cd' to the tagfiles-directory on the external mount. Noted the pwd. Now setup was started, the tagpath prompting mode selected and the noted path entered.
This did not work.


Summary:
The only thing currently working is a local mirror where the tagfiles are edited directly.
This allows for only one configuration. All other options to not work. Sorry for the long post, but I wanted to give as much information as possible...
Any advice for me?
 
Old 01-09-2018, 12:10 AM   #2
lilianfornea
Member
 
Registered: Jul 2017
Location: Stauceni, Chisinau, Moldova
Distribution: Slackware, NuTyX
Posts: 37

Rep: Reputation: 7
Slackware Minimum Install - YouTube Tutorial

Slackware Series: Episode 07 - custom installation tagsets and CLI-fu - 1 and half hour tut...
 
Old 01-09-2018, 01:55 AM   #3
maelcum
LQ Newbie
 
Registered: Jan 2018
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks lilianfornea!

I've watched the second YT video. If somebody has basic shell knowledge, skip to
- 50:00 to see what he is doing (making an iso from his modified tagfiles)
- 1:05:00 to see him mounting the iso (after booting setup) and
- 1:09:15 to see him use the prompting option tagfiles and entering the path to his mounted iso.
Beyond that, there is nothing more related to tagfiles.

Unfortunately that does not solve the problem on my side. Maybe it's a difference between freeslack (what is used in the video) and vanilla slackware, though I doubt it.
I'll keep trying. There is surprisingly little documentation about this (that I've found so far)...
 
Old 01-10-2018, 08:46 PM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,226

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Did you try this wiki?
https://www.slackwiki.com/Tagfile_Install
(replacing all instances of slackware directory name with slackware64 for slackware 64bits version)
https://www.slackbook.org/html/packa...-tagfiles.html

Last edited by keefaz; 01-10-2018 at 08:48 PM.
 
Old 01-11-2018, 03:49 AM   #5
maelcum
LQ Newbie
 
Registered: Jan 2018
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
more details about custom-option not working

Hello keefaz,

thanks for your efforts! Yes, I came across the wiki. That was one of the few mentions of "tagfile" that I was able google.

I've tried a couple more times the last two days but still cannot get the slackware setup to honor my "tagfiles" or "custom" option. *sad*
I was able to document the error of the slackwarearm installation better, though. When choosing the "custom" prompting option, setup starts doing it's thing, but somehow messes up. The screenshot shows how it looks (it just started installing, and from here on the error message keeps repeating until all packages have been interated...

https://imagebin.ca/v/3noeUZ6FB1aO
 
Old 01-11-2018, 06:33 AM   #6
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,226

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
If you have an usb key, or nfs mount
Boot from install media
create directory /tagfiles
mount /dev/sdc1 /tagfiles # example for usb key with corresponding device files see dmesg
mount -t nfs server:/path/to/shared /tagfiles # nfs

run setup, configure what you want (partitions, keymap etc)
then choose INSTALL, choose tagpath and enter: /tagfiles

Note: /tagfiles should be the root directory for tagfiles packages series eg:
/tagfiles/a /tagfiles/ap /tagfiles/d etc...

Else you have to enter the subdirectory that contains tagfiles packages series eg:
tagpath: /tagfiles/slackware64 (for example)
 
Old 02-12-2018, 06:59 PM   #7
rk4n3
LQ Newbie
 
Registered: Jul 2008
Location: MN
Distribution: Freenix
Posts: 13
Blog Entries: 1

Rep: Reputation: 1
Quote:
Originally Posted by maelcum View Post
I've watched the second YT video. If somebody has basic shell knowledge, skip to
- 50:00 to see what he is doing (making an iso from his modified tagfiles)
- 1:05:00 to see him mounting the iso (after booting setup) and
- 1:09:15 to see him use the prompting option tagfiles and entering the path to his mounted iso.
Beyond that, there is nothing more related to tagfiles.

Unfortunately that does not solve the problem on my side. Maybe it's a difference between freeslack (what is used in the video) and vanilla slackware, though I doubt it.
I'll keep trying. There is surprisingly little documentation about this (that I've found so far)...
Hi Maelcum ... I made the video you're referring to.

I have used the sequence of steps shown in the video successfully for years on stock slackware, and it works in FreeSlack (as expected) because there's no change in FreeSlack around the installer's behavior.

I have never tried Slackware for ARM, so I can't attest to whether the same can be said for the installer in that scenario.

In my experience, there are two critical items, easy to mess up, that have to be done correctly for the tag set to be honored. The first is that the directory structure + files has to be faithfully reproduced with no syntax errors in the files, and the second is the path to the custom tag set has to be specified correctly pointing to their already-mounted-and-visible location. As I mentioned in the video, the prompt for path gives you a clue about the exact placement of the directory structure relative to the path you have to provide.

I hope this clarification can be of some help - I'd be happy to try to zero in with more detailed feedback, if you would like to respond with further questions.

Sincerely,
Matt
 
Old 02-16-2018, 04:01 PM   #8
maelcum
LQ Newbie
 
Registered: Jan 2018
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you Matt, for your support.

What you did - if I remember the video correctly - was to modify the tagfiles and burn them to an iso, which you mount and install from. This is not tackling the problem I'm having.
I _have_ been successful in mirroring the slackware ftp server to a local machine, modifying the tagfiles there and installing from that share. That was described as the first option in my original post and in the summary.
But as soon as I rename the tagfiles from, say, tagfile to i.e. tagfile.srv, tagfile.clt and tagfile.lpt this does not work. During the installation I choose the custom prompting mode, but the installation routine does not pick up the tagfile.<XYZ>.
I've made more tests and am pretty sure that this is an error in the installation routine of the arm version of slackware. I'm not experienced enough to fix it myself, so I've just duplicated the local mirror three times (what a waste of space) and edited the individual tagfiles. During the installation I then choose the mirrors with the configuration I need. An ugly workaround at best, but it works.

There has been a new release of the sarpi installer (on the same day you posted) but I was not yet able to test that. Maybe the problem is fixed there.

Anyway, I found it extremely nice and helpful of you to post and wanted to let you know that I'm not ignoring your helpful answer.
 
Old 04-02-2018, 05:53 AM   #9
MisterL
LQ Newbie
 
Registered: Mar 2018
Location: Germany
Distribution: Slackware
Posts: 13

Rep: Reputation: 7
Seems I'm, a little late, but I was testing tagfiles, too, after watching Matt's video (Thanks!).
And I ran into the same problem with custom-named tagfiles not being recognized. I was able to reproduce this on x64-current as well, so it doesn't seem like an arm-specific problem to me.

Quote:
Originally Posted by maelcum View Post
I've made more tests and am pretty sure that this is an error in the installation routine of the arm version of slackware. I'm not experienced enough to fix it myself, so I've just duplicated the local mirror three times (what a waste of space) and edited the individual tagfiles. During the installation I then choose the mirrors with the configuration I need. An ugly workaround at best, but it works.
I have put my tagfiles in another folder on my local mirror and just replace them when I'm installing new. Rsyncing the mirror with an official mirror resets the tagfiles to default. This is okay for my testing, maybe it helps to save a few GB.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slacke17 does or doesn't work on slack14.1_64 running on an Acer Aspire 5100? liltux Slackware 12 01-06-2014 10:52 PM
is there a difference between tagfiles for 32 and 64 bit? mortre Slackware - Installation 0 01-09-2011 12:37 AM
Tagfiles - did someone do the hard work already? TL_CLD Slackware 11 10-21-2006 03:31 AM
tagfiles for Amigo? carolinus Amigo 1 02-04-2005 10:14 AM
Editing tagfiles for new kernel? Makaelin Slackware - Installation 1 12-17-2004 11:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 10:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration