LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-13-2019, 03:17 PM   #1
louisb
Member
 
Registered: Aug 2003
Posts: 165

Rep: Reputation: 15
Auto Mount not working (AutoFS)


I'm trying to auto mount an NFS share when the mount point on the workstation is accessed.

I've made the following entries in the "/etc/auto.master" file:

NAS-Disk /etc/auto.nfs --timeout=60

Followed by the following entries in the "/etc/autofs.nfs" file:

NAS-Disk -fstype=nfs4,rw,soft,intr cscd-nas-1:/volume1/Louis-Disk

I've checked and confirmed that the auto-mount services is running using the following command: "service autofs status". Active (running) was reported in green. The mount point on the local machine is "NAS-Disk". So when ever I reference mount point the NFS volume should get mounted is that correct?

Thanks
 
Old 06-13-2019, 03:54 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 18,575

Rep: Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693Reputation: 2693
The mount point auto.master should be the base directory and use an absolute path i.e /mnt

autofs will create the subdirectory i.e /mnt/NAS-Disk for my example when the service starts and mount the nfs share when the directory is accessed. Make sure you can mount the nfs share manually.

The ArchWiki on autofs is a good reference.
https://wiki.archlinux.org/index.php/Autofs
 
Old 06-13-2019, 09:04 PM   #3
jmgibson1981
Member
 
Registered: Jun 2015
Location: Tucson, AZ USA
Distribution: Debian
Posts: 348

Rep: Reputation: Disabled
Code:
+auto.master

/megalith /etc/auto.megalith --timeout=30
Code:
pool -fstype=nfs,rw,soft,intr,rsize=8192,wsize=8192 megalith.mylan.home:/snapraid/pool
This is my configuration working flawlessly right now on Ubuntu 18.04. I can't recall where I found these settings, probably the Arch wiki. Should give a structure for you to work from. This gives my automount directory @ /megalith/pool.

Last edited by jmgibson1981; 06-13-2019 at 09:06 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] autofs passing username to autofs mounts Timothy Miller Linux - General 3 08-27-2018 06:24 PM
[SOLVED] any autofs experts here? how to get autofs and WebDAV to play nice? zippydan Linux - General 2 09-05-2016 07:13 PM
autofs does not auto-mount cdrom Hammo Linux - General 9 12-28-2012 04:08 AM
using autofs to auto mount my usb drives DesertWolf0132 Slackware 8 07-30-2004 10:27 AM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 12:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration