LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 09-16-2020, 05:35 AM   #1
Shaggy1
Member
 
Registered: Oct 2010
Posts: 39

Rep: Reputation: 1
Typed command echos and outputs below the bottom of the screen


Hi

System:
Thinkpad 400 Laptop
OS: Trisquel 8, Based on Ubuntu 16.04 LTS
---------------

I have a Lenovo Thinkpad 400 laptop whose display is broken, so I have hooked up an external monitor (Philips 226E9Q) via VGA.
In an effort to get out of a boot loop I pressed Ctl-Alt-3 to get to a (full screen) terminal.

Here I find I have an issue where when I type in the terminal I cannot see the command I type until I press return ~5 times, when both the command and its output appears on the screen.
This happens regardless of how much I alter the V-position of the monitor (even if V-pos is at 100% and the prompt is seemingly above the bottom of the screen).

Does anyone know what might be happening here ?
Possibly to do with a screen resolution or monitor size setting ?
Does anyone know how to configure such screen settings from the OS ?
Any ideas on how I can go about troubleshooting this ?
 
Old 09-16-2020, 05:51 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 15,107

Rep: Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975Reputation: 4975
did you switch off the built-in display? I think the two displays are set to mirror mode and the resolution of the external VGA is smaller, therefore cannot show the bottom lines. You might need to disable the built-in display or probably need to configure the kernel to boot in a low resolution mode (but it is only a wild guess).
 
Old 09-16-2020, 09:24 AM   #3
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian Stable and Unstable
Posts: 1,381

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Use the display applet to increase the resolution of the monitor display. One step up should be enough.
 
Old 09-16-2020, 10:11 AM   #4
Shaggy1
Member
 
Registered: Oct 2010
Posts: 39

Original Poster
Rep: Reputation: 1
Thank you for your replies.

> Use the display applet to increase the resolution of the monitor display. One step up should be enough.
Currently at the moment for some reason I am stuck in a boot loop for the user I want to log in as (when I try to log in it simply takes me back to the log in screen)

I can log in as a guest user and though I do not know how to run the display applet (I suspect bad resolution makes it invisible) running the following command:
xrandr --output VGA1 --mode "1920x1080" looks like it is now showing me the whole screen.


However it is not permanent, so when I reboot I get the wrong resolution again.
This may be because in guest mode any file changes to not remain on log out.
Does anyone know how I can change thedefault resolution permenantly - what file would I need to edit to make the setting permanent ?

Also if I go to a console (Ctl-Alt-F3) I still see the odd command line behaviour.
From a console xrandr does not work (seems to require X11 to work).
 
Old 09-16-2020, 11:12 AM   #5
MadeInGermany
Senior Member
 
Registered: Dec 2011
Location: Simplicity
Posts: 1,454

Rep: Reputation: 664Reputation: 664Reputation: 664Reputation: 664Reputation: 664Reputation: 664
A quick workaround for a full screen terminal:
Code:
stty -a
Note the rows value.
Set a lower rows value; for example it was 45 then set
Code:
stty rows 40
If there is no immediate effect then start vim and exit with :q
 
Old 09-16-2020, 11:51 AM   #6
Shaggy1
Member
 
Registered: Oct 2010
Posts: 39

Original Poster
Rep: Reputation: 1
Thank you for the stty tip !
It works for me setting rows to 45

I deleted the user I was having problems with (I incorrectly called it a boot loop - it was a login loop), created a new user and repeated the xrandr command, rebooted and logged in and it looks like the resolution settings were saved.


Probably now more a question for Ubutu specific forum, but I'll ask here in case someone knows:

... However this needs to be done separately for every user.

Having set the resolution I can see the menus and can go to ControlCentre_>Display (it's a Mate desktop) where in theory I can set the resolution, but the Resolution field does not give me the option of 1920x1080 (even though xrandr has that mode). Anyone know how I can get that mode included in the resolution list on the Display dialog ?

If I can get on there and select it the dialog has a 'Apply system wide' button which I'm hoping will set it for everyone.
 
  


Reply

Tags
display.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Search in "less" echos all characters FoxtrotLima Linux - General 1 06-30-2017 07:17 AM
how to convert unformatted binary files/outputs to netcdf outputs in linux? sarasari Programming 2 03-11-2014 11:30 PM
Powerterm 9.x echos garbage oly562 Linux - General 1 01-12-2014 04:16 AM
LXer: Move unity launcher to the bottom with Unity Bottom Launcher | PPA Ubuntu LXer Syndicated Linux News 0 12-19-2011 12:30 AM
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 02:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration