LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 08-08-2018, 07:57 AM   #1
Janvanl
Member
 
Registered: Apr 2015
Posts: 53

Rep: Reputation: Disabled
Solved - Setting system language - cannot find where to adjust


Hi,

I have been tampering to get the system-language right (german).

I changed the /etc/default/locale but with no effect

I have put only 2 lines in it like was advised in a forum

# File generated by update-locale
LANG="de_AT.UTF-8"
LANGUAGE="de_AT:de"

But whatever I do, after I give "locale" in a terminal, I get

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_AT.UTF-8
LANGUAGE=de:en_US
LC_CTYPE="en_AT.UTF-8"
LC_NUMERIC=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_COLLATE="en_AT.UTF-8"
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES="en_AT.UTF-8"
LC_PAPER="en_AT.UTF-8"
LC_NAME="en_AT.UTF-8"
LC_ADDRESS="en_AT.UTF-8"
LC_TELEPHONE="en_AT.UTF-8"
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION="en_AT.UTF-8"
LC_ALL=


I do not have a locale called en_AT, cannot explain from where it came.

So I guess I am missing some config-file, but where???

Grateful for any help on this.

Regards,
Jan

Last edited by Janvanl; 08-10-2018 at 08:27 AM.
 
Old 08-08-2018, 10:20 AM   #2
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Xubuntu
Posts: 5,086

Rep: Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693Reputation: 1693
You don't say which distro you have, which will affect how these things are handled, but you could try the appropriate solution given here
https://www.cyberciti.biz/faq/how-to...-a-linux-unix/
 
Old 08-10-2018, 05:46 AM   #3
Janvanl
Member
 
Registered: Apr 2015
Posts: 53

Original Poster
Rep: Reputation: Disabled
Hi David,

thanks for the response.
I use Kubuntu 18.04.

The link seemed helpfull but did not solve my problem.

I am now stuck with this problem

sudo update-locale -reset
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de:en_US",
LC_ALL = (unset),
LC_MEASUREMENT = "de_AT.UTF-8",
LC_MONETARY = "de_AT.UTF-8",
LC_NUMERIC = "de_AT.UTF-8",
LC_TIME = "de_AT.UTF-8",
LANG = "en_AT.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

I have no idea from where "en_AT.UTF-8" came for that is a non-existent locale.

I just used export to write the locale in bash, but after rebooting I am back to
the starting point with "en_AT.UTF-8".

This must be saved somewhere in the OS but where?

I am running 16.04 on my desktop that is all german.
In Gnome there seems to be a tool to set the system-language that is not in KDE.

Regards,
Jan

Last edited by Janvanl; 08-10-2018 at 07:07 AM. Reason: extra info
 
Old 08-10-2018, 08:26 AM   #4
Janvanl
Member
 
Registered: Apr 2015
Posts: 53

Original Poster
Rep: Reputation: Disabled
Solved!

in KDE I just had to choose

Systemsettings - Formats
and set the Region to Germany de_DE

That was where "en_AT" was entered (I do not understand why it is there anyway),
after changing that and logging off and on I had german back in all programs.

Regards,
Jan
 
Old 08-15-2018, 08:19 AM   #5
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia, Slackware, Maemo
Posts: 309
Blog Entries: 1

Rep: Reputation: Disabled
Well, system language is initially set during the installation in the system. KDE has it's own system language settings, and if these conflict with the main system language, you can run into some annoyances, especially if that locale was not installed with the main system during the installation.

Depending on the distro, this could be something silly like selecting the keyboard layout to determin the locate that way, or by setting the timezone city to determin the locale. In my distro the locale is chosen seperately from those, and correct additional locales are installed in addition to them, according to keyboard setups and timezones etc. I can also choose to install several other locales manually if I want.

But if a specific locale is not installed during the system installation, and I choose this one in KDE, KDE actually have scripts that changes the main system locale according to some silly vectors, and if these are not installed you end up with that annoying message that system locale are not installed. KDE actually controls locale from 2 seperate settings and scripts which can be a bit intimidating. I had huge problems resolving this issue before and finding out exactly what was controlling the locale in KDE. I always use several different locale for different purposes as I am multilingual and multinational, and this can be quite frustrating sometimes.

What I initially tried to do was to change the locale in the system itself, but this never stuck, as KDE runs script to set the locale according to the KDE settings.

However, as far as I remember, the problem was solved by manually installing the missing locale files from the distro package manager. This was the easiest way to solve it, and I still needed those locale files, since I frequency use them and had forgot to install them during the system installation.

Anyways, just throught I would add this to the thread.

Last edited by zeebra; 08-15-2018 at 08:21 AM.
 
Old 08-15-2018, 09:59 AM   #6
Janvanl
Member
 
Registered: Apr 2015
Posts: 53

Original Poster
Rep: Reputation: Disabled
Thanks for the reply, I have had my troubles with locales in the past as well.
Usually I installed Ubuntu and added KDE to it, this time I installed Kubuntu.
I like Synaptic however a lot more then Discover, so had to install it with CLI.

I will not say that KDE is not good but one needs to get used to some peculiarities.

Only, a locale "en_AT" is nonsense, Austrians do not have english as an official language.

I have to deal with NL, D (D-AT), US/UK and CZ and SK.

The thing was, I have 16.04 running in german and when 18.04 seems alway to end in english,
it is annoying. As always, if one digs long enough there is a solution.

Regards,
Jan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't differentiate system language from keyboard language? lilou_b Linux - Newbie 3 04-14-2010 05:47 PM
How do I adjust system volume in Slack 12.2? linus72 Slackware 7 04-10-2009 07:55 AM
ntpd does not adjust system clock kannerke Linux - Software 1 01-15-2009 10:31 AM
can't adjust the date/time setting fixxxer0101 Slackware 4 01-05-2004 08:23 PM
Can't find AUmix or Kmix in Mandrake 9.1 to adjust volume of sound. drumlinuxuser Linux - Software 8 10-10-2003 10:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 11:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration