LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-18-2018, 12:24 AM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 18.04
Posts: 1,669

Rep: Reputation: 55
laptop does not shutdown properly


I bought this Samsung NP3500EL-X0ACN a while ago. It has an nvidia GPU (according to the sticker on it).

After I have used it in the classroom connected to the overhead projector, it will not shutdown. All I can do is hold the on-off switch for a while to force it to shut down.

If I have not used it with the overhead, it shuts down normally.

I tried CTRL-ALT f2 to open another log in, logged myself in, then sudo shutdown -now

I see:

[9590.157268] nouveau 0000:01:00,0: Xorg failed to idle channel 3 [Xorg:983]

later

watchdog: BUG:soft lockup - CPU#1 stuck for 23s

This last message repeats, the laptop will not shutdown.

System Settings says I have: Intel® HD Graphics 520 (Skylake GT2)

Any tips about how to fix this?
 
Old 05-18-2018, 04:50 AM   #2
JJJCR
Senior Member
 
Registered: Apr 2010
Posts: 1,490

Rep: Reputation: 258Reputation: 258Reputation: 258
have you tried this:

ctrl alt F7 back to X

ctrl alt backspace kill your X server

then try to shutdown again
 
Old 05-18-2018, 07:04 AM   #3
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,184

Rep: Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017
From your error message I see you have two VGA cards, the Intel and the NVidia.

Newer distros have a utility which switches between the two VGA cards, depending on the graphic calculations needed. I think this utility is called switcheroo or so.

Ubuntu 16.04 might or might not have included this. It became mainstream around the time Ubuntu 16.04 was released.

Anyway, Intel graphic cards are fast enough for anything except gaming. So if your needs are only office work and Youtube videos you might want to disable the NVidia card. This might also increase you battery life. Chances are you won't even notice anything in graphic performance.

To do this, create /etc/modprobe.d/blacklist-nouveau with this contents:
Code:
blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist gx1fb
blacklist gxfb
blacklist lxfb
blacklist kyrofb
blacklist matroxfb_base
blacklist mb862xxfb
blacklist neofb
blacklist nvidiafb
blacklist pm2fb
blacklist pm3fb
blacklist s3fb
blacklist savagefb
blacklist sisfb
blacklist tdfxfb
blacklist tridentfb
blacklist viafb
blacklist vt8623fb
blacklist nouveau
It contains more than you need. I just copied the file from my own laptop. Once the file is created, reboot.

You reverse the operation by simply removing the file from the modprobe.d directory.

jlinkels

Last edited by jlinkels; 05-18-2018 at 07:05 AM.
 
1 members found this post helpful.
Old 05-19-2018, 09:41 PM   #4
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 18.04
Posts: 1,669

Original Poster
Rep: Reputation: 55
Thanks, I will do that, then see how it goes tomorrow in class. I never play games on my computer, so I don't need high end graphics.

My /etc/modprobe.d/ contains 12 files, some of which begin with blacklist, all of which end with .conf

Question: should this file be called blacklist-nouveau.conf?

@JJJCR I cannot do anything if I am in the normal environment, (F7). I close all programs, go to shut down, the little window pops up, ask if I really want to shut down now, I click shutdown. The screen freezes, mouse is gone, the computer is dead, (I cannot then access virtual terminals with alt ctrl F?) but the screen is still on, showing my desktop, although nothing can be used. Only holding the off switch down actually gets the screen to switch off.
 
Old 05-20-2018, 06:27 AM   #5
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Distribution: Tiny Core, Debian based (Raspbian, RasPiDeskop), & sometimes OpenBSD
Posts: 2,541

Rep: Reputation: Disabled
Perhaps, when you have finished your presentation, open a terminal & type
Code:
sudo halt -p
that should close all files, shutdown the system, & switch off the computer
 
Old 05-20-2018, 07:29 AM   #6
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,184

Rep: Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017Reputation: 1017
Quote:
Originally Posted by Pedroski View Post
Question: should this file be called blacklist-nouveau.conf?
You can call it what you like. The filename is irrelevant. It should end in .conf, that is all.

If the other .conf files already contain lines which are also in my file, it is best not to include those lines again in the new file you create. It won't break anything, but it is bad practice to have the same blacklist line in two files.

jlinkels
 
Old 05-21-2018, 11:21 PM   #7
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,385

Rep: Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979
Try disconnecting the projector before you shut down.
 
Old 05-23-2018, 12:37 AM   #8
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 18.04
Posts: 1,669

Original Poster
Rep: Reputation: 55
Well, blacklisting nouveau seems to have worked! Even after using the laptop with the overhead projector, it actually shuts down!

I first tried using the proprietary nvidia driver. That also allowed me to shutdown normally after using it with the overhead. However, normally, if I just close the lid, when I open it again, I get a log in screen automatically. Using the proprietary nvidia driver, I just get a black screen, it does not recover from closing the lid and I have to force a shutdown. So I went back to the Ubuntu driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop will not shutdown properly gap1975 Ubuntu 5 05-02-2012 07:23 PM
Can not shutdown the computer properly michael! Linux - Hardware 2 09-25-2006 12:18 AM
Properly shutdown Haiyadragon Linux - Hardware 1 06-08-2006 10:22 AM
cannot shutdown properly space_beyond Linux - Security 7 07-15-2005 12:17 PM
Can't shutdown properly hus Linux - Newbie 5 01-01-2004 04:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration