LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-14-2019, 03:17 AM   #1
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 126

Rep: Reputation: 87
gslapt suddenly crashes


I know that most people here prefer slackpkg or slackpkg+ but I'm one of those lazy slackers that use slapt-get/gslapt - have done so for 10 years and like the simplicity.
Today, however, I ran into problems when trying to install the latest -current upgrade. Updating ran OK, but when hitting the last "OK" button it just stopped.
Running gslapt from terminal have given different error messages, among them "segfault".
I've tinkered around a bit and reinstalled the gslapt package from jaos.org. Now I get one of the following error messages:
Code:
bash-5.0# gslapt
[xcb] Unknown sequence number while dequeuing request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
gslapt: xcb_io.c:180: dequeue_pending_request: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted
or
Code:
bash-5.0# gslapt
free(): invalid pointer
Aborted
Removing a package works, though. And upgrading using slapt-get in terminal works fine, too.

Since it worked yesterday, I tried downgrading yesterday's -current upgrades (less and babl) to previous versions, but that didn't help.

I know that there are a few gslapt users out there. Have you encountered the same? Suggestions how to fix? Thanks in advance.

SOLVED: I first tried rebuilding gslapt using the latest git which failed during Make. After first building and upgrading slapt-get (from git), I could build gslapt too. Now running slapt-get-0.11.0 and gslapt-0.5.5 and all is well.

Last edited by kgha; 06-14-2019 at 04:02 AM.
 
Old 06-14-2019, 01:28 PM   #2
dwblas
Member
 
Registered: Jun 2011
Posts: 85

Rep: Reputation: Disabled
jaos.org just hangs when I try to update slapt-get. It lists the latest version as 10.2t, so glad to know about git, which works and has the latest version.
 
Old 06-16-2019, 01:55 PM   #3
jaos
LQ Newbie
 
Registered: Aug 2005
Posts: 18

Rep: Reputation: 0
Sorry, I had a few issues with the LetsEncrypt renewal and had removed the http->https auto redirect. Please try https instead of http if the problem persists for you.
 
Old 06-18-2019, 11:24 AM   #4
dwblas
Member
 
Registered: Jun 2011
Posts: 85

Rep: Reputation: Disabled
Thanks. Using https works just fine.
 
Old 06-18-2019, 07:22 PM   #5
jaos
LQ Newbie
 
Registered: Aug 2005
Posts: 18

Rep: Reputation: 0
Quote:
Originally Posted by kgha View Post
Today, however, I ran into problems when trying to install the latest -current upgrade. Updating ran OK, but when hitting the last "OK" button it just stopped.
...
SOLVED: I first tried rebuilding gslapt using the latest git which failed during Make. After first building and upgrading slapt-get (from git), I could build gslapt too. Now running slapt-get-0.11.0 and gslapt-0.5.5 and all is well.

For -current I have 15.0 repositories setup with up to date builds as current progresses that contain all the integrated changes in the git trees for slapt-get, gslapt, and slapt-src. I'm also changing the default repos to a Google Storage location for hopefully better responsiveness, uptime, etc:

Code:
SOURCE=https://storage.googleapis.com/slackpacks.jaos.org/slackware64-15.0/:OFFICIAL
SOURCE=https://storage.googleapis.com/slackpacks.jaos.org/slackware-15.0/:OFFICIAL
SOURCE=https://storage.googleapis.com/slackpacks.jaos.org/slackwarearm-15.0/:OFFICIAL
SOURCE=https://storage.googleapis.com/slackpacks.jaos.org/slarm64-15.0/:OFFICIAL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gslapt problem on Slackware 10.2 mahdif Slackware 5 08-28-2011 05:50 PM
Gslapt/slapt-get upgraded packages saf Slackware 4 05-31-2006 12:34 AM
How to load installation programs from a CD using Gslapt. Manizales VectorLinux 3 04-07-2006 04:07 AM
slapt-get (gslapt) dhbiker Slackware 9 02-17-2006 03:27 AM
unable to use gslapt adityavpratap Slackware 3 11-20-2005 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration