LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-03-2020, 10:38 AM   #1
cesarsj
Member
 
Registered: Mar 2019
Location: Patos de Minas, MG, Brazil
Distribution: Slackware
Posts: 48

Rep: Reputation: Disabled
Question Is there a problem installing latest Mariadb 10 on slackware 14.1?


I'm asking this because on slackware 14.1 ftp site you only have up to MariaDB 5, and this server version does not support online transactions. Yesterday I went to make a transaction that was copying some radius bank tables and then erasing old records, and stopped all company wifi because of the locks.

detail: our freeradius is version 2

Last edited by cesarsj; 01-03-2020 at 12:26 PM. Reason: One important detail was wrong.
 
Old 01-03-2020, 11:56 AM   #2
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 284

Rep: Reputation: 230Reputation: 230Reputation: 230
I use mariadb-10.4.11 on slackware64-14.2 successfully. Of course I compiled it with the SB, I don't install mariadb package from current on 14.2.
 
Old 01-03-2020, 12:28 PM   #3
cesarsj
Member
 
Registered: Mar 2019
Location: Patos de Minas, MG, Brazil
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Thom1b View Post
I use mariadb-10.4.11 on slackware64-14.2 successfully. Of course I compiled it with the SB, I don't install mariadb package from current on 14.2.
I'm sorry, I made the hurried post and put Slackware 14.2 in the title of the question when I mean Slackware 14.1.
 
Old 01-03-2020, 08:01 PM   #4
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,457

Rep: Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250Reputation: 4250
I haven't used 14.1 in quite some time, but your best bet is to just download the mariadb source folder from a 14.2 or -current mirror and run the SlackBuild and see if it builds.

You definitely don't want to install a package from a newer version of Slackware, because it is most likely compiled against newer versions of libraries found in those newer Slackware versions and won't run.
 
  


Reply

Tags
freeradius, mariadb, mariadb 10, slackware 14.1


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: KDE Participating in Google Summer of Code 2019, MariaDB Releasing New Open-Source MariaDB Enterprise Server, CentOS Celebrates 15th B LXer Syndicated Linux News 0 02-28-2019 07:50 AM
Slackware 14.1 mariadb encrypted mydiamo carlitoco Slackware 3 11-27-2013 07:41 PM
Replace MySQL with MariaDB in Slackware abesirovic1 Slackware 36 03-28-2013 09:53 AM
LXer: Slackware switching to the MariaDB database LXer Syndicated Linux News 0 03-24-2013 10:42 PM
[SOLVED] Slackware: Replace MySQL with MariaDB on fresh installation. astanton Slackware 4 03-03-2012 03:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration