LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2018, 05:18 PM   #1
bk328115
LQ Newbie
 
Registered: Jul 2018
Posts: 15

Rep: Reputation: Disabled
WiFi keeps shutting down when system is idle


Laptop: Lenovo Thinkpad X61, 4GB Ram, 2 Ghz
OS: Debian 9 (Stretch) with Plasma 5.8.6
Kernel: 4.9.0.8-amd64

Every time my system goes idle, my WiFi connection shuts down and NM won't let me re-connect, the only options are to edit or delete. NM ver is 1.6.2. The only thing that fixes it is a reboot. I know there is probably a simple fix for this. I had a similar problem in the last thread I posted, and I thought this was fixed, but no.
Thank you so much for your help. You guys are the best! I mean it!

iwconfig reports:

wls3 IEEE 802.11 ESSID:"MySpectrumWiFib8-5G"
Mode:Managed Frequency:5.785 GHz Access Point: 085:9D:8E:3B:BF
Bit Rate=48 Mb/s Tx-Power=16 dBm
Retry short limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=44/70 Signal level=-66 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:54 Missed beacon:0

lo no wireless extensions.

enp0s25 no wireless extensions.

So, does this mean it is power managed and if so, how do I turn that off?


Bill

Last edited by bk328115; 09-15-2018 at 05:27 PM. Reason: post iwconfig
 
Old 09-15-2018, 08:40 PM   #2
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,302

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
What wifi device is in use here?
Code:
lspci -nnk|egrep -iA3 "wireless|network"
Please enclose output within code tags when responding to preserve formatting (refer to the '#' button in the advanced forum editor).

The iwconfig output seems to suggest the power management is off already...
Code:
Power Management:off
Check that interference isn't causing any issues here perhaps eg nearby APs on the same/overlapping channel.

You could keep a watch on NetworkManager for any messages relating wifi status changes
Code:
sudo journalctl -fu NetworkManager
and report back when such an event occurs.
 
Old 09-15-2018, 08:56 PM   #3
bk328115
LQ Newbie
 
Registered: Jul 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
So I figured out that it's when I close the lid, the WiFi goes to sleep. Is there a way I can prevent this?

Code:
Sep 15 21:46:32 debian NetworkManager[557]: <info>  [1537062392.2291] manager: sleep requested (sleeping: no  enabled: yes)
Sep 15 21:46:32 debian NetworkManager[557]: <info>  [1537062392.2338] manager: sleeping...
Sep 15 21:46:32 debian NetworkManager[557]: <info>  [1537062392.4696] manager: NetworkManager state is now ASLEEP
Sep 15 21:46:32 debian NetworkManager[557]: <info>  [1537062392.5210] device (wls3): state change: activated -> deactivating (reason 'sleeping') [100 110 37]
Sep 15 21:46:33 debian NetworkManager[557]: <info>  [1537062393.2964] device (wls3): state change: deactivating -> disconnected (reason 'sleeping') [110 30 37]
Sep 15 21:46:34 debian NetworkManager[557]: <info>  [1537062394.0371] dhcp4 (wls3): canceled DHCP transaction, DHCP client pid 685
Sep 15 21:46:34 debian NetworkManager[557]: <info>  [1537062394.0373] dhcp4 (wls3): state changed bound -> done
Sep 15 21:46:34 debian NetworkManager[557]: <info>  [1537062394.7958] device (wls3): set-hw-addr: set MAC address to AA:88:B0:CF:E1:48 (scanning)
Sep 15 21:46:35 debian NetworkManager[557]: <info>  [1537062395.3390] device (wls3): state change: disconnected -> unmanaged (reason 'sleeping') [30 10 37]
Sep 15 21:46:35 debian NetworkManager[557]: <info>  [1537062395.3506] device (wls3): set-hw-addr: reset MAC address to 00:1C:BF:25:46:29 (unmanage)
 
Old 09-15-2018, 09:07 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,978
Blog Entries: 24

Rep: Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754Reputation: 3754
Quote:
So I figured out that it's when I close the lid, the WiFi goes to sleep. Is there a way I can prevent this?
Nice troubleshooting. Every new fact moves the process forward.

Try suspending the system before you close the lid, rather than letting closing the lid initiate the suspending.

That works for me with Mageia on my Zareason laptop.
 
Old 09-15-2018, 09:12 PM   #5
bk328115
LQ Newbie
 
Registered: Jul 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
Well, the point is, I don't want to suspend when I close the lid and I have my system set that way. When I close it, only the screen shuts off, so when I open it back up the system is awake already. I just want to know if there is a way to prevent the WiFi connection from going to sleep. Thanks.
 
Old 09-15-2018, 09:14 PM   #6
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,302

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Check the KDE power management settings...

System Settings > Hardware > Power Management

Make sure that the 'Button events handling' and 'Wireless' settings are as desired.
 
1 members found this post helpful.
Old 09-15-2018, 09:22 PM   #7
bk328115
LQ Newbie
 
Registered: Jul 2018
Posts: 15

Original Poster
Rep: Reputation: Disabled
That was it. Thanks again.
 
Old 09-15-2018, 09:31 PM   #8
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,302

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Glad that it was a simple desktop config fix!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi (pci) disconnect when computer idle. Fedora 14, wifi RaLink RT2561/RT61 tessx Linux - Hardware 1 05-27-2012 11:15 AM
[SOLVED] Shutting X server down causes WiFi to disconnect 10110111 Ubuntu 6 08-24-2010 06:20 AM
wifi keeps disconnecting when the computer is idle tjyorkshire Linux - Wireless Networking 2 06-27-2007 10:07 AM
Laptop shutting down while idle vicious Slackware 2 08-13-2005 10:27 AM
nmap shutting down my wifi Enigma Linux - Wireless Networking 0 07-16-2003 06:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration