LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-13-2018, 03:39 PM   #16
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 857
Blog Entries: 9

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322

This should let the current SBo verions of mlt and qt5 to play nice. thanks to those who provided clues and testing as to what was happening.

qt5-5.7.1 SBo version
=====================
Modify the following:

Code:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS -std=c++11"
./configure -v -c++std c++11 \

mlt-6.10.0 SBo version
======================
Modification are:

Code:
# Use qt5 if present, otherwise system default
if pkg-config --exists Qt5 ; then
  qt="--qt-libdir=$(pkg-config Qt5 --variable=libdir)
      --qt-includedir=$(pkg-config Qt5 --variable=headerdir)"
  QTCXX="-std=c++11"
else
  qt="--qt-libdir=$(pkg-config Qt --variable=libdir)
      --qt-includedir=$(pkg-config Qt --variable=headerdir)"
fi
and

Code:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS $QTCXX"
./configure \

...

make clean
make
make install DESTDIR=$PKG
both should now compile so that mlt will have qt5 support. Let me know how it goes.
 
Old 08-17-2018, 03:27 AM   #17
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 528

Original Poster
Rep: Reputation: 55
Downloaded from SlackBuilds mlt and qt5 afresh. Amended the SlackBuild scripts as per the instructions in posting https://www.linuxquestions.org/quest...ml#post5891329

Compiled qt5 then mlt. All compiled successfully as expected.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] aMule doesn't compile in Slackware 64 stable PreguntoYo Slackware 8 07-31-2018 03:12 AM
[SOLVED] I cannot compile 6.47. Gettext-0.19.8.1 in stable systemd version ar124official Linux From Scratch 2 06-30-2018 10:04 AM
[SOLVED] BLFSS 8.0 stable: TCL fails to compile jr_bob_dobbs Linux From Scratch 3 05-06-2017 11:14 AM
mlt 0.8.20 compile error zasavage Slackware 3 11-15-2012 01:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration