LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-31-2019, 04:49 AM   #1
cdek
Member
 
Registered: Jul 2016
Posts: 32

Rep: Reputation: Disabled
anki on current builds but doesn't run


I'm trying to install anki on current. It builds, but doesn't run.

One of the dependencies is missing in the slackbuilds tree: six, which is needed by matplotlib. I assume that is the problem.

BTW, the python3 version, python3-matplotlib depends on python3-six, which is also missing.

Is there a reason why these packages are missing for current?
 
Old 12-31-2019, 05:33 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,876

Rep: Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556Reputation: 6556
Slackware-current has a "python-six" package in the "l" series, currently at version 1.13.0, which supports both Python 2 and 3.
 
Old 12-31-2019, 05:44 AM   #3
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,239

Rep: Reputation: Disabled
hi cdek!
essentially is what Alien Bob said, both packages for 14.2, six and python3-six, have been added to current as part of the python-six package.

if you want to check why something is missing or, more in general, why things have been modified in the unofficial repository for current in respect of the official 14.2 respository, you can refer to the branch list of the git repository, where a short description might shed some light (it's linked in the first post of this topic)

http://cgit.ponce.cc/slackbuilds/refs/heads

I'm sorry but I cannot help with anki as I'm in the middle of rebuilding all of my personal stuff because of the python upgrade in current (might be involved in your problem... maybe something has to be rebuilt and/or is incompatible with python 3.8? just a guess): try pinging the maintainer.

Last edited by ponce; 12-31-2019 at 05:47 AM.
 
Old 01-01-2020, 06:23 AM   #4
cdek
Member
 
Registered: Jul 2016
Posts: 32

Original Poster
Rep: Reputation: Disabled
Thank you for clarifying! It makes sense now.

I installed anki from the anki website instead. Slackbuilds version is 2.0.52 and current version is 2.1.15.

Apparently there is a big change between versions 2.0 and 2.1. I only had to install wayland for it to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anki - can't connect to AnkiWeb from Ubuntu 12.04 charlemagne-is-my-son Linux - Software 0 03-14-2014 06:45 PM
Anki card distribution increase, certain cards are too close together darkstarbyte Linux - Software 5 09-09-2013 06:27 AM
anki on Slackware 13.37 titopoquito Slackware 9 10-13-2011 05:55 AM
LXer: Anki - An alternative learning program LXer Syndicated Linux News 0 06-01-2011 03:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration