LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-12-2017, 02:18 AM   #1
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Rep: Reputation: Disabled
FB-messenger-cli error


Hello,

I have just installed fb-messenger-cli on Debian.
When I run it I get this error output:

[CODE$]fb-messenger-cli

/usr/local/lib/node_modules/fb-messenger-cli/cli.js:16
crypt.load((err, data) => {
^
SyntaxError: Unexpected token >
at Module._compile (module.js:439:25)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
at startup (node.js:119:16)
at node.js:906:3[/CODE]

The install seemed to go fine, I checked and node is version 0.10.29 and npm 1.4.21.
I heard there is an issue with Debian naming "node" "nodejs" but really don't know about this.

Any clue?
 
Old 10-12-2017, 03:02 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,504

Rep: Reputation: 137Reputation: 137
Based on error message, the issue is relative to installation, it can't load crypt java script.
Where do you get fb-messageer-cli packet, from Debian or third party?
 
Old 10-12-2017, 11:27 PM   #3
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
third party, that is, github.
It is a npm package, for there is no fb-messenger-cli package for Debian, at least that I know of.
 
Old 10-13-2017, 12:19 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,474
Blog Entries: 2

Rep: Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566
which debian version are you running?
is it up-to-date?
which nodejs version is installed?
from the repos?

guess:
maybe fb-messenger-cli relies on a different (newer) nodejs version? what do they say about it?
 
Old 10-14-2017, 02:38 AM   #5
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
Debian testing, up to date, npm is 1.4.21, node is 0.10.29, from the repository.
 
Old 10-14-2017, 05:22 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,474
Blog Entries: 2

Rep: Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566
^ good.
now check out the github repo what documentation it provides about what sort of versions of nodejs it requires etc.
 
Old 10-14-2017, 01:26 PM   #7
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
I checked the fb-messenger.cli page at:
https://github.com/Alex-Rose/fb-mess...master/scripts
and also the readme.d file in the fb-messenger-cli package that I have installed and, as far as I can tell, there seems not to be other dependencies besides nmp, nodejs and curl, which are all installed.
 
Old 10-15-2017, 04:14 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,474
Blog Entries: 2

Rep: Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566
^ that looks like the wrong page, you should be reading (and following instructions on) this:
https://github.com/Alex-Rose/fb-mess...ster/README.md
 
Old 10-15-2017, 12:37 PM   #9
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
it's the same readme.md.
 
Old 10-16-2017, 02:49 PM   #10
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,504

Rep: Reputation: 137Reputation: 137
The nodejs version that fb-messageer-cli request is 6 or 7, such as 6.11.3 or something. Your version is 0.10.29, too old.
 
Old Yesterday, 12:30 AM   #11
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
Right on,
never having used nodejs before I was not familiar with the version numbers.
Installed correct versions and it worked.

Thanks alot.
 
Old Yesterday, 01:56 AM   #12
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 6,474
Blog Entries: 2

Rep: Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566Reputation: 1566
^ it would be nice if you told us HOW you did that, esp. on debian.
others will benefit.
life's a two-way street.
 
Old Yesterday, 03:49 AM   #13
black-clover
Member
 
Registered: Jun 2017
Distribution: Vector Linux , Debian Buster, NuTyX
Posts: 43

Original Poster
Rep: Reputation: Disabled
There might be better ways, but here is mine.

1 - upgraded system to Buster (I was using a fresh Stretch install)
2 - # curl -sL https://deb.nodesource.com/setup_7.x | sudo -E bash -
3 - # apt-get install -y nodejs
4 - # apt-get install -y build-essential
5 - # npm install -g fb-messenger-cli
6 - # fb-messenger-cli

For those not familiar with it, fb-messenger-cli allows to use Facebook Messenger on the terminal, which is handy for me since my favorite web browser is Luakit, which,as many other lightweight browsers, does not render the frame of the chat windows very nicely.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Facebook Messenger CLI Chat Via Linux Terminal LXer Syndicated Linux News 0 07-23-2017 12:51 AM
Error: php55u-cli conflicts with php-cli-5.3.3-47.el6.x86_64 NotionCommotion Linux - Newbie 1 07-12-2016 02:02 AM
CLI Client for MSN Messenger CrEsPo Linux - Software 7 05-27-2005 08:05 PM
Mozilla Messenger Profile In Use Error cmus Linux - Software 1 10-31-2004 10:11 PM
Error Starting Yahoo Messenger lanresanusi Linux - General 3 04-09-2004 11:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration