LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-06-2003, 09:16 PM   #1
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Rep: Reputation: 30
Nvidia Driver


Information: Just did it with no problems. If anyone is trying to install the
nvidia drivers and it error's out due to a GCC mismatch, that's because there
is one. The Kernel was compiled with GCC 3.2 and the provided GCC is 3.3, but
3.2 is still there also and must be used when building the module for the
kernel.

As root, just before running the shell command for the install, do
export CC=gcc32
and the install should go great. Don't forget to edit your XF86config file appropriately.

The driver is working great, as it did for RH9 for me...good luck
 
Old 11-06-2003, 10:05 PM   #2
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
My driver works but I have to disable the rhgb or it freezes when trying to bring up GDM after the graphical boot... nothing responds at all... not sure what's up but it runs fine with the standard nv driver...

To clarify, my nvidia driver works as long as I'm noy using rhgb... otherwise it freezes at gdm.

Last edited by lupin_the_3rd; 11-07-2003 at 07:37 AM.
 
Old 11-07-2003, 02:23 AM   #3
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Rep: Reputation: 15
I had my driver working, but when I went to play E.T. all I had was a black screen. One of the guys in #fedora told me to do this........

uninstall the driver, which I did and it went fine.
then rpm -e --nodeps XFree86-Mesa-libGL
exportCC= gcc32 ( I did this again just for good measure)

When I went to install the driver again I made it all the way up unitl it started compiling then it would crash and I would get the "read the log" screen.

Well here is what is in the log, its the last part.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.

Thanks for the help ahead of time

FX
 
Old 11-07-2003, 07:51 AM   #4
mishmash
Member
 
Registered: Nov 2003
Location: Canada
Distribution: RHEL
Posts: 87

Rep: Reputation: Disabled
Hi,

I had the same problem as Bobmeister and did what he suggested and it is working fine now.

Thanks Bobmeister!

Please note that the error messages I had found in the log file are the same as the ones described by FXRS.

The following procedure is the one I used for installing the NVIDIA driver and the one that NVIDIA recommends (except of course for the CC export in order to correct the CC mismatch error...).

1. Modify the /etc/inittab file to force booting in console mode (i.e. text mode, not Xserver). You only have to change the line

id:5:initdefault:

to this

id:3:initdefault:

2. Restart the computer. It will boot in text mode.

3. Login as root.

4. Move to the directory where the NVIDIA .run file was downloaded.

5. Run the following command to set the CC variable and thus avoid the CC mismatch error.

export CC=gcc32

6. Install the NVIDIA driver by running the following command. It should install correctly.

sh ./NVIDIA-Linux-x86-1.0-4496-pkg2.run

7. Move to the directory where the XF86Config file is located, i.e. the /etc/X11 directory.

8. Modify the XF86Config file by changing the line

Driver "nv"

for

Driver "nvidia"

in the "Device" section.

9. Modify the XF86Config file to remove or comment out (by adding the # at the beginning of each line) the lines

Load "GLcore" (did not found this line though...)
Load "dri"

in the "Module" section.

10. Make sure that the XF86Config file has the line

Load "glx"

in the "Module" section.

11. Modify the /etc/inittab file back to what it was, i.e. with the line

id:5:initdefault:

12. Reboot the computer by pressing Ctrl+Alt+Del.

Everything should be OK after this. For newbies, just run the game TUX racer, itf the NVIDIA driver was installed correctly, the game should display "very" smoothly...

Regards,

mishmash
 
Old 11-09-2003, 04:30 AM   #5
manny0
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora Core 1
Posts: 5

Rep: Reputation: 0
Smile

Thank you mishmash and Bobmeister.
Working just great!
 
Old 11-09-2003, 04:48 AM   #6
amir_h
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat-9.0
Posts: 26

Rep: Reputation: 15
Nice mishmash thanks for your comment
but you don't need to modify inittab nor reboot your system
you can do it with "telinit 3" or "init 3" then install and "init 5" or "telinit 5" to brign your gdm on.
 
Old 11-09-2003, 08:50 AM   #7
fmfnavydoc
Member
 
Registered: Feb 2003
Location: State of Confusion
Distribution: Fedora Core 3
Posts: 49

Rep: Reputation: 15
mishmash and Bobmeister are DA MAN!...I upgraded from RH8 to Fedora, and was having a bad time getting NVIDIA up and running - even looked as some of the other sites that talked abut recompiling the kernal...but, I came back here and found the answer! Thanks - the card is tearing it up now!
 
Old 11-09-2003, 12:59 PM   #8
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
http://moongroup.com/nvidia-fedora.html

This works well and has rpms of the driver... I couldn't get wget to work with it but you can just download them in a browser
 
Old 11-09-2003, 03:29 PM   #9
gibbylinks
Member
 
Registered: Oct 2003
Location: Manchester, UK
Distribution: Lucid Lynx 10.04
Posts: 46

Rep: Reputation: 15
Thank you Mishmash your instructions worked a treat.

Driver installed and working.
 
Old 11-11-2003, 06:19 AM   #10
amir_h
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat-9.0
Posts: 26

Rep: Reputation: 15
Well, driver installs successfully
but it seems bugly :-(
Has anyone tried quake3 on it
 
Old 11-11-2003, 07:39 AM   #11
ronss
Member
 
Registered: Mar 2002
Location: phoenix,az
Distribution: red hat linux enterprise-centos
Posts: 766

Rep: Reputation: 31
just got nvidia driver installed, and now i can watch my euporia sreensaver, got to be one of the coolest screensavers around. thanks to bobmeister and others here for the help. did install -export gcc=bcc32-during runlevel 3 as root, and then did the usual nvidia install. it did state mismatched kernel, and did a recompile. after installing the nvidia driver, opened kedit as root, and configured the xf86file as per instructions. got a lot done tonight-yum upgrade-new skins for xmms-nvidia driver. see ya
 
Old 11-11-2003, 02:47 PM   #12
manny0
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora Core 1
Posts: 5

Rep: Reputation: 0
This is a great link also, most people should know it already. http://fedora.artoo.net/faq/
 
Old 11-11-2003, 02:55 PM   #13
manny0
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora Core 1
Posts: 5

Rep: Reputation: 0
Quote:
Originally posted by amir_h
Well, driver installs successfully
but it seems bugly :-(
Has anyone tried quake3 on it
I have quake3 and rtcw, both gave me funny colors and black screens sometimes, so i had to bring down the console and type /quit. I copied my previous .cfg on them and problem was solved. Not sure why, i'd have to go over them and compare them. You may check here also: http://fedora.artoo.net/faq/ (yup, i just posted this link before, sorry)
 
Old 11-17-2003, 03:19 PM   #14
capgadget
LQ Newbie
 
Registered: Nov 2003
Posts: 1

Rep: Reputation: 0
gcc 3.3

I've been using GCC 3.3 since April that I buld myself. Currently using gcc-3.3.2-1.src.rpm from Rawhide, but just downloaded the gcc-3.3.2-2.src.rpm from the Fedora updates. No problems with the nvidia-installer compiling.
No problems building the RH ntpl kernels or the kernel.org 2.4.22-bkX, 2.4.23-rc1, 2.6.0-test9-bkX (Except for bk7 would not compile with the -O3 flag)

I basically have Rh 8.0 but have been doing the majority of my updates from the Rawhide srpms with every Pentium3 tweak I can find.
 
Old 11-18-2003, 01:42 AM   #15
amir_h
LQ Newbie
 
Registered: Aug 2003
Distribution: RedHat-9.0
Posts: 26

Rep: Reputation: 15
Thanks manny0,
q3 works using rpm -e but it seems bugly.
some strannge noises apear on my monitor
does anyone have soloution for it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 06:31 AM
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 02:42 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 09:45 AM
nvidia fx5600 loads vesa driver instead of nvidia driver saburo62 Linux - Hardware 3 05-04-2004 03:59 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration