LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-24-2004, 07:25 PM   #1
iggylibs
LQ Newbie
 
Registered: May 2004
Posts: 3

Rep: Reputation: 0
Fedora core 2 no sound


To start with, I am a completely new linux user and have absolutely no clue what I'm doing (couldn't find the console until today). Anyways, I just installed Fedora Core 2, and am getting absolutely no sound. When I log on, sometimes I get a message telling me I have no sound card. If i go under the sound test thingamajig, it says I have an Nvidia card, and the test sound doesn't play. According to my computer's website, my sound card is "Integrated Soundmax III Digital Audio". My computer is a compaq presario 6020us with the only changes being an added Geforce ti4200 video card, additional 256 ram, and a new power supply. Any help in getting the sound to work would be much appreciated. Thanks.
P.S. Please, treat me like a 2nd grader and go step-bystep as otherwise I'll get completely lost. I have no clue what i'm doing.
 
Old 05-24-2004, 08:03 PM   #2
geekdaddy
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Same thing here...

I upgraded from FC1. My sound was working fine (Intel 845 chipset with AC'97 audio) and now it's not working since I upgraded to FC2. My sound hardware is recognized by the O.S. but it's not functioning. Any ideas???
 
Old 05-24-2004, 08:12 PM   #3
jspaar
Member
 
Registered: Feb 2004
Location: California
Posts: 99

Rep: Reputation: 15
Iggylibs: first lets see how your sound hardware is identified. That will make it easier to figure out what ALSA driver you need.

Run /sbin/lspci. (To do this, click the Red Hat->System Tools->Terminal. At the prompt just type /sbin/lspci and hit enter.)
Post the output here. Then we can take a look at the alsa documentation to see what driver matches your hardware.

It would also be helpful if you could post the contents of /etc/modprobe.conf. (In the terminal, type: cat /etc/modprobe.conf ).
 
Old 05-24-2004, 08:53 PM   #4
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Rep: Reputation: 15
I went to the ALSA documentation page, but found it less than helpful.

Here's my /sbin/lspci:


00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 11


My cat /etc/modprobe.conf:
alias eth0 3c59x
alias char-major-195* nvidia
 
Old 05-24-2004, 09:14 PM   #5
jspaar
Member
 
Registered: Feb 2004
Location: California
Posts: 99

Rep: Reputation: 15
Quote:
Originally posted by gnu noob
I went to the ALSA documentation page, but found it less than helpful.

Here's my /sbin/lspci:


00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 11


My cat /etc/modprobe.conf:
alias eth0 3c59x
alias char-major-195* nvidia
For your card the ALSA docs say you should be using the snd-intel8x0 driver. If you run system-config-soundcard does it detect your card and play the test sound ok? If not you can try adding this to modprobe.conf:

Code:
alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
 
Old 05-24-2004, 09:23 PM   #6
geekdaddy
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Dumb mistake

Just resolved my problem... After using the command line xface for a few of the alsa utils I realized that my speaker tray icon in the lower right corner had a graphical front-end for the alsa utils.

Right-click on the speaker icon and select "open volume control." The dialog box is tabbed for the prior OSS and current ALSA options. I suspect the OSS controls are merely presenting a front-end to ALSA since I'm running FC2 (kernel 2.6)? Anyhow, ALSA apparently defaults to muted volume controls (why?) so I simply unchecked the mute box and raised the sliders. Everything works now.

A dumb-mistake on my part, but I wonder how many other "newbies" have the same problem? The tray icon did not indicate my volume was muted and I could only determine this by opening the complete ALSA Mixer GUI.
 
Old 05-24-2004, 10:11 PM   #7
gnu noob
Member
 
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Rep: Reputation: 15
DUH!!!!!!!!!!!!!!!!!

I added the info at the end of the modprobe.conf and tried it again, and got nothing. Then I re-read the thread and saw that geekdaddy found the sound muted on the taskbar. I checked again and saw that mine was too. Then I remembered that I'd read somewhere that ALSA defaults to 0 volume. GEEZ!!!!!!!!!!!!!!!!!!!


Hey, Thanks for the help. I guess I should have checked the ALSA site more carefully.
 
Old 05-25-2004, 07:38 PM   #8
iggylibs
LQ Newbie
 
Registered: May 2004
Posts: 3

Original Poster
Rep: Reputation: 0
No result from jspaar's request

I tried typing both tings in the terminal that jspaar said. both resulted in telling me no such file or directory exists. What to do?

Last edited by iggylibs; 05-25-2004 at 07:40 PM.
 
Old 05-26-2004, 08:56 PM   #9
vramamur
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
HAve the same issue

I upgraded to the COre 2 and have no sound. I checked the volume control. Moved all the sliders up and i could only hear the screeching mic. mUTED THE Mic and that didnt help.
/sbin/lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645 Host & Memory & AGP Controller (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI- to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTI OL Media IO]
00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0 016
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE ] (rev d0)
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM87 38 (rev 10)
00:08.0 Unknown mass storage controller: Promise Technology, Inc. 20269 (rev 02)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10 k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0c.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIV A TNT2 Model 64/Model 64 Pro] (rev 11)
[root@localhost root]# /sbin/lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645 Host & Memory & AGP Controller (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL Media IO]
00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:08.0 Unknown mass storage controller: Promise Technology, Inc. 20269 (rev 02)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0c.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 11)
I have a creative labs sound blaster that worked fine on Core1.

cat /etc/modprobe.conf
alias eth0 tulip
alias snd-card-0 snd-emu10k1
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1
alias snd-card-1 snd-cmipci
install snd-cmipci /sbin/modprobe --ignore-install snd-cmipci && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-cmipci { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-cmipci
alias usb-controller ohci-hcd

Could you help out please. The wierd thing is when I do the "SOundcard detection" program, I hear the sounds.

Kind of strange.
Thanks
 
Old 05-26-2004, 10:25 PM   #10
jspaar
Member
 
Registered: Feb 2004
Location: California
Posts: 99

Rep: Reputation: 15
@vramamur: Looks like it's close to working. I don't have two sound cards like you, but I'll throw some suggestions out there, and maybe somebody else will have some better ideas. You've probably looked into this stuff already, but what the heck...

(Actually one of my machines does have two sound cards, but I disabled the integrated audio in the BIOS. On that machine I don't have modprobe entries for the integrated sound, just the Sound Blaster.)

When you open the volume controls, there are probably three tabs there, right? One for the CMedia, one for the Sound Blaster, and one (or two?) for OSS. Did you mess around with the controls on each tab? If your speakers are plugged into the SB Live you can probably ignore/turn down the controls for the CMedia.

You say you get sound during system-config-soundcard. What about if you run something like:
Code:
aplay /usr/share/sounds/generic.wav
Any sound?

If it's only gnome event sounds that aren't working, check to see if you have libgnome-2.6.0-3 installed by: rpm -q libgnome
If you're using gnome, do you have Hat->Preferences->Sound->Enable Sound Server Startup checked?

Just a few ideas.
 
Old 05-26-2004, 11:53 PM   #11
sp|k3
LQ Newbie
 
Registered: Sep 2003
Location: New Mexico USA
Distribution: Fedora Core 2
Posts: 12

Rep: Reputation: 0
Angry I too am fighting this one

Like vramamur I am getting sound ONCE I run the >System Settings>Souncard Detection ... once I run that system sounds normalize but things like KsCD still won't play... What gives?

I have performed an upgrade from Fedora Core 1 to Core 2.


**ERROR MESSAGE RECEIVED WHEN FIRST STARTING**
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

/sbin/lspci
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio Controller (rev 02)
00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go] (rev a3)
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:01.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:01.1 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:01.2 FireWire (IEEE 1394): Texas Instruments PCI4451 IEEE-1394 Controller

cat /etc/modprobe.conf
# Note: for use under 2.4, changes must also be made to modules.conf!
alias eth0 3c59x
alias usb-controller uhci-hcd
alias ieee1394-controller ohci1394
alias snd-card-0 snd-intel8x0
install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0



No clue as to what I should do
 
Old 05-27-2004, 12:25 AM   #12
jspaar
Member
 
Registered: Feb 2004
Location: California
Posts: 99

Rep: Reputation: 15
@sp|k3: my upgrade from FC1 to FC2 was a little screwed up too.

One thing I can tell for sure is that your modprobe.conf will not properly restore the mixer settings. Change the last two lines to:
Code:
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove
On my upgraded box the CD volume was off by default (or muted, I forget). If you're using gnome, run gnome-volume control and adjust and unmute the CD volume in all tabs. I don't know much about KDE, but you should be able to run alsamixer in a terminal and accomplish the same thing.

I don't think /dev/dsp should be used by alsa - pretty sure it's only for the old OSS. Are you using artsd under KDE maybe?
 
Old 05-27-2004, 02:00 AM   #13
RedFed
LQ Newbie
 
Registered: May 2004
Posts: 2

Rep: Reputation: 0
Angry AC97 still no sound

I checked what was written earlier in this thread, but I still have no sound.
FC2 with AC97

1. soundcard is recognized but no sound during testing
2. max volume in all contollers
3. sndconfig compalins:
| You don't seem to be running a kernel with modular sound │
│ enabled. (soundcore.o was not found in the module search path). │
│ To use sndconfig, you must be running a kernel with modular │
│ sound, such as the kernel shipped with Red Hat Linux or a 2.2 │
│ or greater kernel.
so I can not use it
4. edited /etc/modprobe.conf

wherever was 'snd-intel8x0', I changed to 'i810_audio'

then rebooted, but still using the wronf module (snd-intel8x0)

The original /etc/modprobe.conf

alias eth0 3c59x
alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias snd-card-2 audio
remove audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove audio
alias snd-card-3 audio
alias snd-card-4 audio
alias snd-card-5 audio
alias snd-card-6 audio
install audio /sbin/modprobe --ignore-install audio && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
alias char-major-81 bttv
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd


Any ideas how to make it work?
 
Old 05-27-2004, 08:40 PM   #14
Mooshi
LQ Newbie
 
Registered: May 2004
Location: Phoenix, Arizona
Distribution: Fedora Core 2
Posts: 4

Rep: Reputation: 0
aumix

RedFed,

Start a terminal.

Type aumix and, using your arrow keys, make sure that the PCM and PCM2 options are not set all the way to the left. Use your right arrow key to move the small "O" over to the right. When done you can exit with Ctrl + C or just close the terminal.

I hope this helps.


Btw: snd-intel8x0 is correct.
 
Old 05-27-2004, 10:21 PM   #15
vramamur
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
JSPAARs suggestion

HI JSPAAR,
I tried disabling the integrated audio which resulted in just 2 tabs in the VOlume control. made sure I had everything up in volume and had the mic Muted since I didnt want to hear the screeeching noice. Tried playing the generic.wav and I HEARD the sound. But the CD music nor the internet radio stations seem to come out of th speakers

Let me know if I need to tr y anything else.

Thanks all for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound in Fedora Core 3 breen92uk Linux - Hardware 1 04-13-2005 02:22 PM
strange sound/no sound in fedora core 2 vijay_babu1981 Linux - Hardware 1 11-23-2004 03:09 PM
strange sound/no sound in fedora core 2 vijay_babu1981 Linux - Newbie 1 11-22-2004 09:38 PM
Sound card not detected by Fedora Core 2 and no sound. jgr00 Fedora 4 08-19-2004 12:05 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 03:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration