LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-25-2004, 05:50 AM   #1
gamehack
Member
 
Registered: Jun 2003
Location: Sevenoaks, UK
Distribution: Ubuntu
Posts: 183

Rep: Reputation: 30
No sound after KDE 3.2.1


I downloaded all packages in a dir and then with pkgtool installed them.Now I have no sound with root or any other user.I tried:
1.adduser username sys
2.adduser username audio
3.chmod 666 /dev/dsp* chmod 666 /dev/mixer*
4.chmod 666 /dev/sound/*
And nothing works.But when I start XMMS and click on a song it says that it plays it - but actually no sound comes out.

Thanks in advance

P.S. Here are the messages http://forums.openclub-bg.org/error.jpg


Last edited by gamehack; 04-25-2004 at 05:57 AM.
 
Old 04-26-2004, 01:12 PM   #2
fragglehorn
Member
 
Registered: Oct 2002
Location: I-Town, NY
Distribution: Debian, Slackware
Posts: 130

Rep: Reputation: 15
Sound support compiled in your kernel? 'lsmod' to find out.
 
Old 04-26-2004, 10:14 PM   #3
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Rep: Reputation: 30
EXACT same error message and problem I get whenever i upgrade a slack install to kde 3.2.1.

I can see from your screen shot that you have the quicklaunch menu button for KDE configuration. So click that green looking button, go to Sound and Multimedia -> Sound System -> 2nd Tab, and then mess around with the "Select audio device" drop down menu. Right now, my drop down menu is set to "Open Sound System."

Hope this solves the problem.
 
Old 05-08-2004, 06:05 AM   #4
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
i'm having the same problem and changing to OSS isn't helping. beforehand it said denied but now that I used chmod 777 /dev/snd it's just not doing anything.. no error message but no sound either...
 
Old 05-08-2004, 03:11 PM   #5
moronikos
LQ Newbie
 
Registered: May 2002
Location: Tulsa, Oklahoma, USA
Distribution: SUSE, ubuntu
Posts: 21

Rep: Reputation: 15
Are you sure it isn't alsa? After I upgraded with swaret, I didn't have any sound. Turns out the current version of alsa can have problems with Intel onboard sound. I rolled back my alsa to 9.1 (Slack 9.1 that is) and sound is back working and I am using KDE 3.2.
 
Old 05-08-2004, 03:25 PM   #6
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
let me try alsa in flux real fast with xmms (it's currently using the oss driver)..

again.. this works in flux just not in KDE.. (actually I guess I didn't say that in this forum.. sorry)
 
Old 05-08-2004, 05:19 PM   #7
Mark Havel
Member
 
Registered: May 2004
Location: Lyon, France
Distribution: Slackware
Posts: 85

Rep: Reputation: 15
Try to look if it's working under other DE such as GNOME or XFCE or IceWM or whatever else. If yes, it is certainly because KDE has its owns sound server, aRts, which monopolizes your sound card and your programs don't send the sound to aRts. So you must configure them to use the aRts output instead of ALSA or others outputs.
Or perhaps you can just disable aRts at the KDE launch...
 
Old 05-10-2004, 01:16 PM   #8
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
Quote:
Originally posted by Mark Havel
Try to look if it's working under other DE such as GNOME or XFCE or IceWM or whatever else. If yes, it is certainly because KDE has its owns sound server, aRts, which monopolizes your sound card and your programs don't send the sound to aRts. So you must configure them to use the aRts output instead of ALSA or others outputs.
Or perhaps you can just disable aRts at the KDE launch...
i got the same problem on a latpot, a compaq presario 1005EA, when KDE start the mute button of my pc start to work. and so no software error, but no sound comes out... i have upgraded to kde 3.2 with kernel 2.4.24

any suggestion?
 
Old 05-11-2004, 04:07 AM   #9
amishtechie
Member
 
Registered: Apr 2004
Distribution: Pop OS
Posts: 130

Rep: Reputation: 17
I had the same problem too. Go into Control Center under sound and multimedia. In the mixer subsection uncheck the box next to "load volumes on login". You will have to do this for all users. Run alsamixer and alsactl store and you are good to go.
 
Old 05-11-2004, 04:57 AM   #10
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
i have only user root on my machine, i've tried to uncheck that box, of course nothing happened instantly cause the mute button was enabled (and i couldnt disable it because kde was started) then exit from KDE (mute button still enabled) run alsamixer, all was ok, no mute on any channel then quit alsamixer, run alsactl store.. mute button still enabled.. rebooted.. start slackware. and this time there was a news!!! : now the mute button is enabled still on console mode!! before i've to login! incredible... have i done wrong something?
 
Old 05-11-2004, 05:02 AM   #11
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
an integration...
i have KDE 3.2 not 3.2.1....
 
Old 05-11-2004, 05:11 AM   #12
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
another integration...

the mute button became enabled when those 2 strings are loaded in the boot process :

"Loading ALSA mixer settings : /usr/Sbin/alsactl restore
Loading OSS compatibility modules for ALSA."

uhmmmmm ???!?!?!?!!?
 
Old 05-11-2004, 07:31 AM   #13
Mark Havel
Member
 
Registered: May 2004
Location: Lyon, France
Distribution: Slackware
Posts: 85

Rep: Reputation: 15
This is very bad an quite unsafe to log in only as root. You should create a normal user you will use in the future.

The messages just means that ALSA is loading the stored settings and the OSS compatibility; OSS is an old sound API like ALSA.
 
Old 05-11-2004, 07:40 AM   #14
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
Quote:
Originally posted by Mark Havel
This is very bad an quite unsafe to log in only as root. You should create a normal user you will use in the future.

The messages just means that ALSA is loading the stored settings and the OSS compatibility; OSS is an old sound API like ALSA.

why unsafe?? i'm the only one that will use slackware on that laptop...
anyway.. i have another user on that pc... but as i've said.. the mute button become enabled during the boot process. so if login with the other user the mute button remain enabled... i think this is not the point...

i've unchekd the load volume setting at startup in the kde sound panel...
dunno what to do now...
 
Old 05-11-2004, 11:08 AM   #15
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
Quote:
i've unchekd the load volume setting at startup in the kde sound panel...
dunno what to do now...
what are the permissions for......../dev/mixer or /dev/mixer0
and /dev/dsp or /dev/dsp0---???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do you turn off sound in KDE if you don't use KDE? solusrex Linux - Software 1 07-29-2005 09:56 PM
KDE blocks sound? cant play sound from other programs. Smurfen Linux - Hardware 1 04-02-2005 08:14 PM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 02:05 AM
kde sound options gone except for root, login sound gone memphisSuseUser Linux - Distributions 2 12-10-2004 06:55 PM
Gnome has sound/switch to KDE no sound Lar Fedora 6 11-05-2004 04:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration