LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-04-2008, 06:49 PM   #16
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,260

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481

Quote:
Or maybe 1280x1024 and above, since I have the same (harmless) issue with a 1680x1050 display (though Franklin has a 1440x900 display, from the looks of it, and it is accurate).
Or perhaps a conflict with the nvidia driver:

NVidia and XRandR 1.2

After I bumped into that thread, I ran a quick test. I exited X and changed the xorg.conf from nvidia to nv (I keep copies of both configuration files for easy changes). I started X, checked the KDE control center and I saw 75 Hz. I ran xrandr and I saw 75 Hz. Perhaps then xrandr is not the culprit. Seems the nvidia driver is somehow confusing xrandr.

So in a way, problem partially solved.

Edit: Problem Fully Solved (At Least For Me)

Sometimes persistent pays. Sometimes.

I ran across an nvidia forum thread, which led me to this page (read the very last item at the bottom).

The solution for me, to eliminate the vertical refresh rate number discrepancies, was to add the following to the Screen section in my xorg.conf:

Option "DynamicTwinView" "false"

Now there is no discrepancy when using the 169.09 nvidia driver. Every tool reports 75 Hz, including xrandr, which now reports both frequencies that the monitor supports (60 and 75 Hz). KDE now even offers me the option to use 60 Hz.

I hope this information helps others.

Last edited by Woodsman; 05-04-2008 at 07:44 PM.
 
Old 05-04-2008, 09:20 PM   #17
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,231

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
Good sleuthing, Woodsman. "And that's the end of that chapter."
 
Old 05-04-2008, 09:46 PM   #18
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
That was indeed a great piece of investigative work there, woodsman. Good job!
 
Old 05-05-2008, 03:15 AM   #19
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by Woodsman View Post
I hope this information helps others.
Works. This certainly should be put into FAQ somewhere.
 
Old 05-05-2008, 11:53 AM   #20
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,260

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Quote:
That was indeed a great piece of investigative work there, woodsman.
Everybody who participated in this thread deserves the kudos. I merely rearranged the pieces of the puzzle based upon the discussion. But thanks.

Quote:
Works. This certainly should be put into FAQ somewhere.
One caution, I have no idea how this solution affects people who use multiple monitors.
 
Old 05-05-2008, 11:22 PM   #21
speck
Member
 
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 271

Rep: Reputation: 54
Just confirming that /Option "DynamicTwinView" "false"/ fixed the xrandr output for me as well. Good job tracking that one down Woodsman.
 
Old 09-25-2008, 08:29 PM   #22
sunman
Member
 
Registered: Jun 2005
Distribution: Slackware64 13.0 (multilib)
Posts: 67

Rep: Reputation: 15
The DynamicTwinView false also works for me, I have a two-screen setup that uses an emachine monitor (eview 17f3) and a Vizio HDTV and never had the correct refresh rates displayed for either, I believe 50Hz was shown for both screens. Adding that option shows the correct refresh rates for both screens now, with the CRT running at 1280x1024@60Hz and the HDTV running at 1024x768@75Hz.

The only thing I notice right away is that you can't use the twinview setup through nvidia-settings like you could before, which only makes sense since it's disabled now. Not a big deal to me since the screens are already set up how I want them.

I'd also like to mention that you can also check to see what refresh rate your monitor is running at by checking the on screen display if there is one. Even though KDE was showing 50Hz as my only option for vertical refresh, pushing the button to bring up the OSD for my monitor always showed 59.9Hz when I was running at 1280x1024. Another way to check vertical refresh, if you are using an nvidia card and the proprietary drivers at least, is to run nvidia-settings and under the opengl settings for your monitor check the Sync to VBlank box. Then run glxgears and the output should give you an idea. Doing this on my box gives something like:

303 frames in 5.0 seconds = 60.450 FPS
301 frames in 5.0 seconds = 60.023 FPS
301 frames in 5.0 seconds = 60.030 FPS

Which fits pretty well with what I already know it's running at.

Thanks for the fix
 
Old 09-26-2008, 12:44 AM   #23
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,216

Rep: Reputation: 176Reputation: 176
hey guys check out this post, it fixed my problem http://www.nvnews.net/vbulletin/show...52#post1421852

Nevermind, I guess I should of read the full post, lol

Last edited by Daedra; 09-26-2008 at 12:58 AM.
 
Old 09-26-2008, 04:43 AM   #24
harryhaller
Member
 
Registered: Sep 2004
Posts: 428

Rep: Reputation: Disabled
Quote:
This certainly should be put into FAQ somewhere.
And give it a good rating! (button on top-right of first post)
 
Old 05-29-2009, 07:58 PM   #25
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,260

Original Poster
Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
To anybody interested, the problem solution posted in this thread is still required with the 180.29 drivers. I was testing a similar xrandr problem with the generic nv driver and I thought I'd check the proprietary side again. No change: without the xorg.conf options xrandr gets confused.
 
Old 05-29-2009, 08:46 PM   #26
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,216

Rep: Reputation: 176Reputation: 176
IF your using the nvidia driver then add this option to your xorg.conf
under the "Device" section

Option "DynamicTwinView" "false"

This will fix the 50Hz refresh problem. For more details see this post
http://www.nvnews.net/vbulletin/show...52#post1421852

Nevermind I got a head of myself, this was answered in the first post, lol

Last edited by Daedra; 05-29-2009 at 08:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertical Refresh Rate shawniecas Linux - General 27 08-17-2007 04:56 PM
How to find my horizonal and vertical refresh rate girlintrouble Linux - Hardware 4 05-16-2006 03:54 PM
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 02:36 AM
Screen with multicolored vertical lines / Refresh rate very low wittyguysuku Fedora 2 08-24-2005 01:54 AM
Horizontal and vertical refresh rate johannes Linux - Laptop and Netbook 3 10-31-2003 05:44 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration