LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 04-20-2006, 02:22 PM   #1
garfield1228
Member
 
Registered: Apr 2006
Posts: 71

Rep: Reputation: 15
Unusual ndiswrapper problems with hp dv5000


PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 0 of device 0000:06:00.0
PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

This is the warnings i get when i boot everytime with boot option acpi=off otherwise my system hangs forver after this.
In the above warnings PCI: Cannot allocate resource region 0 of device 0000:06:00.0 belongs to my wireless card, i have found out.
I have used Ndiswrapper to configure wireless, and followed all steps given in the forum. I have also written 2 scripts -
/etc/sysconfig/network-scripts/ifcfg-wlan0 ,keys-wlan0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
TYPE=Wireless
DEVICE=wlan0
HWADDR=00:13:02:0c:80:f9
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=Auto
CHANNEL=1
MODE=Managed
RATE=Auto

/etc/sysconfig/network-scripts/keys-wlan0
KEY=<my key>

also did modprobe ndiswrapper and ndiswrapper -m which added alias to its conf file.

when i reboot it says device not found.
After boot when i use ifconfig wlan0 up it says device not present.
Using system-config-network i could add the device but not activate it ...

AM very sad not able to auto load wireless till now using ndiswrapper. i think it has to do something with those warnings i get even thgh i give acpi=off i want to get them removed also.IT looks sick when computer starts.

But the other way using my wireless driver ipw3945 i have been able to connect but not able to load it automatically. I have written similar scripts for it also for eth1 device. At boot it says device not found. But when i do dmesg i get -
ieee1394: Initialized config rom entry `ip1394'
PCI: Setting latency timer of device 0000:06:00.0 to 64 (<- see the warning i get on top)
ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection

god knows whats the problem but this way atleast manually i am able connect... but using ndiswrapper neither manually nor automatically i am able to connect...

can anyone help me with these questions-
1)how to remove these warnings.
2)how to solve the ndiswrapper issur
3)using my wirelss drives for linux how can i automatically connect at boot
4)is their any irq issue or acpi issue how to solve it
I am sick and tired of trying this for a long time is this solvable at all...
 
Old 04-20-2006, 03:13 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
I have a zv5000 laptop. I was wondering whether your's uses a 32bit CPU or a 64bit AMD 64. Also, what controller does it use or are you adding a wireless card? I believe that the DV5000z uses a builtin broadcom controller and the DV5000t has an add-on intel controller option.

It looks like you are having a problem with the driver and not a network or wireless setup problem.
There are two quick things you can try, which probably won't help but shouldn't hurt.
A) run as root "depmod -a". Just in case this was interupted when you installed the driver.
B) run as root "ldconfig". This will update the library paths, and is usually run periodically anyway.

You may try 1) Shut down the interface if it is up so you can 2) rmmod ndiswrapper. Then re-enable acpci and try starting over. You might try the "noapic" option instead. I believe this is used for smp kernels with more than one processor, and using "noapic" won't do any harm. You might try downloading a newer version of ndiswrapper.

Good Luck!
 
Old 04-20-2006, 03:51 PM   #3
garfield1228
Member
 
Registered: Apr 2006
Posts: 71

Original Poster
Rep: Reputation: 15
i have a centrino core duo processor, with a intel pro 3945abg wireless card. I have installed FC5 and updated to 2.6.16.2080-smp kernel. These duo processor is new in market and i have no idea how to configure linux properly on it, it has been giving me problems.I want all those warnings to be removed.
I know this is 2 processors so its not working properly and i have no idea how to fix this. If i give only noapic boot option it still hangs, if i give acpi=off it gives all those warnings but atleast after a small delay it boots...
Any idea about how this centrino core duo processors support options for fc5...Regarding ndiswrapper i had downloaded the latest tar file version 1.14 from sourceforge.net.

plz help me.

Last edited by garfield1228; 04-20-2006 at 03:53 PM.
 
Old 04-21-2006, 03:12 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
It seems that more than one device is affected. I wonder if there might be a bios upgrade. For a new model with new technology, this wouldn't be unheard of.

I tried looking for an answer in google. There were several instances of similar messages involving the yenta pcmcia kernel module. If your wireless device is a card, this may be something to look for in bug reports on the web.

Do some of the messages posted exist if you don't boot up with the ndiswrapper kernel module?
Sorry I don't have any answers, but I did look.
 
Old 04-21-2006, 03:26 AM   #5
garfield1228
Member
 
Registered: Apr 2006
Posts: 71

Original Poster
Rep: Reputation: 15
thanx for trying atleast, i hadnt got any reply by nayone on similar issues for my posts ...
 
Old 04-21-2006, 04:32 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Try using this string in quotes in your searches along with the version of your kernel in web searches:
"PCI: Cannot allocate resource region"

Also check for overlapping resources which may be able to be resolved. I wouldn't use NOACPI unless the CDROM doesn't even boot, and I would use it only during the installation. I believe one of the features of ACPI feature is the sharing of interupts and assigning resources which could cause some of these problems.

You might try a usenet search on google also, in the Fedora group.
 
Old 05-06-2006, 10:39 AM   #7
ptraca
LQ Newbie
 
Registered: May 2006
Location: Lisbon
Distribution: FedoraCore4, SuSe10
Posts: 1

Rep: Reputation: 0
Solution on FC4 and FC5

I, i have a Toshiba P100-103, Dual Core and when i installed FC5 on my new machine i had the the same problems.
The installation process went great, but when i rebooted it would hang while starting udev and i had the same warning messages.
It would only boot with acpi=off.
This is a problem with pcmia, to fix this you have to edit the /etc/pcmcia/config.opts file and change the line
--> include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff
to
-->include port 0x100-0x4ff, port 0xc00-0xcff
removing the 0x800-0x8ff. This will allow you to boot with acpi enabled.
Add the following kernel flags to grub.conf pci=assign-busses pci=routeirq.

--> kernel /vmlinuz-2.6.16-1.2096_FC4smp-firefly ro root=/dev/VolGroup00/LogVol00 rhgb pci=assign-busses pci=routeirq

about the warning message for pci, that's a problem that is waiting for some free time.

hope that helps
 
Old 05-07-2006, 06:45 AM   #8
garfield1228
Member
 
Registered: Apr 2006
Posts: 71

Original Poster
Rep: Reputation: 15
thnx ptraca , it works great ... but could u figure out how to remove the warnings ...
 
Old 05-10-2006, 03:36 PM   #9
deep_jyotsingh
LQ Newbie
 
Registered: Mar 2006
Location: New Delhi India
Distribution: Suse
Posts: 22

Rep: Reputation: 15
i to have same laptop and i am too facing the same problem with FC5. Being new with linux can anyone please guide me how to do acpi=off.
Is it done when we install the FC5 or we can do it latter when it is installed.
and also how do i get that graphic nvidia card of mine to work.

Last edited by deep_jyotsingh; 05-10-2006 at 03:44 PM.
 
Old 05-11-2006, 09:08 AM   #10
garfield1228
Member
 
Registered: Apr 2006
Posts: 71

Original Poster
Rep: Reputation: 15
while boot when it shows ur operating systems list -
select FC5 and press a, then in the end give a space and type acpi=off
once its booted, login and open ur /boot/grup/grub.conf and add the above entry to that file so that it gets added permanantly so that u dnt have to do it again and again ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 10.0 install problems on HP dv5000 RyRyH Linux - Laptop and Netbook 17 05-21-2006 08:42 AM
Unusual Partitioning Problems Steve314 Linux - Newbie 5 01-23-2005 01:19 PM
Unusual problems mounting iPod. yarjar Linux - Hardware 2 12-18-2004 02:48 PM
mandrake boot problems(various), possible bug report, my unusual story :P OmniXBro Mandriva 4 03-12-2004 06:08 PM
Unusual install problems. raid517 Linux - Software 0 08-08-2003 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration