LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Sabayon
User Name
Password
Sabayon This forum is for the discussion of Sabayon Linux.

Notices


Reply
  Search this Thread
Old 09-20-2017, 04:01 PM   #1
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,124
Blog Entries: 3

Rep: Reputation: 180Reputation: 180
Unable to boot Sabayon after uefi install


Here is my disk layout:
Code:
GNU Parted 3.2
Using /dev/nvme1n1
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: Unknown (unknown)
Disk /dev/nvme1n1: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  211MB  210MB  fat32        EFI System Partition  boot, esp
 2      211MB   735MB  524MB  ext4
 3      735MB   250GB  249GB                                     lvm
/boot is on partition #2

/root and /home reside on the lvm partition.

I can supply you with anything you need to help me.

As the OP I get through the entire setup but once rebooted I cannot boot Sabayon.
I boot a usb stick that boots uefi without issues.

Any and all help to get this going is most appreciated.
 
Old 09-20-2017, 05:56 PM   #2
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,234

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
1. Where is the efi partition mounted in your fstab?
2. Was grub used as the bootloader and if so is there a grubx64.efi in a subfolder of EFI on your efi partition?
 
Old 09-20-2017, 09:02 PM   #3
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,124
Blog Entries: 3

Original Poster
Rep: Reputation: 180Reputation: 180
Quote:
Originally Posted by colorpurple21859 View Post
1. Where is the efi partition mounted in your fstab?
Here is the fstab from the installed Sabayon:
Code:
#
# /etc/fstab
# Created by anaconda on Wed Sep 20 02:15:57 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=1b0660e6-3769-410e-8841-36dcf2e2fd44 /                       ext4    defaults        1 1
UUID=da4ceba0-52c8-4ee0-8a81-d6e9196c154c /boot                   ext4    defaults        1 2
UUID=78A0-C987          /boot/efi               vfat    umask=0077,shortname=winnt 0 0
UUID=73f2150b-f903-4744-a48d-3e4ac76934cc /home                   ext4    defaults        1 2
UUID=5e42010e-581e-4a94-851b-fb2184e21c58 swap                    swap    defaults        0 0
Quote:
2. Was grub used as the bootloader and if so is there a grubx64.efi in a subfolder of EFI on your efi partition?
I've mounted the efi partition and I can see the following:
Code:
sabayon ramdisk # ll /tmp/sabayon_os/
total 1
drwxr-xr-x  3 root root 512 Jan  1  1970 .
drwxrwxrwt 12 root root 300 Sep 21 00:50 ..
drwxr-xr-x  3 root root 512 Sep 20 02:15 EFI
sabayon ramdisk # ll /tmp/sabayon_os/EFI/
total 2
drwxr-xr-x 3 root root 512 Sep 20 02:15 .
drwxr-xr-x 3 root root 512 Jan  1  1970 ..
drwxr-xr-x 2 root root 512 Sep 20 02:17 sabayon
sabayon ramdisk # ll /tmp/sabayon_os/EFI/sabayon/
total 122
drwxr-xr-x 2 root root    512 Sep 20 02:17 .
drwxr-xr-x 3 root root    512 Sep 20 02:15 ..
-rwxr-xr-x 1 root root    775 Sep 20 02:17 enroll-this.cer
-rwxr-xr-x 1 root root 122880 Sep 20 02:15 grubx64.efi
Nothing is jumping out at me presently as an issue.
 
Old 09-20-2017, 09:20 PM   #4
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,234

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
create an EFI/Boot on the efi partition and copy the grubx64.efi to it, if that doesn't work then rename the EFI/Boot/grux64.efi to bootx64.efi
 
Old 09-21-2017, 10:14 PM   #5
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,124
Blog Entries: 3

Original Poster
Rep: Reputation: 180Reputation: 180
colorpurple21859, Thanks for the insight. This fixed the booting now I have another issue. KDE doesn't start. When I run startx I get 3 white windows that I can click on and exit out of but no KDE. I thought maybe it wasn't installed but that wasn't the case either. I'm at a loss as to why I cannot start KDE. I get dropped directly into the CLI.

I tried looking for the latest version of Sabayon but the web site only has 16.11 which I already have. Do you knowe where I can DL the latest 17.10 iso? Might have something to do with the install want to try a new install using 17 instead of 16.
 
Old 09-21-2017, 10:21 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, puppy, ubuntu
Posts: 2,234

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
I don't know much about sabayon, have you looked at your xorg log for errors? Maybe turning off kde compositing will help.
 
Old 09-22-2017, 10:58 PM   #7
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,124
Blog Entries: 3

Original Poster
Rep: Reputation: 180Reputation: 180
Looks like it might be a display manager. I switched from lightdm to sddm and I can get it to start from the command line just not at boot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to install Slackware 14.2 64 bit [UEFI] Bourbon Slackware 7 07-04-2016 12:59 PM
sabayon uefi rbrick49 Sabayon 3 10-14-2015 09:39 AM
[SOLVED] Unable to install Kubuntu 14.04.1 LTS on UEFI system. americast Linux - Laptop and Netbook 25 04-20-2015 03:43 PM
LXer: Sabayon 11 with UEFI SecureBoot support LXer Syndicated Linux News 0 02-18-2013 01:20 PM
Sabayon 8 Installation issues - Sata Raid unable to boot (via grub) leo_mancini Linux - Software 1 05-02-2012 10:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Sabayon

All times are GMT -5. The time now is 11:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration