-   Sabayon (
-   -   Sabayon and Windows "My Documents" not showing (

bikrmagi 04-02-2010 11:06 AM

Sabayon and Windows "My Documents" not showing
I've been running several live distros trying to decide on which to install. Mostly I've been having good results with Mint with the exception I miss the "details" view in the file browser. It does pretty much everything else, editing graphics in GIMP, internet browsing using Firefox, maintaining my MP3 collection and Open Office stuff. And it sees the files on my Windows NTFS partition.

The other distros I like are Mandriva (I'm anxiously waiting for the next release!) and Sabayon.

But most odd is the fact that the recent Sabayon release does not see the files in my "My Documents" folder on the NTFS partition. Other stuff it sees, like files on the desktop for example.

Perhaps this is a anomaly? Something I have to do different?

I'm a database programmer on the Windows side, and have run a SCO server when I was at Microsoft in support of one of their products, so I'm not totally dense with 'nix stuff, like oak, just like pine perhaps.

Any ideas?

lrfocke 04-02-2010 11:45 AM

I can't help you in Sabayon but I can in Mint. In your file browser go to view > list. It's close to the bottom of the drop down window. this should show you the information similar to Details in MS Windows. Things like File Name, Size, Type, and Date modified. Heck, it even gives you the time zone where it was created, whether standard or daylight.

As far as Sabayon, have you checked the permissions of the folder in Windows? This would make sense why you might not be able to see them. While in Mint, can you see them open, open them but not save them?
This might help in pinpointing the problem.
Hope this helps.


bikrmagi 04-04-2010 10:40 AM

OK - point of density on my part - I should have said that I am able to not only see but also access and write and create files under Mint, but Sabayon ... sees 0 files in the directory. It would SEEM odd for it to be a rights thing if one distro can freely access the subdirectory, but not the other distro, right?

lrfocke 04-05-2010 02:10 AM

Sorry to have ask one more question about your access in Mint. When you access an existing file, can you edit and save the file without changing the name? Also what version of Sabayon are you using? 32bit, 64bit, the latest release? let me know and I will download it and run inside VirtualBox and see if I can duplicate your problem. I will go download the latest version now and install it. I will also run it as a live CD as well since that is the way that you are testing it. I will let you know what I find out. Keep me informed as to how you are faring.

lrfocke 04-05-2010 12:30 PM


Here is where I am at this moment. I have ran Sabayon 5.2 32bit gnome release. The download was a iso of 1.6 gig. It just came out so I don't know if you are trying 5.2, 5.1, gnome or KDE, what version of Windows are you using?

My version of Windows is Win7 home premium 32bit (ntfs). When Sabayon booted up from the live DVD, I first mounted my Windows partition went to My Documents folder and everything was there! I even opened a .doc file edited it and saved it. No such glitch on my setup. I had hoped that I could reproduce your problem. The only thing that I can think of now is maybe you are using KDE or 64bit OS', which still doesn't make sense but I'm not sure where to go from here.

It does look like a nice distro so I am going to run it inside VirtualBox and give it a try. I don't personally need a Media Center machine but sometimes my clients want one and are tired of MS and it's inherent problems, so I keep looking for a great distro that will suit their needs, I get tired of always having to setup a media center. HA

Have you used virtualBox before? I find it a great environment for testing distributions. The only thing about it though is you can't mount the whole host drive but folder sharing is relatively easy.
I hate to keep asking for more info, but without it I don't know where to go.


bikrmagi 04-06-2010 11:16 AM

Thank you for looking into this, I appreciate you asking for more info. If you need even more than what I provide here, please let me know.

My HP Elitebook 2530p is running Microsoft Windows XP Professional, Version 5.1 (Build 2600.xpsp_sp3_gdr.091208=2036: Service Pack 3). The ISO of Sabayon I downloaded was the 3/26 release and the 1.6GB download (smaller of the two variants).

With The latest Mint Live CD I am able to use a variety of apps to view the "My Documents" directory for my username. I can use Open Office Writer to access, modify, and in fact create files. I can use the text editor and do the same. GIMP as well. But the Sabayon live DVD sees 0 files in the My Documents directory using the file browser. Nor can any of the apps in Sabayon see anything in the directory using "file::open."

lrfocke 04-07-2010 10:05 PM

I have installed Sabayon inside VirtualBox and have tried to get it to replicate your problem. I can't seem to do it. The only difference that I can see is that you have XP and I no longer own a copy so I can't try that combination. I cant do a native install as my current system doesn't have the room. Shouldn't make a difference anyway. So we have to look elsewhere. Have you checked your .iso to see if the checksum matches? Also after you burned it to disk did you check the integrity of the disk to make sure that the copy is good? What speed did you burn it at? Sometimes if you burn it at a fast speed, say over 4X, it can generate some bad sectors. Maybe, just maybe there is a bad sector in just the wrong spot.
Try burning a new DVD as slow as you can and check its integrity after completion. Then try it LIVE and see if the files appear. I know it's a long shot but at the moment, it is all that I can think of. I would say to dual boot with Mint 8. I find that it is an excellent distro and more than suits my needs. I also know Debian based systems much better than I do Gentoo.
I hope this helps.

bikrmagi 04-08-2010 11:20 AM

Curious. I have not checked the integrity, figuring that no errors reported in the burn process was sufficient. Will look into finding a high-speed wired connection (I am in an extended out-of-town scenarion caring for an aged relative, and I rely on wifi in a coffee shop for my daily internet) to do a new download.

lrfocke 04-09-2010 01:31 AM

Before you go to that trouble, let me see if I can get the checksum for the iso image so you can check it on you existing copy. Do you still have the iso on your system? What program did you use to burn your DVD? This might help me find what might help you. When you burned the DVD did it automatically check its integrity? If so that should mean that the burn is not the issue. The only thing that I can think of then would be a glitch in the iso. Mmm, this is a stumper. I'll look into the checksum.

bikrmagi 04-09-2010 11:09 AM

I usually use a little thingy called ImgBurn ( which has not presented any problems. But they do have a new version out that I didn't have.

lrfocke 04-10-2010 12:00 AM

Okay, first here is the checksum as generated by md5sum inside linux:

4601c2ad6dedb652c228f5388093c790 for Sabayon_Linux_5.2_x86_G.iso

Like I said before, when I ran this iso the files showed up for me. There is something else that I need to say though. I was trying another distribution that I thought that might work for you called Zorin OS 2. Guess what happened when i ran it in a live session? You guessed it, no files in My Documents! Go figure that one out. So I made a Usb live persistent drive booted it up and still no files. I then updated the OS hoping that this would solve the problem thinking that just maybe the update would fix what ever was causing the fail. No luck again.
The funny thing is that it is based on Debian/Ubuntu just like Mint. Foggier and foggier. The next thing that I am going to do is run Zorin as a guest inside Windows and see if I can share the folder. This might tell me if you do a native install of Sabayon that you should be able to mount the folder. I can't figure out why this is happening and I don't like things that I can't figure out.
Anyway, I will give you an update later.


bikrmagi 04-10-2010 11:43 AM

Marvelous! As a former product support guy for M$, I actually liked it when I could actually duplicate the problem ... it told me then that the guy wasn't an idiot, and that memory tells me now that maybe I'm not so stupid if someone else can actually see what I mean.

Of course, now the question is, WTF is causing it?

lrfocke 04-10-2010 12:16 PM


Got it!!
I have figured it out and as usual there is nothing wrong! Your files are accessible. It turns out that "My Documents" is empty. It is supposed to be. "My Documents" is just a symlink pointing to another directory or "folder." The real directory is "Documents." inside your user directory. Once you start your live session, mount your Windows drive then go to "Users>your-account>Documents. Everything is there! This is true in Win7 and should also be in XP. It could be a different directory but I doubt it. There are two XP machines that are owned by my housemates, when I get the opportunity I will check it on one of their machines. That simple.
Why some live sessions sees "My Documents" as a legitimate directory and not a symlink is the real mystery. If I used Windows more frequently I might have recognized this sooner. So now you have to choose which distribution you wish to use. If you get a chance you should check out Zorin OS 2 as well. It is sort of in between Sabayon and Mint and based on Debian/Ubuntu so I am more used to the layout and upgrade path. I can't say how stable Sabayon and Zorin are as they are using the latest kernels and programs that some say are still untested to the point of calling them "unstable" even though you may never experience any crashes. I can say that after using Mint for over a year, I have never had a crash or glitch. For Sabayon, the install is a bit confusing for me but that might just be that I have never used a Gentoo disto before. I would check out the install process first before installing as a dual boot just to be on the safe side.
Good luck man, I hope this helps. Oh, if you ever wish to get in touch with me about any future problems, check my profile and leave me a message. Don't forget to mark this solved if it works for you like it did for me.
Sorry if I write like I am talking to a noob, it's just a habit of having to trouble shoot via e-mail. HA


bikrmagi 04-11-2010 01:14 PM

Can't wait to get home and try it out ... thanks for the suggestion! ...A

bikrmagi 04-12-2010 12:20 PM

Sadly, the suggestion did not resolve the case. What is even odder is that the "My Documents" folder for the other Windows user (an admin) does show! But not mine. :(. Maybe I'll just keep trying to find a distro that does work for me.

Had great hopes for MCNLive, but cannot activate the wireless card on my HP Elitebook 2530p to get online and use the remaster ability to add OpenOffice and GIMP.

All times are GMT -5. The time now is 06:36 AM.