LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Sabayon
User Name
Password
Sabayon This forum is for the discussion of Sabayon Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2009, 02:43 AM   #1
altairz
Member
 
Registered: Nov 2009
Distribution: Mandriva
Posts: 34

Rep: Reputation: 15
problems with volume controlling..?


I go to "open volumecontrol", and choose output.
Then I have three choices:
1. dmix:0
2. Internal Audio Analog Stereo
3. Internal Audio Digital Stereo (IEC958)

I want it to be nr. 2, so I set a mark on nr. 2, and everything works as I want it to.
But, when I restart the computer, the mark has jumped down to nr. 3.

Why does this happen? I want it to always be on nr. 2, not nr. 3.

Thanks for answers
 
Old 11-17-2009, 10:48 AM   #2
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Have you tried 'alsactl store' ? This will save your setting to /etc/asound.state

You might also want to add alsa to default runlevel if you have not already done it.

Check 'rc-update -s' to see whether alsa is already loaded as default

if it is not do this 'rc-update add alsasound default'

HTH
 
Old 11-17-2009, 12:10 PM   #3
altairz
Member
 
Registered: Nov 2009
Distribution: Mandriva
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by hurry_hui View Post
Have you tried 'alsactl store' ? This will save your setting to /etc/asound.state

You might also want to add alsa to default runlevel if you have not already done it.

Check 'rc-update -s' to see whether alsa is already loaded as default

if it is not do this 'rc-update add alsasound default'

HTH
Alsa was loaded in default.

When I type "alsactl store", is it just to type it in the terminal as root. Or is there more I have to do?

Last edited by altairz; 11-17-2009 at 01:53 PM.
 
Old 11-19-2009, 03:06 AM   #4
hurry_hui
Member
 
Registered: Oct 2008
Location: Near Jakarta
Distribution: Slackware, Arch, Slax, Porteus, Tiny Core, Slitaz
Posts: 355
Blog Entries: 1

Rep: Reputation: 51
Quote:
Originally Posted by altairz View Post
Alsa was loaded in default.

When I type "alsactl store", is it just to type it in the terminal as root. Or is there more I have to do?
Try first by typing it in the terminal / konsole. Or you might want to check for 'alsactl --help' for more info.

HTH
 
Old 11-20-2009, 12:13 PM   #5
altairz
Member
 
Registered: Nov 2009
Distribution: Mandriva
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by hurry_hui View Post
Try first by typing it in the terminal / konsole. Or you might want to check for 'alsactl --help' for more info.

HTH
I sat the volume control to nr. 2, I typed in "sudo alsactl store", but it went down to nr. 3 again as soon as i re-started. I also tried to type in just "alsactl store". So that command probably won't store the settings I make for the output.
 
Old 01-01-2011, 09:47 AM   #6
raman78
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by altairz View Post
I sat the volume control to nr. 2, I typed in "sudo alsactl store", but it went down to nr. 3 again as soon as i re-started. I also tried to type in just "alsactl store". So that command probably won't store the settings I make for the output.
The problem is with pulseaudio. I had the same problem. To solved this I did:
mv /usr/bin/pulseaudio /usr/bin/pulseaudio.stfu && reboot

This command is disabling pulseaudio. On restarting X you will be have message about lost device, click ok.
It's brutal method but it's working. Now the alsamixer is stored correctly and kmix is displaing good volume controls.
"alsactl store" working correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with volume controlling..? altairz Linux - Software 2 11-03-2009 09:09 AM
Mouse gestures not seen in xev, volume not controlling PCM jabulani_jonny Linux - Hardware 1 05-07-2006 10:01 PM
Volume Control Not Controlling Talendel Fedora 1 05-31-2005 03:20 AM
Volume problems jaslowe Linux - Software 1 05-25-2005 04:58 AM
Controlling Volume of all outputs with one main slider Boffy Linux - General 3 09-08-2004 04:21 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration