LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   XServer problems for ROOT !! (https://www.linuxquestions.org/questions/red-hat-31/xserver-problems-for-root-228272/)

theGuru 09-08-2004 03:19 PM

XServer problems for ROOT !!
 
Hello everyone,

Newbie to Linux here. I have Redhat 9.1 installed on my computer. It was working fine till I installed " keychain-2.3.5", a software to enable me ssh to other machines using my system public key rather than asking for my password.

The problem is, when I login as root and try to start the XServer, it gives me

"XIO: Fatal IO error 104 Connection reset by peer on X Server ":0.0" after 0 requests (0 known processed) with 0 events remaining"

startx seems to work for all others users to that computer. Does any one have any idea ! I am puzzled cuz the all powerful root cannot get in whereas others can !

Thank you!
theGuru.

fenderman11111 09-08-2004 03:45 PM

solution: don't run xfree as root... number one unix nono is to use root as your normal system account. (trust me I learned it the hard way when I accidentally did rm -rf /home/* back in my n00b days)

You should make yourself a normal user account and only use root when you need to change something (via sudo or su, etc).

theGuru 09-09-2004 07:14 PM

Wouldn't do that...still
 
Hey ...

Thank you for the word of caution. I won't do it... but still would like to know what
could be done to get my X Server up and running in the root account. I don't login as root
for daily usage but I am a n00b and makes life a lot simpler with the GUI when I wanna
install something or so.

Thank you guys.
theGuru.

jojotx0 09-09-2004 07:49 PM

have you tried going into init 3 (text mode) and logging in as root, and then starting XServer?

theGuru 09-11-2004 04:26 PM

yes
 
yes... my initlevel is set to 3 so everytime I bootup, I don't start X Server directly. Still doesn't work
Works for other users though


All times are GMT -5. The time now is 09:10 AM.