-   Red Hat (
-   -   xfs, inode64, NFS export, no_subtree_check and "Stale NFS file handle" message (

mcacciagrano 01-12-2011 10:31 AM

xfs, inode64, NFS export, no_subtree_check and "Stale NFS file handle" message
Here is the problem:
I have a 20TB filesystem, xfs formatted. The filesystem has been mounted with the inode64 option, and I now need to NFS export it.

NFS doesn't like the inode64 option at all. The NFS clients cannot access any of the directories with inode numbers exceeding the 32bit limit. They get the "Stale NFS file handle" message.

I have tried to attach the filesystem to a RHEL5.3 system, and after turning on the no_subtree_check option in /etc/exports on the server, it all works fine. No changes were needed on the clients.

The problem is that I need to get this to work on a RHEL4.4 system.
Unfortunately I cannot do any test on that system yet, I then did a quick test on a RHEL4.3 system... and it didn't work.
Even using the no_subtree_check option was on any help. I am afraid that this will not work on the RHEL4.4 system either.

Do you have any suggestions on how to get the inode64 xfs filesystem NFS exported on a 2.6.9 kernel ?



ciotog 01-16-2011 03:25 PM

I read somewhere that someone worked around this issue by creating a bunch of new directories at the same level as the one being exported, and using "ls -il" to see the inodes and find one that was less then 2G. Then move the contents of the exported dir over to it, delete the original, rename it to the original and remount.

Here's a link to the original:

All times are GMT -5. The time now is 06:08 PM.