-   Red Hat (
-   -   Where are sndconfig and isapnp tools located in RHEL3 (ws) kernel version 2.4.21-4 ( (

k_c_kumar 01-30-2004 07:02 PM

Where are sndconfig and isapnp tools located in RHEL3 (ws) kernel version 2.4.21-4 (
Where are sndconfig and isapnp tools located in RHEL3 (ws) kernel version 2.4.21-4 (Taroon)


I recently installed redhat enterprise linux WS on my pc. The kernel version is on i686. I want to completely switch over to linux in due course of time. Now I have starting problems. Hope you guys would help me in resolving. I am new to linux.

1. My sound card is ISAPNP CMI8330 sound card. During the installation Kudzu detected my sound card, however , it did not configure.

I want to manually do the configuration.

At the command prompt I typed sndconfig, for which reply was: command not found.

Redhat installation book says that this tool by defualt is not installed but can be found on the installation CDs. I searched all the CDs but could not locate.

Please help me where the hell is this rpm file? what exactly is the rpm name?

Also same is the case with isapnp tools. When I typed : isapnp /etc/isapnp.conf
the reply was : command not found.

I serached for both sndconfig and isapnp commands in my pc. I did not find them.

I want to install this tool too. Please tell me whether this is available on the CDs. If yes, what exactly is the name?

How can I make my sound card CMI 8330 work in RHEL3(WS).

Thank you very much in advance

aqoliveira 01-31-2004 11:46 AM


by default the sndconfig tool is not installed try using redhat-config-sound this is the new version of the sndconfig tool. Canīt remember which file on the CD but u will be able to use the aboce cmd. Also if u unable to have success with the sound drivers goole to ALSA.


k_c_kumar 01-31-2004 12:49 PM

Hi friend

Thank you very much for your help.

I tried redhat-config-sound at the command prompt in the terminal window after I logged in as root user. The reply is NO SOUND CARD IS DETECTED.

But the dmesg shows as follows:

ad1848:ISAPNP reports CMI 8330 SOUNDPRO PnP version:1.0

cat /proc/isapnp command gives a reply of the same with 4 logical devices being displayed but not active. I know the first one playback device, second one is mpu401, third one joystick and fourth one is soundblaster.

But I do not know how to go further.

But then no sound. This card is working alright under windows98SE with windows sound system534 as play back device and soundblaster220 as record device.

I will look into your advice of ALSA. But before that any further help is highly appreciated.

Thanks in advance once again

k_c_kumar 02-02-2004 02:06 AM


I tried redhat-config-sound and the reply was bash:command not found

I am stuck now.

Any further clues?

coolamit78 02-03-2004 05:18 AM

Since Red Hat has decided to remove the sndconfig utility from the coming versions, you can download and use the 'sndconfig' utility for RedHat 8.0 too...

A google search for the same gives this page..

The following site provides 'sndconfig-0.70-2.i386.rpm' for download..

However, to be able to listen to music on your linux box, you will need to load the appropriate sound module for your soundcard.

for example,

'sb' is the name of the module for the creative sound blaster this device driver can be loaded in memory by the command

modprobe sb

Similarly, in your case, find out what's the module name for your soundcard and then as root, give the command

modprobe <sound-module-name>

This will load the device driver for your soundcard into memory. Now you can run sndconfig and be able to hear the 'test sound'..



k_c_kumar 02-03-2004 08:11 AM

Hi amit

Many thanks for your tip and help. I will follow your suggestion.

After I posted the question in the forum, parallelly I started figuring it out.

The dmesg shows that the system had found 1 isapnp cmi8330 sound card.
The cat /proc/isapnp showed that cmi8330 sound card with 4 logical devices, namely, playback,mpu,joystick,playbakc/record.

so finally I placed the following in /etc/rc.d/rc.local

modprobe ad1848 io=0x530 irq=11 dma=0 soundpro=1

and then I rebooted the linux.

Bingo, Now I can play my music CDs. Then I tried to use sound recorder program. So I hooked a microphone and started to speak into microphone to record. Alas, I cannot record. Nothing happens.

Any tips.

I looked into dmesg again. It reports that as

ad1848:cmi8330 soundpro isapnp sound card detected at : what ever the address I mentioned above.

Then I again looked into cat /proc/isapnp. It reported again 4 logical devices. However, LD0 is shown as active and all other logical devices shown as inactive.

So I am now stuck at this point. That is I cannot record.

Any further help.

Many more thanks well in advance

coolamit78 02-03-2004 02:11 PM

Hi there...

In Linux, there are multiple ways of getting the same thing done...

In my case, what I did was to load the module opl3sa2 first and then use the 'sndconfig' utlity to configure the settings for my card and it works well for all audio uses......Now everytime during the start up sequence, it automatically displays the following message :

"loading sound module ad1848"

So I can play CDs, mp3s and view Videos....However, I have never tried recording, so I cant help you out here...

Now, since your card has been auto-detected, the only thing is, you need to configure it...I suggest that you try the sndconfig utility and check whether u are able to record your voice..



k_c_kumar 02-03-2004 11:29 PM

Hi amit

Thanks again. I will follow your suggestion.

By the way what sound card you have. Can u give your settings present in
the following files.

/etc/rc.d/rc.local or rc.modules
/etc/modules.conf or conf.modules.

just I am curious to know. that's all.

bye for now

coolamit78 02-04-2004 11:57 AM

Hi once more!..

Well, below is the link for a thread where I have explained my sound card's configuration and how I've got things done on my pc...I hope you will find this thread useful.



All times are GMT -5. The time now is 09:51 AM.