-   Red Hat (
-   -   UTF-8 problem (I think) (

GomiCowboy 04-01-2004 10:30 PM

UTF-8 problem (I think)
I've been running Red hat for about a year now and have gotten fairly proficient at it, but I ran up2date a little while ago and it seriously screwed something up with my install of rh9. Here's a sample:

[root@localhost root]# dateconfig
( Gdk-WARNING **: DESKTOP_STARTUP_ID contains invalid UTF-8

So when the window for dateconfig appears on the screen, there are all the buttons but no text (see screenshot here: ). I've tried reinstalling a lot of the rpms from the rh9 cds, but to no avail (all rpms relating to xfree86 fonts, python, and gtk+, gdk, gnome, etc.). Also, after searching on these forums for a while, I tried to run the following command:

rpm -qa|while read pkg;do rpm -V "$pkg";done

which would theoretically show any packages that were missing, broken, etc. but the only ones that I got were :

missing /usr/java/j2re1.4.2_01/javaws/javaws.pack
missing /usr/java/j2re1.4.2_01/lib/charsets.pack
missing /usr/java/j2re1.4.2_01/lib/ext/localedata.pack
missing /usr/java/j2re1.4.2_01/lib/jsse.pack
missing /usr/java/j2re1.4.2_01/lib/plugin.pack
missing /usr/java/j2re1.4.2_01/lib/rt.pack
missing /usr/java/j2re1.4.2_01/lib/unpack
missing /etc/samba/samba.stack
missing /etc/samba/samba.xinetd

So, at this point I'm kind of at a loss. Any help is seriously appreciated.

leonscape 04-01-2004 11:25 PM

DESKTOP_STARTUP_ID is an enviromental variable, that appears is not being set properly.

Try redoing the language set up with the redhat-config-language, as root.

GomiCowboy 04-02-2004 11:33 AM

Thanks for the help, but here's the problem. I can't run redhat-config-language because of this problem. I've reset the language from the install cds but that seems to have no effect. Maybe this is an indication that I should install Gentoo on this machine as well (I've got it on two others and it works without a hitch). Anyway, thanks for the help

ps: "# echo $DESKTOP_STARTUP_ID " returns nothing. And "locale" returns nothing out of the ordinary.

All times are GMT -5. The time now is 01:33 AM.