LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   up2date fails with dependencies i386 & x86_64 rpms for Oracle (https://www.linuxquestions.org/questions/red-hat-31/up2date-fails-with-dependencies-i386-and-x86_64-rpms-for-oracle-548965/)

gatr_head 04-25-2007 02:48 PM

up2date fails with dependencies i386 & x86_64 rpms for Oracle
 
I'm running RHEL4 64bit (update3) with Oracle 10g installed. As we all know, Oracle requires some 32bit rpms to be installed as a pre-req.....every thing is running fine until I go to run up2date and it chokes. I tried running --arch=i386 and --arch=x86_64 and both still fail.

I really suspect, RH can't reconcile the dual rpms of different architectures...

Has anyone encounted this before and what was the fix/workaround?

Thanks.

# Display both arch rpms required by Oracle.
rpm -qa --qf '%{name}-%{version}-%{release}.%{arch}\n' | sort | grep binutil
binutils-2.15.92.0.2-18.i386
binutils-2.15.92.0.2-18.x86_64

# --arch=x86_64 output
up2date --arch=x86_64 binutils

Fetching Obsoletes list for channel: ftid1-rhel4-as-x86_64...

Fetching rpm headers...
########################################

Name Version Rel
----------------------------------------------------------
binutils 2.15.92.0.2 21 x86_64


Testing package set / solving RPM inter-dependencies...
########################################
binutils-2.15.92.0.2-21.x86 ########################## Done.
Preparing ########################################### [100%]
An error has occurred:
Failed running transaction of packages:
('file /usr/include/bfd.h from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/include/bfd.h', 0L))
('file /usr/share/info/as.info.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/info/as.info.gz', 0L))
('file /usr/share/man/man1/addr2line.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/addr2line.1.gz', 0L))
('file /usr/share/man/man1/ar.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ar.1.gz', 0L))
('file /usr/share/man/man1/as.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/as.1.gz', 0L))
('file /usr/share/man/man1/c++filt.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/c++filt.1.gz', 0L))
('file /usr/share/man/man1/gprof.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/gprof.1.gz', 0L))
('file /usr/share/man/man1/ld.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ld.1.gz', 0L))
('file /usr/share/man/man1/nm.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/nm.1.gz', 0L))
('file /usr/share/man/man1/objcopy.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objcopy.1.gz', 0L))
('file /usr/share/man/man1/objdump.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objdump.1.gz', 0L))
('file /usr/share/man/man1/ranlib.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ranlib.1.gz', 0L))
('file /usr/share/man/man1/readelf.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/readelf.1.gz', 0L))
('file /usr/share/man/man1/size.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/size.1.gz', 0L))
('file /usr/share/man/man1/strings.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strings.1.gz', 0L))
('file /usr/share/man/man1/strip.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strip.1.gz', 0L))

See /var/log/up2date for more information




# --arch=i386 output - note referring to 64bit
up2date --arch=i386 binutils

Fetching Obsoletes list for channel: ftid1-rhel4-as-x86_64...

Fetching rpm headers...
########################################

Name Version Rel
----------------------------------------------------------
binutils 2.15.92.0.2 21 x86_64


Testing package set / solving RPM inter-dependencies...
########################################
binutils-2.15.92.0.2-21.x86 ########################## Done.
Preparing ########################################### [100%]
An error has occurred:
Failed running transaction of packages:
('file /usr/include/bfd.h from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/include/bfd.h', 0L))
('file /usr/share/info/as.info.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/info/as.info.gz', 0L))
('file /usr/share/man/man1/addr2line.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/addr2line.1.gz', 0L))
('file /usr/share/man/man1/ar.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ar.1.gz', 0L))
('file /usr/share/man/man1/as.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/as.1.gz', 0L))
('file /usr/share/man/man1/c++filt.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/c++filt.1.gz', 0L))
('file /usr/share/man/man1/gprof.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/gprof.1.gz', 0L))
('file /usr/share/man/man1/ld.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ld.1.gz', 0L))
('file /usr/share/man/man1/nm.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/nm.1.gz', 0L))
('file /usr/share/man/man1/objcopy.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objcopy.1.gz', 0L))
('file /usr/share/man/man1/objdump.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objdump.1.gz', 0L))
('file /usr/share/man/man1/ranlib.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ranlib.1.gz', 0L))
('file /usr/share/man/man1/readelf.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/readelf.1.gz', 0L))
('file /usr/share/man/man1/size.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/size.1.gz', 0L))
('file /usr/share/man/man1/strings.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strings.1.gz', 0L))
('file /usr/share/man/man1/strip.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strip.1.gz', 0L))

See /var/log/up2date for more information




# No arch specified
up2date --nox binutils

Fetching Obsoletes list for channel: ftid1-rhel4-as-x86_64...

Fetching rpm headers...
########################################

Name Version Rel
----------------------------------------------------------
binutils 2.15.92.0.2 21 x86_64


Testing package set / solving RPM inter-dependencies...
########################################
binutils-2.15.92.0.2-21.x86 ########################## Done.
Preparing ########################################### [100%]
An error has occurred:
Failed running transaction of packages:
('file /usr/include/bfd.h from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/include/bfd.h', 0L))
('file /usr/share/info/as.info.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/info/as.info.gz', 0L))
('file /usr/share/man/man1/addr2line.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/addr2line.1.gz', 0L))
('file /usr/share/man/man1/ar.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ar.1.gz', 0L))
('file /usr/share/man/man1/as.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/as.1.gz', 0L))
('file /usr/share/man/man1/c++filt.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/c++filt.1.gz', 0L))
('file /usr/share/man/man1/gprof.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/gprof.1.gz', 0L))
('file /usr/share/man/man1/ld.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ld.1.gz', 0L))
('file /usr/share/man/man1/nm.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/nm.1.gz', 0L))
('file /usr/share/man/man1/objcopy.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objcopy.1.gz', 0L))
('file /usr/share/man/man1/objdump.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/objdump.1.gz', 0L))
('file /usr/share/man/man1/ranlib.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/ranlib.1.gz', 0L))
('file /usr/share/man/man1/readelf.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/readelf.1.gz', 0L))
('file /usr/share/man/man1/size.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/size.1.gz', 0L))
('file /usr/share/man/man1/strings.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strings.1.gz', 0L))
('file /usr/share/man/man1/strip.1.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/man/man1/strip.1.gz', 0L))

See /var/log/up2date for more information


# /var/log/up2date
Wed Apr 25 15:44:03 2007] up2date updating login info
[Wed Apr 25 15:44:03 2007] up2date logging into up2date server
[Wed Apr 25 15:44:03 2007] up2date successfully retrieved authentication token from up2date server
[Wed Apr 25 15:44:03 2007] up2date availablePackageList from network
[Wed Apr 25 15:44:06 2007] up2date installing packages: ['binutils-2.15.92.0.2-21']
[Wed Apr 25 15:44:07 2007] up2date Failed running transaction of packages:
('file /usr/include/bfd.h from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/include/bfd.h', 0L))
('file /usr/share/info/as.info.gz from install of binutils-2.15.92.0.2-21 conflicts with file from package binutils-2.15.92.0.2-18', (7, '/usr/share/info/as.info.gz', 0L)

Lenard 04-25-2007 04:37 PM

See: http://wiki.centos.org/HowTos/Packag...ment/YumOnRHEL

It is so fun to type; yum update binutils binutils.i386

Nothing is stopping you from using update to only download the two binutils packages and installing them by hand at the same time;

up2date -d binutils-2.15.92.0.2-21.i386.rpm binutils-2.15.92.0.2-21.x86_64.rpm
rpm -Uvh binutils*.rpm

Or you can manually download them.

gatr_head 04-26-2007 12:51 PM

Thanks it worked. RH suggested removing the rpms, run up2date, then re-add them which made me nervous. I did what you suggested and it was seamless.

Much appreciated.

Lenard 04-26-2007 07:20 PM

Your welcome, glad to help.

FYI: if have not done so already, it is a good idea to 'yum'ify RHEL4, consider it practice for RHEL5


All times are GMT -5. The time now is 03:35 PM.