-   Red Hat (
-   -   unclean shutdown causes "Couldn't find matching filesystem: label=" error (

irnerdette 06-01-2006 03:03 PM

unclean shutdown causes "Couldn't find matching filesystem: label=" error
Here's what happened: Have a rack mount dell 2850 server running Redhat Enterprise Linux 3 AS and the power cables from our server accidently got caught and came out while I was pulling the server out of the rack to obtain some information on a sticker on the side of the server. So it was an unclean shutdown, so when I tried to power the system up, I get the message "Couldn't find matching filesystem: label=/u01" and I'm forced into a recovery mode. So, I edited the /etc/fstab file and commented out the label /u01 that is related in the error message. Okay then I could boot up without the error. I ran e2fsck and it checked out clean. But I still got the error when I would try to boot with that label in the fstab file. I tried restoring every backup superblock, but the error still persisted. So I ran the tune2fs -l and reset the label to the same name /u01. Okay, now that let me boot without errors, however, all of the data that I originally had is unavailable. /u01 is a label for /dev/sdb1. And my mount point is also /u01. If I unmount /u01 I can still get to the data and I have made a copy of it. But the data is not there if I mount /u01. This is an ext3 filesystem running hardware controlled RAID. I have run a consistency check on the RAID and no problems were found. Has anyone ever had this problem? Can anyone give me suggestions on how to fix this?

david_ross 06-01-2006 03:27 PM

Welcome to LQ.

Are you saying that the data appears at the mountpoint but not when the partition is mounted? It sounds like the partition was never mounted and that the data is actually on another partition.

I'd suggest mounting the partition at a temporary location, then copying the data to it. Once you've verified the copy then you can delete the original source and remount the partition at the correct location.

You can use the df program to see how much data is on each partition at any point in time:
df -h

irnerdette 06-02-2006 11:29 AM

Thanks for the reply. I have made a copy of the data at a temporary location. Do you mean to just delete the data or remove the whole partition and re-create the partition? I've thought about removing the partition and re-creating it but wasn't sure if it would help this problem.

david_ross 06-02-2006 02:44 PM

It sounds like the partition is empty so just remove it from the partition it is on then mount the partition you want to use and restore the data.

All times are GMT -5. The time now is 11:01 PM.