-   Red Hat (
-   -   Unable to use cmake any many other commands after yum update (

NikhilD 02-20-2013 12:10 AM

Unable to use cmake any many other commands after yum update
I just did a yum update on my system on redhat 5.4. After that I am unable to use many commands like cmake,make etc. It is giving below error.
$ cmake
cmake: error while loading shared libraries: wrong ELF class: ELFCLASS32

I did few searches and found it is due to 32 bit libcurl file instead of 64 bit on my 64 bit system.I removed curl.i386 using "rpm -e --nodepend libcurl.i386" command, but still it is giving me same error.

Below are outputs of other commands that i ran as google suggested.

ldconfig -p | grep libcurl (libc6,x86-64) => /lib/ (libc6,x86-64) => /usr/lib64/ (libc6) => /usr/lib64/ (libc6,x86-64) => /lib/ (libc6,x86-64) => /usr/lib64/
After removal libcurl is not present in /usr/lib but it is still present in /usr/lib64

Can i somehow remove from ldconfig or any other solution to link it correctly. Thanks.

linosaurusroot 02-20-2013 05:19 AM

Ask RH support. If a bad update has occurred someone should know about it and arrange that another update sorts it out.

NikhilD 02-28-2013 12:52 PM

My best guess is it was not a bad update. I have tried to do several changes in the system that i don't understand fully. Only issue was even removing and reinstalling libcurl is not helping at all. Anyways I think I will do stuff in vm instead.Thanks.

All times are GMT -5. The time now is 12:29 AM.