-   Red Hat (
-   -   Trying to install ethernet adapter driver, not finding kernel-devel or kernel-headers (

oneFishtwoFish 08-30-2010 06:01 PM

Trying to install ethernet adapter driver, not finding kernel-devel or kernel-headers
I'm attempting to install the driver for my atheros AR8131 PCI-E Gigabit Ethernet adapter (in my Lenovo laptop) on my newly installed RHEL5 system (it's not currently being recognized). I tried using:

'make install'

but hit an error "Makefile:61: *** Linux kernel source not found." After this, I tried:

'sudo yum install kernel-devel kernel-headers'

to rectify this, but hit this error "No package kernel-devel available" (and the same for the headers). What should I do?

PTrenholme 08-30-2010 06:31 PM

Since you're using the RHEL, which include RH support, you should ask RH to provide the support for which you payed.

And the Gigabit drivers are, I believe, included in most recent kernel releases so you should not need to compile your own version unless you're running a really old kernel.

You could try yum install kernel-devel-`uname -r` kernel-headers-`uname -r` to see if they exist for your specific kernel. (Note that the uname -r command is surrounded by back-quotes, nor single-quotes.)

Also, note that there is a RHEL sub-forum to which you should have posted your query.

oneFishtwoFish 08-30-2010 07:03 PM

I get the error "No package kernel-devel-2.6.18-194.el5PAE available" when I try that. My RHEL distribution is through my university, so they would forward the question to Red Hat (eventually), so I thought I would try here first. Thanks for the help!

The reason I think it doesn't have the driver is when I go System -> Administration -> Network -> Devices (New) -> Ethernet Connection, there is a large list in a dropdown menu of various adapters, and there are no Atheros branded adapters listed. Some that are listed are 3Com, Alteon, Apple, PCMIA, RealTek, etc branded adapters. Am I right in thinking that my hardware's driver isn't installed?

Would it be appropriate to delete it from this forum and repost to the RHEL subforum? I wasn't sure if it was a general Linux issue, an issue with RHEL, or with my hardware.

PTrenholme 08-31-2010 09:53 AM

First, this is definitely a Red Hat issue. But you don't need to delete and repost. Just "report" your thread and ask the moderator(s) to move it to the "Red Hat" forum.

The form of the `uname -r` output you posted (2.6.18-194.el5PAE) looks strange to me. I don't use RHEL, so this is from looking at the CentOS and Fedora repositories, where the usual format would be <kernel>.<version>.<architecture>, so I'd expect to see something like 2.6.18-194.el5PAE.i586 Of course, using a PAE kernel on a 64bit kernel release doesn't make too much sense unless you've got more than 16Gb of RAM. (That 16Gb is if I recollect correctly. I only have 4Gb in this laptop, so I've never needed a PAE kernel.)

XavierP 08-31-2010 02:28 PM

As requested, moved to Red Hat

DrLove73 08-31-2010 06:24 PM


yum install kernel-devel kernel-headers
is enough. BUT if you have any other network connection, like wireless, and ONLY if you registered your RHEL system. If you do not want to register, use CentOS, free version of RHEL.

If yo can not register, use kernel-devel and kernel-headers rpm's from RHEL dvd to install those packages so you can register and update your system.

All times are GMT -5. The time now is 11:28 PM.