-   Red Hat (
-   -   tried installing FC4 kernel to my RHEL4 box & wanted to make FC4 kernel as default (

visitashu 04-06-2006 12:01 AM

tried installing FC4 kernel to my RHEL4 box & wanted to make FC4 kernel as default
hi fans !!!
i m having kernel-2.6.9-5.EL.i686.rpm in my linux box...
the same is added in my /etc/grub.conf file
Now what i tried is copied a fedora core 4 kernel from a FC4 CD_1 on my /opt directory !!!
then i said
# rpm -ivh kernel-2.6.11-1.1369_FC4.i586.rpm --aid

i got an ERROR
warning : kernel-------.rpm V3 DSA signatutre: NOKEY,key ID
error : failed dependencies:

selinux-policy-targeted <1.23.16-1 conflicts with kernel-2.6.11-1.1369_FC4.i586.rpm

how shall i proceed then ???
please help

we know that as we install a NEW kernel it automatically gets written in /etc/grub.conf file
and when i change defaults=1 it 'll boot my NEW kernel
right !!

reddazz 04-06-2006 12:33 AM

Either remove selinux-policy-targeted (which is probably not a good idea especially if there are other packages that depend on it) or stick with the RHEL 2.6.9 kernel. You could also force the FC kernel to install using the nodeps switch for rpm but this may break some things.

visitashu 04-06-2006 02:01 AM

thanx for that....
but my RHEL4 box has its own RPMS selinux-policy-targeted if i remove that then won't it affect my original Kernel 2.6.9-5 ??
i jus copied all the RPMS from Fedora CDs n tried intalling selinux-policy-targeted [version]....but again same prob no dependencies !!!
how shall i install new kernel ??
updation may cause my 2.5.9-5 to crash which i don't want !!

comptiger5000 04-06-2006 02:20 PM

use a new rhel kernel, or build your own, using a fedora kernel on a non-fedora system is aksing for problems

All times are GMT -5. The time now is 11:30 PM.