-   Red Hat (
-   -   The Phantom Dir. (

krome 11-08-2003 11:46 PM

The Phantom Dir.
I installed Realplayer on my RH9 and it worked yesterday but not today. That is I try to open the link to play and nothing happens. I decide that I need to reinstall realplayer(I have upgraded at since then and figure that some lib file got switched) so I as root rm -rf The RealPlayer8 dir and reinstall. Still nothing. So, I try it again, rm -rf RealPlayer8(where all the realplay files are according to my 'locate realplay') and when I try to reinstall it says that RealPlayer8 is already installed. So, I do a locate realplay and, sure enough it shows me a bunch of files in the dir /usr/lib/RealPlayer8. But if I try to go there it tells me that the dir doesn't exist. And if I try to look via my gnome desktop It's not there and if I login as just a user not root I don't see these files. I have rebooted multiple times. Where is the .config or other file that is making root believe that these filesz still exist? Do I need to reinstall the OS to get things back to normal?:Pengy::scratch:

adz 11-09-2003 12:44 AM

Try doing a shutdown -Fr now. This will reboot the computer and run fsck on start up. The reason why you need this is because you can't run fsck on a mounted drive.

usernamenumber 11-09-2003 01:00 AM

I'm really not sure what the above advice about running fsck is supposed to accomplish, but here's what I believe your problem is.

The reason your system says rp is still installed: Did you, by any chance, install realplayer using an rpm? If so, you will have to do 'rpm -e realplayer' (or whatever the realplayer package is called). There is data stored in your system's rpm database besides just the files stored on the disk. rpm -e (as in erase) removes everything.

The reason locate still shows those files is that locate does not actually search your drive. Every night at about 4am a program called 'updatedb' is automatically run. This program creates a database of every files and directory on the system. Since actually going through the entire system would take a very long time, the locate command just searches the database. When you deleted that directory it was not removed from the db and so locate will give you inaccurate information until the db is updated. You can do this either by waiting until the next time updatedb is run automatically or you can just run it yourself (as root). If you want to search the disk in real time (not from the database), use the find command:

find / -iname realplayer

This will take longer than locate but it will be searching the actual disk and will update locate's database as it goes.

Hope this helps

krome 11-09-2003 05:41 PM

well, I did the rpm -e and then tried to reinstall and was told that it was already installed...ugh. So, I went ahead and booted with fsck and found that I had some bad sectors that couldn't be rewritten so I reinstalled RH9 and now have RP8 installed and working as well as just about everything else. I am almost convinced that this HDD is physically damaged but can't afford another.:cry:

All times are GMT -5. The time now is 06:19 PM.