-   Red Hat (
-   -   serial ports (

timl 03-12-2013 11:56 PM

serial ports
Hi, I do a bit of work on HP Itaniums. From my windows computer I can putty into the console of this computer via the serial port on my PC.

I tried this on a linux box - CentOS6.4. The motherboard has 2 serial ports. A grep on dmesg shows:
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:09: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
I am not sure which is which so I plugged the cable into both and I tried to connect via /dev/ttyS0 and ttyS1. This always gives me:

Unable to open connection to:
Unable to open serial port
The sad thing is that I get the same response on ttyS2 & ttyS3. I guess the question do I diagnose activity on the serial ports?


michaelk 03-13-2013 07:31 AM

A simple test can be accomplished by using minicom and serial loop back plug or just a jumper between pins 2 & 3. Configure minicom for no hardware flow and the desired port. If you see what you type then you have identified the correct connector / serial port device ID.

timl 03-14-2013 05:48 PM

thanks. I was not aware of minicom which I will have to play with first. serial loop back plug, I know what you mean. Since I started working from home though, I'll have to hunt around for places to get one.

All times are GMT -5. The time now is 06:46 AM.