LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 10-16-2003, 12:24 PM   #1
JohnGalt00
LQ Newbie
 
Registered: Aug 2003
Location: Dallas
Distribution: Fedora,Gentoo
Posts: 24

Rep: Reputation: 15
Samba working, but SMB browsing not?


I'm running the new Fedora. Samba sort of works, connecting to a winXP machine.

at a terminal
smbclient -L //foo
doesn't work, but
smbclient -L //192.168.0.4
works just fine.
findsmb (I'm doing this from memory) doesn't report any machines.
Nautilus says it can't find the SMB master browser. smbd and nmbd are running fine, but I'm not sure what service provides the browsing.

Any ideas?
 
Old 10-16-2003, 09:56 PM   #2
killjoy
Member
 
Registered: Mar 2001
Location: Atlanta,GA
Distribution: Red Hat, Mandrake
Posts: 66

Rep: Reputation: 15
SMB browsing is done by election on the network. If it's a small network, probably the easiest thing to do is to add the other machine to your /etc/hosts file. You can try raising the OS level in your smb.conf file if you want a "better" solution. The higher the OS level, the higher the chance your machine will be elected. (mine is set at 100 as a PDC) You can also set Preferred Browser to yes in the smb.conf file-that will help as well.
HTH
 
Old 10-16-2003, 10:09 PM   #3
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
Check your firewall settings as well. You may be blocking the smb port... or your other machine may be.
 
Old 10-17-2003, 10:08 AM   #4
JohnGalt00
LQ Newbie
 
Registered: Aug 2003
Location: Dallas
Distribution: Fedora,Gentoo
Posts: 24

Original Poster
Rep: Reputation: 15
I bet the firewall is what did it. Samba was working, then i turned the firewall on, and didn't put the two together. Stupid. Thanks for the help guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reinstalling Samba doesn't recover the original /etc/samba/smb.conf Akhran Debian 2 11-11-2005 12:54 AM
SAMBA client stopped windows browsing from working - SuSE 9.1 mikemrh9 Linux - Networking 7 08-18-2004 01:38 PM
Samba Browsing Runningonair Linux - Software 2 04-19-2004 04:41 AM
Samba share - network name no longer available when browsing samba from win2k dorango Linux - Software 0 03-02-2004 01:02 PM
Samba and browsing subnets J_Szucs Linux - Networking 19 01-27-2003 09:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 01:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration