LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 02-05-2007, 07:48 PM   #1
Heba Ezzat
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Rep: Reputation: 0
Samba installed on centos or not?


I use CentOS-4.4 & I know that SAMBA is already installed on centos but while working on this site
http://www.samba.netfirms.com/sambconf.htm
it started by "how do we tell if Samba is installed. The most easiest, open a terminal window and type in the following: smbd -V "

when i tried this command this error appear "bash: smbd: command not found"

i have tried smb.conf and also command not found appear
now i dont know whether SAMBA is installed or not. and if it is already installed on centos why the previous error appears !!!!

please if anyone can help me soon
thnx in advance
 
Old 02-05-2007, 09:36 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
A quick check to be sure; rpm -qa 'samba*'

If no results the use yum; yum install samba-swat samba-client

Then smbd -V will work.
 
Old 02-06-2007, 02:52 AM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
It's certainly part of the distro - whether you have it installed is another question
 
Old 02-09-2007, 01:30 AM   #4
Heba Ezzat
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Original Poster
Rep: Reputation: 0
when I wrote
rpm -qa 'samba*' the output was
samba-client-3.0.10-1.4E.9
samba-common-3.0.10-1.4E.9

I think this means that samba is installed, eventhough, smbd -v cant be executed

I wrote yum install samba-swat as you told me and also smbd -v cant be executed

so what can I do
 
Old 02-09-2007, 02:11 AM   #5
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Same on FC5 machine (CentOS box is off), I get

samba-client-3.0.23c-1.fc5
samba-3.0.23c-1.fc5
samba-common-3.0.23c-1.fc5

So I don't think you're fully installed.


Try yum install samba
 
Old 02-09-2007, 07:13 AM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
The client is installed but the server part is not, follow billmayday's advice with a slight change;

yum install samba samba-swat
 
Old 02-09-2007, 11:31 AM   #7
Brydon
Member
 
Registered: Dec 2006
Location: Lancaster, Ontario
Distribution: Fedora 6-7, CentOS 5, Red Hat 9, Ubuntu
Posts: 36

Rep: Reputation: 15
Just a thought, did you try testing your configuration as root?

Scott
 
Old 02-12-2007, 09:32 AM   #8
Heba Ezzat
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Original Poster
Rep: Reputation: 0
i have tried yum install samba samba-swat the output was
Loading "priorities" plugin
Setting up Install Process
Setting up repositories
http://dag.linux.iastate.edu/dag/redhat/el4/en/i386dag/
repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>

Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno256] No more mirrors to try.


Now what i want to know from where i can download samba server component and SWAT component with their dependencies

thnx in advance
 
Old 02-12-2007, 09:53 AM   #9
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Download and install directly then, also use the CentOS-Base repo file found here (it replaces or goes in the /etc/yum.repos.d directory), the samba rpm files can be found under the "os" directory for your arch;

http://isoredirect.centos.org/centos/4.4/

FYI: your yum configuration for Dag's site looks incorrect or old;

http://dag.wieers.com/rpm/FAQ.php#B
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Panel Vanished in Gnome (Centos) cruiserparts Linux - Server 3 10-24-2006 09:32 AM
Just Installed centOS and startx gets error Darrelzz Linux - Newbie 1 08-04-2006 10:47 AM
Samba config on CentOS 4.3 Yig Linux - Networking 3 06-06-2006 01:00 PM
CentOS - Samba Share Mithrilhall Linux - Newbie 1 05-18-2006 08:02 AM
Installed CentOS, but cant resolve DNS abcampa Red Hat 1 04-27-2005 12:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 01:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration