LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 01-26-2005, 01:10 AM   #1
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Rep: Reputation: 15
RPM problems


I'm trying to install the newest Snackamp rpm and this is what I've done and what's happening:

Currently installed:
snackamp-2.2-4.fdw.test.rh90.noarch.rpm with
libsnack-2.2.7-1.0.rh9.dag.i386.rpm
uses tcl 8.3
Works, but a bit buggy. So I'd like a newer version

Trying to install:
snackamp-3.0.2-1.dag.src.rpm


Step 1: rebuilding the snackamp-3.0.2-1.dag.src.rpm
error message reads:
error: Failed build dependencies:
tcl >= 8.4 is needed by snackamp-3.0.2-1.dag

Step 2: Install required tcl packages
rpm -ivh tcl-8.4.5-7.i386.rpm tcl-devel-8.4.5-7.i386.rpm
Says it conflicts with:
file /usr/share/man/mann/unset.n.gz from install of tcl-devel-8.4.5-7 conflicts with file from package tcl-8.3.5-88
and a bunch of other stuff related to tcl-8.3.5-88

Step 3: try to upgrade current tcl package instead
rpm -Uvh tcl-8.4.5-7.i386.rpm tcl-devel-8.4.5-7.i386.rpm
Get this message:
[root@localhost tcltk]# rpm -Uvh tcl-8.4.5-7.i386.rpm tcl-devel-8.4.5-7.i386.rpm
warning: tcl-8.4.5-7.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
libtcl8.3.so is needed by (installed) tuxracer-0.61-19
libtcl8.3.so is needed by (installed) compat-db-3.3.11-4
libtcl8.3.so is needed by (installed) expect-5.38.0-88
libtcl8.3.so is needed by (installed) isdn4k-utils-vboxgetty-3.1-62
libtcl8.3.so is needed by (installed) postgresql-tcl-7.3.2-3
libtcl8.3.so is needed by (installed) postgresql-pl-7.3.2-3
libtcl8.3.so is needed by (installed) tk-8.3.5-88
libtcl8.3.so is needed by (installed) expectk-5.38.0-88
libtcl8.3.so is needed by (installed) pvm-gui-3.4.4-12
libtcl8.3.so is needed by (installed) ruby-tcltk-1.6.8-5
libtcl8.3.so is needed by (installed) tclx-8.3-88
libtcl8.3.so is needed by (installed) tix-8.1.4-88
libtcl8.3.so is needed by (installed) tkinter-2.2.2-26
libtcl8.3.so is needed by (installed) csound-4.24-1
libitcl3.2.so is needed by (installed) tix-8.1.4-88
libitk3.2.so is needed by (installed) tix-8.1.4-88
itcl is needed by (installed) tix-8.1.4-88
Step 4: search for libraries
slocate libtcl8.3.so
/usr/lib/libtcl8.3.so
have it

slocate libitcl3.2.so
/usr/lib/libitcl3.2.so
have it

slocate libitk3.2.so
/usr/lib/libitk3.2.so
have it

have them all.

Step 5: Try to force upgrade
rpm -Uvh --force tcl-8.4.5-7.i386.rpm tcl-devel-8.4.5-7.i386.rpm
warning: tcl-8.4.5-7.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:

Force does the same thing as Upgrade.

How do I get around this?
Any help would be appreciated.

P.S. I'm not really the King of Japan.
But I'd like to be.
 
Old 01-26-2005, 01:35 PM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
its good that u tried all these options and posted them here

did u try force install??

rpm -ivh --force

regards
 
Old 01-26-2005, 02:03 PM   #3
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
Thanks for the reply.

I haven't tried that one.

I'll try it.

If that doesn't work, I guess I'll try to
rpm --nodeps -e tcl

and install the newer packages.
It will most likely render the dependency packages unusable, but what the hey, I'll just upgrade them. However, I see a potential dependency Catch-22 nightmare that might occur if I need to go that route.
It's good practice I suppose, because I'm sure I'll see this problem again if I continue to RH, Fedora, or any RPM based distributions.

Once again thanks for the input.
I'll reply in a bit on what happened.
 
Old 01-26-2005, 06:02 PM   #4
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
Using the rpm -ivh --force worked.
It just wouldn't force an Upgrade.

Then I had to upgrade Tk to 8.4
Then I had to install this metakit thingy.

Then I could install snackamp.

After 2 days and 21 steps later, I got it installed.

Thanks Man
 
Old 01-26-2005, 11:04 PM   #5
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
"After 2 days and 21 steps later, I got it installed."

thats the way it works , but it works for sure!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
'rpm' problems. Devyn Linux - Software 2 01-02-2006 08:38 PM
RPM problems bloodfrost Linux - Newbie 6 05-06-2004 04:47 PM
problems with rpm talkinggoat Linux - Software 2 10-12-2003 10:02 PM
RPM Problems demonx Mandriva 2 09-28-2003 09:12 AM
problems with RPM kessario Linux - Software 5 09-14-2003 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 12:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration