Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 12-09-2009, 10:21 AM   #1
LQ Newbie
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
Root Filesystem (/) Mounts as Read-only

Can someone tell me what did I do to my filesystem, and how I can get it back?

I am configuring a RHEL5 system and I had some file system problems, including superblock errors. I followed a correction found here Surviving Filesystem Failures

After many reboots and fsck executions, it still will not mount on boot to read-write. However now it will let me remount to read-write after boot.

My /etc/fstab looks like:

LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/VolGroup00/LogVol00 / ext3 defaults 1 2
/dev/VolGroup00/LogVol02 /usr ext3 defaults 1 2
/dev/VolGroup00/LogVol03 /tmp ext3 defaults 1 2
/dev/VolGroup00/LogVol04 /var ext3 defaults 1 2
/dev/VolGroup00/LogVol05 /home ext3 defaults 1 2
/dev/VolGroup00/LogVol06 /more ext3 defaults 1 2
Running the command cut /proc/mounts -f 2,3,4 -d " " gives me:
/ rootfs rw
/ ext3 ro,data=ordered
/dev tmpfs rw
/proc proc rw
/sys sysfs rw
/dev/shm tmpfs rw
/dev/pts devpts rw
/usr ext3 rw,data=ordered
/tmp ext3 rw,data=ordered
/var ext3 rw,data=ordered
/home ext3 rw,data=ordered
/more ext3 rw,data=ordered
/misc autofs rw,fd=6,pgrp=3015,timeout=300,minproto=5,maxproto=5,indirect
/net autofs rw,fd=12,pgrp=3015,timeout=300,minproto=5,maxproto=5,indirect
Notice that the rootfs is mounted rw, but the next one is ro.

Doing df -h gives me:
Filesystem Size Used Avail Use% Mounted on
10G 1.1G 8.5G 11% /
/dev/sda3 10G 1.1G 8.5G 11% /boot
Notice that the /dev/sda3 and the /devVolGroup00/LogVol00 have the same information, which is suspicious. Also, I am missing my other Logical volumes. (They are mounted but they don't show up unless I do a df -h /dev/VolGroup00/LogVol02). I have a another RHEL5 box with a similar setup and these volumes are listed with a simple df -h.

Anybody have any ideas on what's going on?

Thanks for any advice,

Old 12-09-2009, 11:58 AM   #2
Registered: Nov 2009
Location: Lisbon, Portugal
Distribution: Gentoo, CentOs, Ubuntu, Debian
Posts: 182

Rep: Reputation: 49
Hi eric. Your post is very complete. If all first posts here were like yours.

This possibility is a long shot, but do you have hal working?
Can you reboot and init on runlevel 3 without hal and check again.

You can change your default runlevel by edit the default /etc/inittab
# Default runlevel.
Old 12-09-2009, 03:08 PM   #3
LQ Newbie
Registered: Dec 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks, I appreciate for your response. I set to runlevel 3 and rebooted, haldaemon off and I get the same problem.

I also tried booting to single user and got an error that /usr/bin/id not found. I am trying other things. I am also wondering if I made a mistake in setting the superblock.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
why does a df on a wildcarded filesystem show multiple mounts to root dlemieux33 Linux - General 1 07-27-2009 09:43 PM
How can I have: Root has Read-Write, user has read only for the boot filesystem? xmrkite Linux - Software 6 10-16-2008 05:31 AM
Filesystem root ( / ) mounts read only at boot, can't re mount RW TheMusicGuy Debian 10 07-25-2006 07:14 PM
After Ghost 4 Linux Root Filesystem mounts readonly tjabaut Linux - General 6 07-18-2006 08:51 AM
ext. usb HDD mounts read only for non root accounts logname Linux - Hardware 14 02-27-2006 05:17 PM > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 03:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration