LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 08-15-2017, 09:27 PM   #1
christr
LQ Newbie
 
Registered: Sep 2011
Posts: 17

Rep: Reputation: Disabled
RHEL7 - Samba


I'm having trouble with a Linux Samba share after migrating a system from RHEL 5 to RHEL 7.

My current configuration is below.

Code:
[global]
workgroup = DOCS
security = share
[data]
comment = Data
path = /export
read only = yes
guest ok = yes
browsable = yes
In RHEL7 the service will fail to start. I can get the service to start if I change it to "security = user", but that's not what I want because it will force users trying to connect for logins. I need this share to be completely open, and Windows users can't be prompted for a username or password whatsoever. Has anyone run into this, or know of a work around?

I see in the new man page that "security = user" is deprecated. However, I must have the share completely wide open to guests.

Thanks
 
Old 08-16-2017, 06:18 AM   #2
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 2,290

Rep: Reputation: 919Reputation: 919Reputation: 919Reputation: 919Reputation: 919Reputation: 919Reputation: 919Reputation: 919
If you are running RHEL, then you must have an RHEL license. Why not ask Red Hat support on those forums?
 
Old 08-16-2017, 08:01 AM   #3
christr
LQ Newbie
 
Registered: Sep 2011
Posts: 17

Original Poster
Rep: Reputation: Disabled
I already opened a case with Red Hat, but it seems this may be something the community can help answer. I can't imagine I'm the first to have run into this. All my google and forum searches have come up empty.
 
Old 08-16-2017, 09:03 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,076

Rep: Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377Reputation: 4377
Quote:
Originally Posted by christr View Post
I'm having trouble with a Linux Samba share after migrating a system from RHEL 5 to RHEL 7. My current configuration is below.
Code:
[global]
workgroup = DOCS
security = share
[data]
comment = Data
path = /export
read only = yes
guest ok = yes
browsable = yes
In RHEL7 the service will fail to start. I can get the service to start if I change it to "security = user", but that's not what I want because it will force users trying to connect for logins. I need this share to be completely open, and Windows users can't be prompted for a username or password whatsoever. Has anyone run into this, or know of a work around?

I see in the new man page that "security = user" is deprecated. However, I must have the share completely wide open to guests.
Try
Code:
public = yes
for your "must be open to guests" needs. Also, check selinux status as well, if you're having other issues. Anything in the logs? Any other info?
 
Old 08-16-2017, 10:02 AM   #5
christr
LQ Newbie
 
Registered: Sep 2011
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestion. I've been trying a number of things, but still no luck so far. This is what I have currently.


Code:
[root@server1 samba]# cat smb.conf
# See smb.conf.example for a more detailed config file or
# read the smb.conf manpage.
# Run 'testparm' to verify the config is correct after
# you modified it.

[global]
        workgroup = SAMBA
        security = user

        passdb backend = tdbsam

        printing = cups
        printcap name = cups
        load printers = yes
        cups options = raw

[xfer]
   comment = Files for transferring
   path = /export
   public = yes
   guest ok = yes
   writable = no

[root@server1 samba]#
 
Old 08-16-2017, 10:40 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,014

Rep: Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848Reputation: 1848
I believe you meant to post that security=share is deprecated.

Code:
FYI public == guest ok
This information is fairly old and might depend on what samba version you are running.
http://beginlinux.com/blog/2010/01/c...hare-on-samba/

You need to add map guest = bad user to the global section of your smb.conf file to enable . By default the guest account is nobody which may not have sufficient permissions. The posted link creates a special guest account and then creates the public directory that it owns.
 
1 members found this post helpful.
Old 08-16-2017, 11:15 AM   #7
christr
LQ Newbie
 
Registered: Sep 2011
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thank you Michaelk. Before I had a chance to see your post I ended up solving this problem on my own. I discovered the same thing you said.

I finally found this in the documentation, and that solved my problem. The security modes for Samba changed in RHEL7.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] rhel7 vucni Linux - Server 2 03-10-2017 04:14 PM
RHEL7 AD Authentication jeffrosquad Linux - Server 1 05-14-2015 10:20 AM
Unable to install RHEL7 KVM onto RHEL7 desktop redhatprat Red Hat 10 02-18-2015 03:44 AM
Rhel7 wagh1.ravi Linux - Newbie 5 01-04-2015 02:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 05:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration