LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
 
Search this Thread
Old 09-27-2006, 11:59 AM   #1
erwinfletch
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Rep: Reputation: 0
RHEL 4 WS freezing up on IBM ThinkCentre


Hi-

I have recently installed Red Hat Enterprise edition WS 4 on my IBM ThinkCentre. The install went great and everything worked fine until I left it running overnight the first night. When I came back to it in the morning, it was barely responsive. I tried to reboot but it was taking so long to take any of my actions that I had to hard boot the machine.

This seems to happen randomly, yesterday I had to hard boot the machine 4 times

I basically installed the default packages, with a few exceptions(mostly development packages)

Has anyone heard of this before? Know why it's happening or how I can diagnose it?

Thanks!
 
Old 09-27-2006, 05:56 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 28,274
Blog Entries: 54

Rep: Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176Reputation: 3176
Interesting. I'd first look at the HW specs and config (amount of RAM, swap), what you configured (VM sysctl for instance) and then the logs for clues (make sure your loglevels aren't set too high). If nothing out of the ordinary appears then I'd install some form of SAR to generate system stats over a 24 hr period: Dstat (python), Atop or Atsar. I usually default to running Dstat in CSV mode as an at job and then check graphs in OOo for spikes or ramp-ups.
 
Old 10-03-2006, 08:32 PM   #3
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
You might try booting with the "noapic" kernel option. IIRC, there's a timer problem with the Intel chipset on those machines.
 
Old 11-29-2006, 11:30 AM   #4
erwinfletch
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
I wanted to make sure I was ok before posting the solution... the noapic option seems to have fixed the freeze. I've been up for over 20 days now a couple times.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux RHEL 4 on IBM x346 xianzai Linux - Enterprise 14 02-25-2008 04:05 AM
RHEL not installing on IBM machine !!! logicalfuzz Red Hat 0 12-20-2005 11:31 AM
Laptop Freezing with RHEL 4 basketkase999 Red Hat 0 10-28-2005 09:23 PM
IBM T21 freezing on install chadwick Linux - Laptop and Netbook 3 05-09-2005 06:31 PM
fedora 3 anaconda freezing during install on IBM ServeRaid jacko0 Linux - Software 1 03-10-2005 06:56 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration