-   Red Hat (
-   -   RHEL 4 on HP ML150 G3 (

gzoubek 08-12-2006 06:44 AM

RHEL 4 on HP ML150 G3

I'm trying to install RHEL 4 on HP ML150 G3 (dual core Xeon 3.0, 1Gb RAM..).. Problem is, that it can not recognize Adaptec HP Embedded SATA RAID Controller, so no Sata disk is found..I made driver disk (CD..) from disk image provided by HP. RHEL loads driver, but still no SATA disk can be found.. I tried both - 32 bit an 64 bit version (with proper drivers) but the result was the same..

Any clues??

LP, G.

Lenard 08-12-2006 04:13 PM

Please review;

gzoubek 08-12-2006 06:36 PM

Thank you, Lenard!

But, my problem is slightly different. Following the link that you posted, you were providing help on kernel-driver issues on already installed machine.

I can't install RHEL 4 with the driver HP enclosed with server (same as on the HP update site). Tried to insatll ESX Server - same problem..Driver just doesn't seem to fit..

If I disable SATA Raid option in BIOS, Fedora5 installs with no problem..But that is not satisfactory result, is it? there any way to slipstream different drivers into installation package as you can do in Windows?? (prohibited word in here:tisk: :rolleyes: )

Lenard 08-13-2006 10:14 AM

Did you not read the entire thread??? The drivers HP work with various supplied kernels for RHEL4, the initial release and upto update 2. The link to apaptec's site (post #8) will work for newer version like update 3 and 4 now.

Installing the driver during installation is done by typing something like 'linux dd' at the start (as described on the on-screen menu).

pgluke 10-18-2006 04:06 AM

I have a similar problem. System ML150 G3 with embedded SATA RAID Controller.
RAID 1 array is enabled and created.
During installation of CentOS 4.4 the two single SATA drives are displayed.

My further steps:
- downloaded this Toolkit: aar81xx-openbuild-b5732_i386_tar_gz from adaptec
- Build the .img file
- New installation with linux dd=httptoimagefile

But nothing changed. The install process started as before and two single
drives are displayed.
Does the install process display any information about the additional driver normally?

What am I doing wrong? Any Ideas?

gzoubek 10-19-2006 01:04 PM


I guess that you don't have the right drivers for 4.4 CentOS kernel.. Since CentOS is based on RHEL you should try drivers from other RHEL4 updates (1,2,3,4). That can be very sensitive, for example - driver for RAID controller for RHELu2 will not work with RHEL (no update).

You should normaly see an information that states 'disk controller found' or something like that during install.

Hope it helped a bit

gracla 07-15-2007 10:10 PM

re: RHEL 4 on HP ML150 G3
Hello gzoubek,

Having the same problem. Did you solve it?

If so, how did you do it?


linux+ 09-11-2009 11:58 AM

Centos 4.3 installation + Adaptech Host - Raid 8130
try the url it worked for me,

i used FDD u can try with USB drive.


All times are GMT -5. The time now is 11:13 AM.