LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   RH9 Won't boot. (https://www.linuxquestions.org/questions/red-hat-31/rh9-wont-boot-363176/)

Justintoxicated 09-14-2005 01:12 AM

RH9 Won't boot.
 
I did not make any changes but after a rebooting the machine it will not boot back up. I have pics of the error but it says I can't post a URL untill I have posted 5 times so I have to post it like this.

www-rohan.sdsu.edu/~fleming1/LinuxErrorRedHat9.jpg

Tried to edit my fstab...Didn't think this would work

www-rohan.sdsu.edu/~fleming1/fstabRedHat9.jpg

Can anyone help?

I have no idea why all of a sudden I can't even boot up. This is my webserver and I dunno if I trust linux anymore. No idea how to fix this. hate to say this but windows has never done anything like this to me.

Please Please Please help my out if you know the answer I'm sorry if this is a stupid newb question.

Ike M. 09-14-2005 03:28 AM

I sympathize
 
with your dilemma... I am sorry to say that I do not have enough experience with basic LINUX filesystem operations to really help you. Some people do, but whether they will have time to help you...

Your snapshots are helpful but you are still not really giving enough information about what led up to your problem. You said that you made 'no changes', and yet your filesystem is now having trouble mounting essential parts. Can I ask you how long you have been using this system? I mean, if you just installed this like 3 days ago, I wouldn't think it would be a really big deal to just start over from scratch. However if you have a few years worth of stuff sitting on there, it might be worth your while to wait for someone who really knows what they are doing to help you.

I hear what you are saying about LINUX vs. Windows, however in my personal experience my LINUX distro has proven to be VERY resilient up until the point where I try to install something/make a change that I do not completely understand (sometimes my Mandrake 10.1 has allowed me to install a couple of things that 'conflict', so I try to make sure I understand what exactly I am doing before I do). Other than that it has performed what it said it was going to do pretty much up to the letter, so depending on what your particular application of this is (webserver, I guess?) it might be worth your while to check into this. Be wary of installing anything that you do know KNOW for SURE that you ABSOLUTELY NEED.

Justintoxicated 09-14-2005 06:17 PM

Yea theres a couple years of use on it....

I myself do not know what led up to the problem.

The box was at my parents house not mine. They were having issues with the cable modem...so at first I thgouht the modem was just not working again.

Basicaly one day, all of a sudden I could not connect. I called him to check the PC he said it was shut off. No1 in the house shut it off though. It was also plugged into the APC 1500.

Turned it on and it would not boot up. I don't think it is a hardware issue as the only piece of new hardware in it is a WD SE Hard Drive and thats is a couple years old now.

I can take the HD out and plug it into my PC but how can I get teh data off it when it is not formatted NTFS?

Any way I can fix this problem? I doubt I will go back to linux again if I cannot fix this issue, although the uptime was great while it lasted I won't feel comfortable knowing that one day it might just not boot up.

Again NO changes were made to the filesystem. Only things that may have been added were some pictures I FTPed to it.

I made a trip down to San Diego to check it out and could not figure out for the life of me why the file system is crashing on boot. I now have the box with me at home taking up space.


I hope someone can help me out Let me know what I need to do to provide more information.

dfowensby 09-14-2005 06:32 PM

ok. hope this dont sound bad: reinstall linux. use your manual/expert partitioning mode, and keep the partition you have your data on intact (no format) during reinstall.
reboot.
oh, yeah. have you done a disk-check lately? you may have a small borked disc prob, if not. this tends to happen on non-reiserFS or non-bsd file system installs. if the holes are shot in the MBR or early chunks of the disc, i suggest you buy a bottle of cheap wine and procede to do a HD replace, fresh install, and kiss that old booger goodbye in style.
been there, done that.
hope this helps...cheers

luck, dude -O.

Justintoxicated 09-15-2005 11:47 PM

Damn, I didn't want to do a re-install untill I upgraded the whole PC later this year (after x-mas ) :(

no way around that then? I don't think I wanna use RH again if this is the kinds of issues it is going to give me. What other distro would you suggest? Looks like my old Celly 300a is going to have to work a bit longer. Since it takes soo long to get everythig set in linux when your still learning.

I actualy have an old IBM HD in there thats not connected with RH 4 or 5 on it...but the man pages are all garbled for some reason on that distro.

wmakowski 09-25-2005 12:33 AM

You are getting segmentation faults during execution of the rc.sysinit script. This is not a problem with the /proc filesystem. That error is only a side effect of the segmentation faults. /proc has an entry on line 3 of your fstab and you can take out the line that you added. Segmentation faults occur when a program tries to access memory that hasn't been allocated for program's use.

While I haven't had this problem myself, what I see on the picture of your screen is that each time grep is executed you seem to get a segmentation fault. I would start up the system in rescue mode, chroot /mnt/sysimage, and then run an rpm --verify on grep. Any inconsistencies should be reported. While you are there you might as well run an rpm --verify on the kernel. If you need to reinstall either of these you can use rpm --replacepkgs to do the job.

I know how you feel about doing a complete reinstall of RH9, but I have been running some version of Red Hat since 1997. The only problems I have had were caused by me and I have been able to recover each time. I can't say that about Windows. I had to do a complete reinstall of RH once because I made the mistake of installing a newer version of glibc-common. That caused segmentation faults and general weirdness in a number of programs. I really should have known better.

Bill

wmakowski 09-25-2005 12:44 AM

Just spotted something in your second post. If you need to do a reinstall you can extract the data from that harddrive by using a live distro like Knoppix to boot up your PC and access the drive. You would have to have something to copy it to though. AFAIK no one has perfected writing to an NTFS drive from Linux. If you have a network you could connect to your Windows box using a share and do it that way.

Bill

Justintoxicated 09-27-2005 03:26 PM

Quote:

Originally posted by wmakowski
Just spotted something in your second post. If you need to do a reinstall you can extract the data from that harddrive by using a live distro like Knoppix to boot up your PC and access the drive. You would have to have something to copy it to though. AFAIK no one has perfected writing to an NTFS drive from Linux. If you have a network you could connect to your Windows box using a share and do it that way.

Bill

I do have a network, but I have never been able to figure out how to network linux to windows. How would I network something like Knoppix to windows in order to transfer my data?

I will Try running "rpm --verify grep" as you suggesed.

I did not think it was the /proc myself, it looked to me like it was a problem with something the /prc file was trying to access. not sure how to fix it though. I don't pretend to be a linux guru I just know some basics and programing.

wmakowski 09-27-2005 06:28 PM

On the network your linux box should share a router or hub with your windows box? They would both be given separate IP addresses using DHCP or be assigned IP addresses manually. If I remember right Knoppix will set up the network connection automatically allowing a physical connection to be made between both boxes.

The next part is to set up a share on your windows box. For this example I'm going to call it shaggy. Windows help will tell you how to do this better than I can. Basicly you right click on the folder you want to share and select Sharing... from the menu. Then give it a share name, scooby perhaps, and possibly permissions or a password depending on the windows version you use. If sharing hasn't been enabled take a look in Windows help to enable it and set up the share.

On the Linux side you would pick a mount point to mount the share. This is simply a directory that we will use with the mount command. Let's say our mount point is a directory called /mnt/scooby. We then issue the command to mount the share.
Code:

mount -t smbfs -o username=freddy //shaggy/scooby /mnt/scooby
The windows machine with computer name shaggy will ask for the password of user freddy. Provide the password and the connection between the two machines is made. I'll break down the command so you'll understand the pieces.

> mount - unix mount command
> -t smbfs - type of filesystem being mounted is smbfs
> -o username=freddy - this is an option setting our username to freddy, you can use any user, but it must be set up on the windows box call shaggy.
> //shaggy/scooby - shaggy is the name of the server. scooby is the name of the share on the server.
> /mnt/scooby - mount point or directory on linux box

At this point /mnt/scooby on your linux box is connected to the directory you shared on shaggy. You can back up all the files you want to this directory and it will physically end up on the Windows hard drive.

Bill

Justintoxicated 10-05-2005 05:18 AM

Ok I have knoppix booted up.

I'm not sure how to find what knoppix is recognizing my windows box's name as.

Also I cannot create a directorys or anything it says I must be root.

Thus the command you gave me says permission denied also when bringing up the console.

Sorry if these are dumb questions I can see my website on the drive...but Can't really do anything with it.

thanks for all the help so far

Justintoxicated 10-07-2005 07:26 PM

Ok the problem is that Knoppix does not recognize my network card! What can I do ? Nothing? it's an old ISA network card I believe.

Is there anyway I can reinstall a certain redhat package from within Knoppix to fix my current disrt? How would I go about finding the correct package and installing it?

Thanks.
Justin


All times are GMT -5. The time now is 11:08 AM.