-   Red Hat (
-   -   RH9 Shrike /sbin/loader display problem with SIS 630 laptop - display is blank ! (

johnvoisey 09-28-2003 09:59 AM

RH9 Shrike /sbin/loader display problem with SIS 630 laptop - display is blank !
I am trying to load redhat linux 9 (shrike) on a laptop which has an sis video chip and it's very hard going.

I grabbed the ISOs from a mirror site and burned the cd's myself.

I have checked the md5's of all three cd's and they match what redhat say they should be. I have also booted the cd on a different pc in order to run the "on-disk" program that verifies the disk contents early in the install process. All three cd's pass. For that reason, whatever the cause of my problem, I don't believe it's a "media error" issue.

Ok here's what happens. On boot, I get the prompt that tells me to hit "enter" or supply options like text or lowres or the like.

regardless of the options I put in at that point, after I hit enter I get the usual sort of messages as the kernel starts up, then the last text message I see says its running /sbin/loader.

Now on OTHER PC's the monitor goes blank briefly and then the program comes up asking me if I want to check the disks, etc. On the laptop, the display panel blanks, the cd whirrs a bit, and then the pc sits there forever with a black screen.

I have tried all manner of options at the boot prompt as suggested by the options screens. These include resolution=640x480 (and others), lowres, text, noprobe, skipddc. NOTHING works.

Obviously I have tried googling and poking round in this site. All I found were references to Sis audio problems on earlier versions of redhat.

Is there something about the SIS video chip ? (well, there has to be). Can anyone suggest something that will let me get on and install the software (!!).

thanks in advance for any pointers

joeboike 10-04-2003 05:56 PM

I had a similar problem w/ RH 7.2 on an amptron mb w/ sis 730 chipset.
At the boot: prompt I had to use nofb. You might give that a try.

whencat 10-05-2003 01:33 AM

i dont think it is a problem with the chipset(SiS).try hitting <ALT> F3 or <ALT> F4 at the point whr u feel it hangs.u will see som messages.try and see if somthing makes som sense.....or else post the errors (obvious ones) here.....maybe somone will help.

i had such a problem months ago...finally it was my CD-ROM drive that played mischief......try to think of it...

do get back when u hav solved it
gud luck.

johnvoisey 10-05-2003 04:17 AM

solved it with "nofb" option
The "nofb" option did the trick, I can now install redhat ! Hooray !

After I posted my original request, I went off and tried some experiments with a slackware distro that I know better than redhat. From doing that, I think I understand the problem.

The PC is a cheap laptop and they cut corners. The bios has a way to "share" (but they really mean "reallocate") some of the main 64Mb RAM so the Sis video chip can use it.

When the boot / startup process gets to the point where the framebuffer driver is loaded, it tries to find the video memory, fails utterly, and gets configured as a "dummy 80x25 display" which is why I got the black screen !

using the "nofb" option suggested above, I was able to persuade redhat to stay away from using framebuffer drivers and presto up came the "anaconda" screen asking if I wanted to check the cd's or skip straight to install.... yippee and thanks everyone.

Oh yeah, there was another way and I'm almost too ashamed to mention it. When I picked up the laptop to make room on the desk I noticed an external svga socket on the back I didn't even know I had. Out of curiosity I plugged a monitor into it, dug out the manual that came with the laptop and found the keystrokes to disable the flat panel display and use the monitor instead.
I'm ashamed to say that using this hardware kludge, the redhat loader was there for all to see, it was, of course, there all along, but the problem with the framebuffer driver for the flat panel meant I couldn't see it !!! Boy do I feel stupid now !

carp 11-01-2003 06:52 AM

Hi there!

I wish to thank you for posting your solution here. It helped me out, too. I was going mad already because of this: an installation of mandrake worked all right.

We obviously got the same type of notebook. Have you found a solution for the annoying always-on cpu fan problem?


All times are GMT -5. The time now is 08:53 PM.