-   Red Hat (
-   -   RH9 Installation killed hard drive detection! HELP!?! (

jcubed 04-20-2004 10:25 AM

RH9 Installation killed hard drive detection! HELP!?!
I just tried installing Red Hat 9 on a >70GB partition of my 180GB hard drive. The first 3 tries failed due to bad sectors on the partition. Between those attempts, I was able to boot back into Windows 98 SE (I'm trying to NOT give M$ any more of my $$$ for a new OS!) without problems. After learning about fsck, I thought I'd give it another try. .

I set up the partitions manually just like I did the other times. . .
Partition 1 is the existing 100GB of Windows space -- I left that untouched.
Partition 2 is 60GB for /. (Format)
Partition 3 is 10GB for /home (Format)
Partition 4 is split by the installer for:
Partition 5 is 600MB for /tmp (Format)
Partition 6 fills the rest of the drive with swap. (Format)
Another hard drive exists with a previous installation of Windows on it.

My first 2 attempts tried to mount Partition1 as /c_drive and the second drive as /d_drive, but RH didn't want to mount them and rebooted. Again, I was able to get to Windows just fine between them. After attempt #2 was another matter.

[b]The Bios now fails to detect BOTH drives!!![b]:eek: It detects my other drives -- 2 CD drives, 2 floppy drives (one of those old 5 1/4 + 3 1/2 combo drives), and a Super Disk drive. However, I can't even explicitly tell it to boot from floppy or CD!!! The computer hangs at the point that it should start booting from the CD! :cry:

I've successfully installed RH9 from these CDs onto my Alienware laptop, so the media should be good. Then again, my previous laptop was toasted in a similar manner. (Also hangs after drive detection fails, but works fine if told there are no hard drives to detect.) But, since that attempt involved redoing the partitions on the drive, I thought I messed up the partitioning. Now I am sure that isn't the case. :mad:

:confused:Has anyone seen this before?
:confused:Any ideas how to fix this without buying a new machine?
:confused:Or, if the HW is toast, is this kind of problem in the motherboard, or the drive controller card that came with the 180GB drive?
(Since both drives are MIA, including the one that was not touched in the RH installation, I am positive the drives are fine.)

J.W. 04-20-2004 08:40 PM

The first thing I'd look at is to make sure that both HD's are securely connected to the ribbon cable, and that the ribbon cable is securely seated in the mobo. Assuming that it's OK, I'd also ask about how you are defining the system "hanging".

The reason I ask is because I encountered something similar, where the initial bootup would seem to pause on the HD detection, and the bigger the drive, the longer the pause (about 90 to 120 seconds for an 80G drive if I recall, on a system with a P4 2.4G CPU and 1G of RAM). For a giant 180G drive, if it were installed in my box I'd expect a full 5 or 6 minute delay before the process would resume. Have you tried just letting it run, and then getting some coffee or watching TV for 15 minutes. -- J.W.

jcubed 04-21-2004 10:49 AM

Thanks for responding, JW. Good question, but I'm afraid the cables are secure.

By hanging, I meant that I went upstairs after the installer wanted to reboot because it couldn't install one of the components (again, the bad sector issue?) and came down after dinner to discover the screen showing the table of what was found on the system (processor, drives, memory, etc.) typical of most PCs just before booting the OS. This was easily 30-45 minutes.

The detection process also gives a nifty little spinner (the old routine of -\|/ characters) during the process. It reported that it did not detect any hard drives. This was reflected n the table mentioned above, where the primary drive was assigned to one of the CD-ROMs.

All times are GMT -5. The time now is 03:43 AM.