LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   RH9 graphical login theme is corrupt (https://www.linuxquestions.org/questions/red-hat-31/rh9-graphical-login-theme-is-corrupt-149266/)

cremeglace 02-22-2004 05:01 PM

RH9 graphical login theme is corrupt
 
I've had red hat 9 installed on my computer for about a month now - it is my first linux experience. i use kde

anyway, out of the blue, I can't use the graphical login screen anymore
when i start linux, it starts everything smoothly, including X, but when i get to the graphical login, instead of the prompt for my username, there is a dialog box that says

"The theme for the graphical greeter is corrupt. It does not contain a definition for the username/password entry element"

along with the button "okay", but when i click "okay", nothing happens
from reading some of the posts, I've acquired the ability to press ctrl-alt-f1 at this point to log in on a text prompt
now my instinct at this point is to find some configuration file, edit a couple lines or something, but I'm not very familiar with where any configuration files are stored on linux, especially for this particular problem (not to mention the fact that growing up on windows has left me impotent at a text prompt)

I'm not sure why this problem has occurred all of a sudden. Possible reasons include:
1) I've recently been trying to install new software (glib, libjpeg, kmago), and some of the compilation from source hasn't been going very smoothly (although I could not imagine why that would affect the login screen)
2) I think at one point I changed the background image of the login screen, but that was a couple days ago and I've used the OS successfully since then

Here is the configuration of my computer, if it matters:
Dell Dimension L733r
Intel PIII 733Mhz, 320 MB RAM
Win2k/Red Hat 9 dual-boot, w/ RH on a partition of a second hard drive

So I can't get into my graphical environment, and I'm stumped. Any help on this matter is greatly appreciated

cremeglace 02-22-2004 06:04 PM

okay i think i have a clue to what's happening:

when i tried to run emacs at the command prompt (after not being able to get X running), I get this error:

"emacs: error while loading shared libraries libpng12.so.0: cannot open shared object file: no such file or directory"

i remember recently installing this rpm: libpng-1.2.5-4.i686.rpm
because i think i needed the png libraries for some application that I had been atttempting to install
but i think me installing them affected the existing installation of the libraries, which somehow in turn affected the login screen
in retrospect i'm not even sure if the rpm was intended for redhat

anyway, does anyone have an idea on how to go about fixing this?

cremeglace 02-22-2004 08:05 PM

Problem solved
 
it turns out i just forgot to run ldconfig after I upgraded those libraries, so none of the old paths were working

haha...I love how no one else has even posted in this thread yet

well the moral of the story is -- run ldconfig after installing new libraries


All times are GMT -5. The time now is 01:30 PM.