LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 11-25-2004, 07:32 AM   #16
urifrid
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0

thanks all for the answers

if you read my 1st post you can see that i know about the desktop part under nautilus on gconf. having said that, it;'s ok to say that i already tried alll the twicks and tricks that you people are posting. posts that i appreciate tons,. i already tried adding the desktop part, and other things, otherwise i wouldn't be asking here.

so, the question again, anyone knows how to delete the freaking default icons from the desktop? a simple question. needs a simple answer. no software intalll (like a new desktop manager) and no work around, a simple "do this and your icons are gone"

thanks
 
Old 11-25-2004, 03:59 PM   #17
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
What versions of nautilus and gconf are you using?
 
Old 11-26-2004, 01:03 AM   #18
urifrid
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0
nautilus 2.2.1
gconf-editor 0.4.0

standard with redhat 9 and enterprise 3
 
Old 11-26-2004, 05:05 AM   #19
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
Hmm, I think it may be time to upgrade. I have:-

Nautilus 2.6.0
Gconf-editor 2.6.1 (and hence gconf 2.6.1)

I don't think what is applicable to 2.6.1 will work with 0.4.0
 
Old 11-26-2004, 07:48 AM   #20
urifrid
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0
yeah, and...

i upgraded it, but nothing.

you know what, forget it, it seem, that it's not possbile. something as simple as deletting freeaking icon is turning into a pain in the ass thing, so whatever. aparently no one is reading what i am writing,


RED HAT 9 OR RED HAT ENTERPRISE 3, NO FEDORA

ANYONE KNOWS ABOUT THOSE SYSTEMS? OR NOT, IF NOT THEN PLEASE REFRAIN FROM POSTING;'
]
THANKS'\
 
Old 11-26-2004, 08:03 AM   #21
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 66
Please cool down!

We are just trying to help you. And YES, we're reading what you're writing. Please don't be rude. Good bye,

Yves.
 
Old 12-02-2004, 03:18 PM   #22
kungfuramone
LQ Newbie
 
Registered: Dec 2004
Distribution: Libranet (Debian)
Posts: 1

Rep: Reputation: 0
The suggestion from the first page of this thread works.

Like so:

1. cd /home/you/.gconf/apps/nautilus
2. mkdir desktop
3. touch %gconf.xml
4. Edit %gconf.xml and paste this in:

<?xml version="1.0"?>
<gconf>
<entry name="trash_icon_visible" mtime="1093328073" type="bool" value="false">
</entry>
<entry name="home_icon_visible" mtime="1093328071" type="bool" value="false">
</entry>
<entry name="computer_icon_visible" mtime="1093328070" type="bool" value="false">
</entry>
</gconf>

I had the exact same problem, running Libranet 2.8.1 w/ Gnome 2.6, and this fixed it. No icons = a much cleaner desktop.

Hope that helps.
-KFR
 
Old 12-08-2004, 08:26 PM   #23
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
I followed the directions re: making the desktop directory. When I went to edit the file %gconf.xml, it looked like this;

<?xml version="1.0"?>
<gconf>
<entry name="start-state" mtime="1102550378" type="list"ltype="string">
</entry>
<entry name="sound_state" mtime="1102549962" type="int" value="0">
</entry>
<entry name="preferences_version" mtime="1102471894" type="int" value="2">
</entry>
</gconf>

Is this the right file? If so do I delete every thing and paste the new data in? It doesn't say anything about icons so I wondered.

This is in gnome 2.8 that I just installed in mepis and I don't want to mess it up, which would be easy for me to do because I haven't a clue!

I would like to get the trash and computer icons off of the desktop but leave the home icon. If this is the right file, if I put in bool value true for the home icon will that leave it there?

I know that this is a Red Hat area of the forum, but I thought that maybe gnome is gnome all over.

Thanks, zoey

Last edited by ~zoey~; 12-08-2004 at 08:30 PM.
 
Old 12-09-2004, 12:59 AM   #24
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
If you paste this in just before the </gconf> it should do the trick:-
Code:
<entry name="trash_icon_visible" mtime="1093328073" type="bool" value="false">
</entry>
<entry name="computer_icon_visible" mtime="1093328070" type="bool" value="false">
</entry>
 
Old 12-09-2004, 09:13 AM   #25
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
OK, I followed your suggestion, but the icons are still there, big as life! I did a restart and they were still there.

Thanks, zoey
 
Old 12-09-2004, 10:16 AM   #26
ahh
Member
 
Registered: May 2004
Location: UK
Distribution: Gentoo
Posts: 293

Rep: Reputation: 31
I'm afraid I haven't had to troubleshoot this as it worked for me with no problems.

Just two things, make sure you have the latest GConf, and maybe
Code:
<entry name="trash_icon_visible" mtime="1093328073" type="bool" value="false">
</entry>
<entry name="home_icon_visible" mtime="1093328071" type="bool" value="true">
</entry>
<entry name="computer_icon_visible" mtime="1093328070" type="bool" value="false">
</entry>
would work. Who knows, maybe it needs all three icons...

Another point is that maybe the mtime is not the same for everyone, whatever mtime is. I've no idea how you would find out though, short of scouring the web (or asking here, maybe).

Finally, maybe there is a preference somewhere to stop local gconf files from overriding the default desktop.

Sorry I'm not more help.

Last edited by ahh; 12-09-2004 at 10:18 AM.
 
Old 12-09-2004, 10:47 AM   #27
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by urifrid
thanks all for the answers

so, the question again, anyone knows how to delete the freaking default icons from the desktop? a simple question. needs a simple answer. no software intalll (like a new desktop manager) and no work around, a simple "do this and your icons are gone"

thanks
Why not just do away with Gnome and use IceWM, Blackbox, Fluxbox, or some other minimal window manager? You can have ZERO visible on the "desktop" with minimal window managers, system performance is faster, and NO ICONS.

I got tired of icons when I was still using Windows. I use IceWM or Blackbox and am quite happy with my "bare" desktop.

If this isn't a straightforward answer, I guess I don't understand the question yet.
 
Old 12-09-2004, 11:51 AM   #28
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
I think that you understand the question just fine, Jon Rutherford!

But I am a 'gnome person' who has a lot to learn.

I found a file /home/me/.nautilus/metafiles/x-nautilus-desktop:%2%2%2f.xml, that lists the 3 desktop files. Could this be the file that I need to edit?

Thanks, zoey
 
Old 12-30-2004, 07:24 PM   #29
KPOM
LQ Newbie
 
Registered: Feb 2004
Location: Milwaukee
Distribution: Slackware 10.2, FreeBSD 5.4, LFS 6.1
Posts: 16

Rep: Reputation: 0
This is an older post, but having the same problem, it came up when I was searching.

Turns out I've found a solution on my own, though.

While it seems impossible to simply erase the icons, a good alternative is to edit the x-nautilus-desktop:%2F%2F%2F.xml file located in /.nautilus/metafiles/.

Simply change the icon_position="$x,$y" line on all 3 of the default icons. Change them to something obscenely out of range, but not on top of each other. For example, I set mine to 1400,1500 for trash, 1500,1600 for computer, etc.

They're still technically there, but out of sight is out of mind.
 
Old 12-30-2004, 10:13 PM   #30
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
Thanks. I have discovered that all I needed to do was type gconf-editor in the terminal window then go to apps>nautilus>desktop and uncheck the boxes by the icons that I wanted removed. That works in mepis/gnome. I haven't tried it in mepis/kde. I added gnome to mepis as it comes with kde.

zoey
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
remove icons from gnome desktop? ssfrstlstnm Linux - General 3 11-25-2005 08:37 AM
Desktop icons of file systems - remove/rename? lefty.crupps MEPIS 2 06-06-2005 08:36 PM
Cannot remove desktop icons in KDE will103 Debian 2 01-02-2005 04:14 AM
How do I remove the icons off of gnome desktop? javaarmy Linux - General 4 03-05-2004 04:52 PM
How do I remove these icons from my desktop? Iguana Linux - General 1 10-05-2003 01:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 12:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration