LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   relocation error:symbol_dl_loaded version GLIBC_2.1 not defined in file ld-linux.so.2 (https://www.linuxquestions.org/questions/red-hat-31/relocation-error-symbol_dl_loaded-version-glibc_2-1-not-defined-in-file-ld-linux-so-2-a-650675/)

chettyravi 06-21-2008 01:26 AM

relocation error:symbol_dl_loaded version GLIBC_2.1 not defined in file ld-linux.so.2
 
Hello everyone,

I am new to this forum and new to linux too.

Please help me out in resolving a problem which i am facing when i ran software tool on redhat 9.0.

when i try to software tool in gui mode i got the following problem.

"relocation error:tool: symbol_dl_loaded version GLIBC_2.1 not defined in file ld_linux.so.2 with link .time reference"

i analysed this problem its related to glibc,
tool will support glibc_2.1(redhat 7.2) the current glibc will be redhat 9.0 glibc.

kindly suggest me on this problem.

Thanks in advance,

Ravi.

lazlow 06-21-2008 02:28 PM

Chettyravi

You do realize that support for RH9 was dropped in 2004? If money is the issue, Centos is free to download and update. Centos is RHEL(Red Hat Enterprise Linux) with the logos removed. The current version is 5.1.


Since RH9 is so old I do not know if it will apply but current versions have compatlibs that allow them to recompile software written for ealier versions. As a general rule most software has to be compiled to run on a specific gcc version, so most RH7 software will probably have to be recompiled to run on RH9.


All times are GMT -5. The time now is 04:40 PM.