LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Red Hat (http://www.linuxquestions.org/questions/forumdisplay.php?f=31)
-   -   Release 6.2 Printer Config crashes (http://www.linuxquestions.org/questions/showthread.php?t=4175444079)

ehedman 01-03-2013 11:23 PM

Release 6.2 Printer Config crashes
 
I've been setting up a server with Redhat Enterprise release 6.2. Everything works except when from the desktop I try going into the Printer Configuration program. It crashes. I tried opening it from the command line using strace. The First time I tried it launched the printer configuration program and I was able to set up one network printer. Every subsequent time it crashes again.

I have been running the program from the command line with the following:

strace -ffttTvo printer.log system-config-printer

In the strace log file generated I keep getting the following errors:

10:23:37.004467 stat("/usr/lib64/python2.6/copy_reg", 0x7fff377b1aa0) = -1 ENOENT (No such file or directory) <0.000020>
10:23:37.004543 open("/usr/lib64/python2.6/copy_reg.so", O_RDONLY) = -1 ENOENT (No such file or directory) <0.000018>
10:23:37.004616 open("/usr/lib64/python2.6/copy_regmodule.so", O_RDONLY) = -1 ENOENT (No such file or directory) <0.000016>
10:23:37.004685 open("/usr/lib64/python2.6/copy_reg.py", O_RDONLY) = 5 <0.000017>
10:23:37.004752 fstat(5, {st_dev=makedev(253, 0),


the "/usr/lib64/python2.6" directory exists and has many files in it, just not the ones listed in the error messages above.

I didn't know the printer config program used python. Do I need to install a new version of python? When I set up the server I installed just about every option from the Redhat DVD. Any suggestions?

John VV 01-04-2013 11:04 PM

update from the RHN repo ?

Code:

su -
yum update

the 6.2 dvd is a bit "out of date"

yum MUST have installed the matching version of python that is in the current update repo
and most of the gnome utilities also must have it installed

a mismatch will result in things not working

ehedman 01-11-2013 04:53 PM

I tried the yum update as suggested. It said everything on the system was up to date. So then I tried using CUPS to configure printing. It would find the printers and I could print test pages to them. When printing from programs on the system only an occasional report would get through. Error message windows would flash open for a few seconds on the console with a message about something crashing. After one of these crash messages through CUPS I would have to delete and re-add the printer to get it to work again even to print a test page. Everything else on this server works beautifully.

hon lancelot 02-06-2013 12:02 AM

Parallel printer on fedora 15
 
Hi Team.
I have install my computer on Fedora 15.I have a thermal printer that has got parallel port only. Once i add a printer i have to run this command "MAKEDEV /dev/lp" so that i can add lpt port connection on my computer so that i can install the printer. But once i restart the computer, am loosing or fedora is deleting the lpt port connection hence the printer that i have installed cant printer. How can i rectify this so that the printer shall always printer.

Kind request Team.

John VV 02-06-2013 12:08 AM

Hi " hon lancelot" please start a new thread and not hijack a RHEL6 thread for a "past END OF LIFE " version of fedora, fedora 15

see the End of life section on Fedoraforum.org
http://www.forums.fedoraforum.org/forumdisplay.php?f=75

The current version is fedora 18
And ONLY fedora 17 and 18 are currently supported

ehedman 02-15-2013 08:31 PM

I found a couple of step workaround for this problem. I installed Python 2.7.3 which triggered another problem. The server has an Informix database engine that when installed used Python 2.6 and a soft link in the /usr/bin/ directory to the Python-2-7-3 directory. That prevented the database engine from starting up. Redirecting the soft link back to the Python 2.6 directory fixed that problem. Python 2.7.3 allowed Cups printing to work. It never fixed the issue with system-config-printer. So the system can print now, but not using the printer administration on the desktop menu.

John VV 02-15-2013 11:14 PM

rhel needs the version of python that is in the update( or base RHN ) repo
-- it is a MUST USE --

yum and gnome both require that very specific version .
If a different version is installed "on top" of the required version yum and some of Gnome will not work !

Now you can install a second version of python next to the needed one
say in /opt/python2.7.3 or /lib64/python2.7.3

from your first post
Quote:

I didn't know the printer config program used python.
that is one of the things in gnome that WILL break from using a different version of python than is in the RHN repo

you might want to contact red hat tech support
they can point you to the needed rpms to reinstall the required version of python

i am betting you will get a error if you try this
Code:

su -
yum update

a long output of python errors

chrism01 02-16-2013 08:31 AM

Quote:

I tried the yum update as suggested. It said everything on the system was up to date.
Can I just clarify? Did it say it was already up to date, or it was up to date after running yum AND doing updates.
I ask, because RHEL6.3(!) has been out for a while.
FYI, on my 6.3 system, I get
Code:

rpm -qa |grep -i cup

cups-libs-1.4.2-48.el6_3.3.x86_64
gutenprint-cups-5.2.5-2.el6.x86_64
cups-1.4.2-48.el6_3.3.x86_64
cups-pk-helper-0.0.4-12.el6.x86_64



All times are GMT -5. The time now is 02:57 PM.