LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 03-02-2004, 04:40 PM   #1
fatbaldbob
LQ Newbie
 
Registered: Jan 2003
Posts: 25

Rep: Reputation: 15
Redhat 7.3 PHP 4.3.4 "upgrade" not compiling


OK, I have been at this for days now and I need help!

I have a Redhat 7.3 server (fully up2date) running Apache 1.3.23, PHP 4.1.2 & MySQL 3.23.58.

I have been trying to "upgrade" to PHP 4.3.4, but when I run ./configure with all my options I get the following:

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...

Sorry, I was not able to successfully run APXS. Possible reasons:

1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /etc/httpd/bin/apxs follows
apxs:Error: Sorry, no DSO support for Apache available
apxs:Error: under your platform. Make sure the Apache
apxs:Error: module mod-so is compiled into your server
apxs:Error: binary '/etc/httpd/bin/httpd'.
configure: error: Aborting

As far as I can tell (using phpinfo) Apache has got DSO support, apxs IS in my path, and I have Perl 5.6.1 installed (although I'm not sure how to check this - I have a /usr/lib/perl5/5.6.1/ directory.... )

Has anyone any idea how I can install PHP 4.3.4...can I just re-compile Apache, and if so can I upgrade to Apache 1.3.29 at the same time? (without losing all my Apache setup?)

Apologies for all the questions, but I really need to get this working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use synaptic "smart upgrade or "apt-get dist-upgrade" PenguinMolester Ubuntu 2 04-04-2005 02:11 PM
Compiling Drivers for a www.startech.com "UE1205CB" PCMCIA NIC in RedHat 9 vipernicus42 Linux - Newbie 1 01-31-2005 09:20 PM
When "function pointer" meets "template"... I can't get rid of this compiling er cyu021 Linux - Software 3 12-17-2004 07:52 PM
"Compiling c prog using gcc in PHP" manikantha Programming 4 09-24-2004 04:05 AM
Php or Mysql upgrade on Fedora Core 2 "Uptodate" Program geninblaze Fedora 1 07-12-2004 09:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration