LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   Red Hat does not open when installed on 2 hard disks (https://www.linuxquestions.org/questions/red-hat-31/red-hat-does-not-open-when-installed-on-2-hard-disks-329896/)

rajivb 06-03-2005 08:50 AM

Red Hat does not open when installed on 2 hard disks
 
when i installed Red Hat 9 on my 2 hard disks seperately ( Samsung 40GB and 80GB) and put 40GB one as master and other as slave,linux says read only file system. It does not open. It comes till 'opening system log ...' and does not move further. When the installations are opened when run with only 1 HDD(any one of 2) on system , both work fine.
please tell me what to do?

bramhastra 06-06-2005 05:36 AM

does that work the other way round means 80Gb as master and 40 Gb slave

rajivb 06-06-2005 02:00 PM

no did not try that. i'll give it a try.
thanx bramhastra.
by the way where in india r u from?
i'm from vijayawada, ap.

bramhastra 06-07-2005 04:22 AM

I am from Bokaro Steel City. Well have you tried it yet

rajivb 06-07-2005 09:23 AM

yes i tried it. i put 80GB as master and 40GB as slave. It works but what i observed is that not matter from which hard disk i boot , it always boots the linux partition from 80 GB hard disk only (when 80GB is the master).

So it means that my 40 GB installation has some problem and the linux boots only from master disk partitions only no matter from which hard disk partition u boot. Am I right bramhastra?

bramhastra 06-07-2005 09:28 AM

Have you checked out for the jumper settings
Booting only from the 80 Gb as masters gives this point only

rajivb 06-09-2005 09:46 AM

yes that was what i did. I put the master jumper settings for 80GB and none for 40GB. The above result was what i got (post #5).

actually my first post has the opposite settings i.e. 40GB as master jumper and 80GB none.
So what do u think about it?

i want it to be 40 GB master and 80GB slave. That's how i work with it because 80GB is a newer HDD and i use it as store for my info and 40GB as working drive(editing, deleting, running or anyother processor work).

bramhastra 06-09-2005 09:50 AM

so it would be better not to install Red Hat on 80 Gb but let it be plain then boot with 40 gb see it detects or not. It should be detected then use the fdisk command utility to expand the space you need for storage

rajivb 06-09-2005 10:12 AM

but i have installed red hat on 40GB first even before i bought my 80GB. i installed redhat on 80GB seperately and joined both 40 as master and 80 as slave.

problem is that redhat is detected if i boot from 40GB as master but it says read only file system and also i got this message , 5 min. after it booted. It says
"I could not start X server (your graphical environment) due to some internal error.Please contact your system adminstrator or check your syslog to diagnose. In the meantime this is disabled.Please restart gdm when "
OK

there is noscrolling provided to read the complete message. This appeared after some time after system log started.

bramhastra 06-09-2005 10:16 AM

fine I got ur point but still i wuld suggest u to make the 80 Gb disk blank and then use the procedure i suggested you in the above mentioned post.

Just try and see if it works.

rajivb 06-09-2005 10:36 AM

thanks for that help and for changing my status as member.

this is my OS structure. so please suggest what should i do.
40GB
-------
windows 98SE
windows 2000 professional
redhat linux 9 (one that's troubling presently)

80GB
------
windows 98SE
redhat linux 9 (this is working fine even internet is connecting)

one more question
what if in future my 40GB installation starts troubling ? then how do i backup my data into the other HDD without/with an redhat installation

bramhastra 06-09-2005 10:45 AM

Ok one more thing can you boot them in master and slave configuration using win2000(same 40Gb master and 80 Gb slave).

If yes then it is a problem with your Red Hat Installation.
Your Red Hat is not accepting a combination where u have a larger slave drive.
By the way what is the result of fdisk -l command when 40 Gb is the master.

rajivb 06-09-2005 10:49 AM

i have booted in same config. and presently working in win98 . And i am talking to u from win98.
can u tell me how to go into command prompt mode into linux without booting into linux?

bramhastra 06-09-2005 10:58 AM

for such kind of dual boot u need vmware on your machine.
Without booting in linux its not possible to open command prompt of linux. Vmware does a dual boot in your windows machine only.

Well i wuld suggest you not to go with such configuration. Uptill dual boot is ok but a triple boot with a dual boot will lead to a conflict wit both windows and linux running.

Well I wuld say that try reinstalling the linux and if again you are stuck with error then better make it a dual boot

rajivb 06-09-2005 11:10 AM

sorry but i was a little bit confused.
i meant that i want to go to linux command prompt from starting, not from windows.

and about linux installation, if i install linux now would i face problems with windows OSs in case of boot menu

i don't want to change the current installations of windows OSs on both the drives.
It will take me a very long time to get into normal position if i do that


All times are GMT -5. The time now is 04:02 AM.