-   Red Hat (
-   -   RAID 0 Filesystem checking? (

kennic 11-10-2004 10:43 PM

RAID 0 Filesystem checking?
osĄGRed Hat Enterpris Linux ES release 3

i combined two harddisk to RAID 0 and format it to ext 3.
Then add the line "/dev/md0 /new ext3 defaults 1 1" into fstab.
No error occurred after run " mount -a". Everyting oK.

reboot system

When the filesystem check, error occur.

checking filesystems
fsck.ext3: /dev/md0:
The superblock could not be read or does not describe a
correct ext2 filesystem.
If the device is valid and it really contains an ext 2 filesystem
( and not swap or ufs or something else),
then the superblock is corrupt, and you might try running
e2fsck with an alternate superblock: e2fsck -b 8193 <device>

Invalid argument while trying to open /dev/md0

How can i do to fix it?

Finlay 11-11-2004 07:32 PM

set it to not be checked by fsck at startup

kennic 11-12-2004 02:27 AM

set it to not be checked at startup
-"/dev/md0 /new ext3 defaults 0 0" into fstab.


mount: wrong fs type, bad option, bad superblock on /dev/md0,
      or too many mounted file systems
      (could this be the IDE device where you in fact use
      ide-scsi so that sr0 or sda or so is needed?)

Show about error but i can enter linux.
it can't mount md0 (raid drive).

On the other side,
"raidstart /dev/md0"
"mount -t ext3 /dev/md0 /new"
md0 can be used!!


All times are GMT -5. The time now is 01:15 AM.